Bug 1616318 - 2 dashboard icons exist
Summary: 2 dashboard icons exist
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.3.0
: ---
Assignee: Greg Sheremeta
QA Contact: Pavel Novotny
URL:
Whiteboard:
: 1619254 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-15 15:09 UTC by Raz Tamir
Modified: 2019-02-13 07:48 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-13 07:48:05 UTC
oVirt Team: UX
rule-engine: ovirt-4.3+
rule-engine: blocker+


Attachments (Terms of Use)
screenshot (18.17 KB, image/png)
2018-08-15 15:09 UTC, Raz Tamir
no flags Details
logs (772.60 KB, application/x-gzip)
2018-08-16 14:24 UTC, Elad
no flags Details
Dashboard icon - fixed (27.84 KB, image/png)
2018-11-06 11:47 UTC, Pavel Novotny
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 92698 0 None None None 2018-08-24 18:12:04 UTC

Description Raz Tamir 2018-08-15 15:09:46 UTC
Created attachment 1476178 [details]
screenshot

Description of problem:
There are 2 dashboard icons in the left pane (screenshot attahced)


Version-Release number of selected component (if applicable):
4.3.0-0.0.master.20180814113734.gitad81cd3.el7

How reproducible:
100%

Steps to Reproduce:
1. Open oVirt
2.
3.

Actual results:
2 dashboard icons exist

Expected results:
there should be 1 icon

Additional info:

Comment 1 Greg Sheremeta 2018-08-15 18:06:58 UTC
Did you install from rpm or is this one of our test environments that a developer was messing with?

Comment 5 Elad 2018-08-16 14:24:52 UTC
Created attachment 1476432 [details]
logs

ovirt-engine-webadmin-portal-4.3.0-0.0.master.20180815091554.gitd5455ea.el7.noarch

Comment 6 Greg Sheremeta 2018-08-21 13:55:33 UTC
*** Bug 1619254 has been marked as a duplicate of this bug. ***

Comment 7 Michael Burman 2018-08-21 14:03:06 UTC
I see the same bug 
[root@network-ge-3-he ~]# rpm -qa ovirt-engine-ui-extensions
ovirt-engine-ui-extensions-1.0.0-1.el7.noarch
[root@network-ge-3-he ~]# rpm -qa ovirt-engine-dashboard
ovirt-engine-dashboard-1.2.1-1.el7.centos.noarch
[root@network-ge-3-he ~]# rpm -q ovirt-engine
ovirt-engine-4.3.0-0.0.master.20180819104048.git932969e.el7.noarch

This was built from scratch and no one has messed up with this setup.

Comment 8 Greg Sheremeta 2018-08-21 14:05:39 UTC
Thanks. The problem is both ovirt-engine-ui-extensions and ovirt-engine-dashboard are installed. They both contain dashboard.

ovirt-engine-dashboard will be removed soon.

Comment 9 Red Hat Bugzilla Rules Engine 2018-08-22 12:33:41 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 10 Red Hat Bugzilla Rules Engine 2018-08-22 14:42:59 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 11 Scott Dickerson 2018-08-24 13:34:30 UTC
This will be fixed by https://gerrit.ovirt.org/#/c/92698/

Comment 12 Pavel Novotny 2018-11-06 11:46:34 UTC
Verified upstream in
ovirt-engine-4.3.0-0.0.master.20181101091940.git61310aa.el7.noarch
ovirt-engine-webadmin-portal-4.3.0-0.0.master.20181101091940.git61310aa.el7.noarch
ovirt-engine-ui-extensions-1.0.1-0.el7.noarch

After a clean installation of ovirt-engine, only ovirt-engine-ui-extensions package is installed and only one Dashboard icon is present in the vertical menu.
ovirt-engine-dashboard is present in the repository, but not installed:

# yum list ovirt-engine{,-webadmin-portal,-dashboard,-ui-extensions}
Loaded plugins: product-id, search-disabled-repos, versionlock
Installed Packages
ovirt-engine.noarch                                                       4.3.0-0.0.master.20181101091940.git61310aa.el7                                        @ovirt-master-snapshot
ovirt-engine-ui-extensions.noarch                                         1.0.1-0.el7                                                                           @ovirt-master-snapshot
ovirt-engine-webadmin-portal.noarch                                       4.3.0-0.0.master.20181101091940.git61310aa.el7                                        @ovirt-master-snapshot
Available Packages
ovirt-engine-dashboard.noarch                                             1.2.1-1.el7.centos                                                                    ovirt-master-snapshot

Comment 13 Pavel Novotny 2018-11-06 11:47:11 UTC
Created attachment 1502414 [details]
Dashboard icon - fixed

Comment 15 Sandro Bonazzola 2019-02-13 07:48:05 UTC
This bugzilla is included in oVirt 4.3.0 release, published on February 4th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.