Bug 161665 - After starting Eclipse Fedora 4 is hanging forever
After starting Eclipse Fedora 4 is hanging forever
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-25 04:24 EDT by Wolfgang Raith
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-20 14:14:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Raith 2005-06-25 04:24:53 EDT
Description of problem:
At the end of the eclipse startup the ide is suddenly frozen and Fedora seems to
be hang. 

Version-Release number of selected component (if applicable):
Fedora 4 with all standard upgrades. Eclipse 3.1 

How reproducible:
Simply start Eclipse 


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Wolfgang Raith 2005-06-25 04:29:21 EDT
By the way. I tested eclipse of the Fedora 4 distribution and eclipse 3.1 taken
from www.eclipse.org. Both results in a hanging system.
On the other hand I tested eclipse 3.1 also on SuSE 9.1 on the same computer.
There the problem did not happen. 
Comment 2 Andrew Overholt 2005-06-27 14:11:26 EDT
Were you running Eclipse as root?  If so, this is most likely a duplicate of:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=152386
Comment 3 Andrew Overholt 2005-09-21 10:34:14 EDT
Any news here?
Comment 4 Andrea Caltroni 2005-10-19 05:39:50 EDT
I was using Eclipse v3.1 on Fedora core 1 and had no problem.
When I switched to Fedora core 4:

- Eclipse v3.1 is working but has some problems (selection highlighting does not
work)

- Eclipse v3.1.1 both the source recompiled with JDK 1.5 and the binary
distribution eclipse-SDK-3.1.1-linux-gtk.tar.gz do not work
1. in a new workspace:
-----
Unable to read workbench state.Workbench UI layout will be reset
-----
and then I have very few menu items enabled.

2. in a workspace with Eclipse projects, I do not have the previous error, but
when I try to open one project, I get:

Errors during build.
  Error instantiating builder: org.eclipse.jdt.core.javabuilder.
    Plug-in org.eclipse.jdt.core was unable to load class
org.eclipse.jdt.internal.core.builder.JavaBuilder.
  Plug-in org.eclipse.jdt.core was unable to load class
org.eclipse.jdt.internal.core.builder.JavaBuilder.
Comment 5 Andrea Caltroni 2005-10-19 05:49:00 EDT
I'm already back with an update:
If I try this with Eclipse 3.1.1:

<ECLIPSE_HOME>/eclipse -vm <JAVA_HOME>/jre/bin/java

and JDK v1.5.0_04, I do not have the problems of my previous post.
Comment 6 Andrew Overholt 2005-10-20 11:34:30 EDT
So we can close this bug, right?
Comment 7 Wolfgang Raith 2005-10-20 14:14:23 EDT
nsb-install-8-0.exe

YES, of course you can close the bug.

Thank you very much for your effort
Wolfgang Raith 

Note You need to log in before you can comment on or make changes to this bug.