Bug 161684 - Some File permissions not being correctly handled by samba
Some File permissions not being correctly handled by samba
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Simo Sorce
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-25 12:55 EDT by Phill O'Flynn
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 10:33:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phill O'Flynn 2005-06-25 12:55:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I upgraded from fc3 to fc4. 

Background:
I have my user document files on a separate disk so that if something screws up under an install or upgrade then it is easier to recover the files. In this case, the upgrade was a fresh install to a new hard drive so all other data could remain unaffected. On installation, I then tell the system where the old home directories are so it becomes "/home" under the new install. Unfortunately this buggers everything up when i re-install existing users. So, i have to temporarily rename the home directories an manually copy the files across to the new ones that are created as the users are added. I don't like to just upgrade as bugs may exist in the new os your stuffed and can't rollback. (NB there has got to be an easier way)

In my case, the new and old UID's were different though the names were the same; ie user "phill" had a UID 501 in fc3 and under fc4 it was 500. In the first instance, the file/group owner name of each file and directory came up in fc4 as he old id ie 501 not phill. So i consequently renamed everything to "phill" 

Finally the problem:
If i copy the directories across to the new user home and share them using samba 
I keep getting a "network path not found" error - no matter what i did with file names and permissions. However, creating a new folder and making it a share worked perfectly.

The next step i took was to move a subfolder across to the new created share but was invisible under samba (btw win xp sp2 client). The only way i could make the sub-folder visible was to copy it to a new folder share.

This was pretty consistent as i tested it. However, i am not sure if it is a bug or some silly thing with my setup.

appolgies about the wordiness, hopefully it makes sense


Version-Release number of selected component (if applicable):
latest as of 26/6/05

How reproducible:
Always

Steps to Reproduce:
see above
  

Actual Results:  the files became visible under samba

Expected Results:  the files/directories should have become accessible after changing ownership

Additional info:
Comment 1 Phill O'Flynn 2005-06-25 22:02:52 EDT
i have managed to get access to the home directory but i cannot access other
network drives. For example i have a HD setup to store backup files and is
mounted under /backup. Under linux access ok. Under samba it is inaccesiible.
not even a link in my home directory will allow me to access the the backup drive

phill
Comment 2 Phill O'Flynn 2005-06-26 06:37:54 EDT
The problem is solve by disabling selinux for samba

setsebool -P smbd_disable_trans 1 

but it is still a bug that needs to be resolved rather than worked around

Phill
Comment 3 Joel Peterson 2005-06-30 02:27:28 EDT
Thanks Phill! I can use Samba again now!
Comment 4 Jim 2006-01-29 11:16:06 EST
I am seeing the same issue.
Comment 5 Christian Iseli 2007-01-19 19:40:18 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 6 Phill O'Flynn 2007-01-20 00:22:25 EST
Not sure how to do that.

I have not upgraded fedora yet. so i don't know if it is an issue or not

But it can be closed if necessary
Comment 7 Simo Sorce 2007-03-14 10:33:05 EDT
This kind of bug should be fixed in FC6, reopen it if not.

Note You need to log in before you can comment on or make changes to this bug.