Bug 161712 - Suspend Mode "acpi_sleep=s3_bios" broken on IBM Thinkpad T43 (1.86 Ghz)
Suspend Mode "acpi_sleep=s3_bios" broken on IBM Thinkpad T43 (1.86 Ghz)
Status: CLOSED DUPLICATE of bug 169201
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-06-26 07:40 EDT by Anderson Silva
Modified: 2015-01-04 17:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-05 01:49:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anderson Silva 2005-06-26 07:40:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686; en) Opera 8.01

Description of problem:
The laptop goes into suspend mode, and it tries to come come back up again 
(using acpid to initiate action via LID closing). The contents saved on RAM are 
restored, but the HD never stops spinning... I can pull down gnome menus, but 
can't run any application.

Version-Release number of selected component (if applicable):
echo -n mem >/sys/power/state 

How reproducible:
Always

Steps to Reproduce:
1.Setup an event on acpid for lid that call the shell script on step 2
2.Setup an action for suspend ... mine:

#!/bin/sh

echo -n mem >/sys/power/state
/sbin/hwclock --hctosys


3. Close lid
  

Actual Results:  What was described on Description

Expected Results:  I had a T42, and suspend mode worked 99% of the time, only once in a while the 
unsuspend would freeze up.

Additional info:
Comment 1 Dave Jones 2005-07-15 17:36:45 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 2 Anderson Silva 2005-07-15 18:36:01 EDT
I am not able to retest this right now, since I went back to my T42 and now I am running RHEL4. I 
will see if any of my co-workers is running it though.
Comment 3 Rodrigo Curado 2005-08-02 18:06:34 EDT
Hi,

I've experienced the same problem. I've got a new T43 and after return from
sleep mode the HD seams to keep always running (at least the LED has a constant
green light).

After I try to do something that should access the HD it freezes and keep
logging to console this message:

ata1: command 0xca timeout, stat 0xd0 host_stat 0x1
ata1: status=0xd0 { Busy }
end_request: I/O error, dev sda, sector 56681019
ATA: abnormal status 0xD0 on port 0x1F7
ATA: abnormal status 0xD0 on port 0x1F7
ATA: abnormal status 0xD0 on port 0x1F7

The sector number is changing.

The only action I do from the sleep.sh (on /etc/acpi/action) is to

echo -n "mem" >/sys/power/state
Comment 4 redhat-bugs2eran 2005-09-17 11:59:24 EDT
I had the same problem with vanilla 2.6.12.3 and a ThinkPad T43. The problem is
lack of kernel support for SATA suspend/resume. 

There are patches at http://www.thinkwiki.org/wiki/How_to_make_ACPI_work (see
the bottom of the "Suspend to RAM (Sleep)" section). These patches, applied to
vanilla 2.6.13.1+swsusp2, fixed the problem for me.
Comment 5 redhat-bugs2eran 2005-09-26 08:58:20 EDT
The problem persists in vanilla 2.6.14-rc2, and the corresponding patch is at 
http://lkml.org/lkml/2005/9/23/97 .
Comment 6 Dave Jones 2005-09-30 02:56:39 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 7 redhat-bugs2eran 2005-10-01 11:39:48 EDT
Still broken in 2.6.13-1.1526_FC4 .
Comment 8 redhat-bugs2eran 2005-10-01 11:44:39 EDT
To clarify: on the ThinkPad T43, by default 2.6.13-1.1526_FC4 uses the IDE
driver to handle the disk (making it /dev/hda) so resume works because the SATA
system is not involved. But if I add "hda=noprobe" then the SATA system takes
over like in previous kernel (and the disk is /dev/sda as before), and in this
case resume is broken.
Comment 9 Dave Jones 2005-11-05 01:49:04 EST

*** This bug has been marked as a duplicate of 169201 ***

Note You need to log in before you can comment on or make changes to this bug.