Bug 1617978 - Previous character always get deleted
Summary: Previous character always get deleted
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-sayura
Version: 28
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-16 10:14 UTC by Danishka Navin
Modified: 2018-09-18 08:49 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-18 08:49:16 UTC


Attachments (Terms of Use)
Screen capture of issue with ibus (1012.78 KB, application/octet-stream)
2018-08-17 09:07 UTC, Danishka Navin
no flags Details

Description Danishka Navin 2018-08-16 10:14:19 UTC
Description of problem:

When we use ibus-sayura, it always delete the previous character expect the starting character of the sentence.

Version-Release number of selected component (if applicable):

Fedora 28 x86_64

How reproducible:


Steps to Reproduce:
1. Start LibreOffice 6.0 or gedit 
2. Switch to Sayura imput method
3. Type keys 'DnisHwk ' 
(space to start next word but now space also delete the previous key due to this issue)

Actual results:
ඩඉහ්

Expected results:
ඩනිෂ්ක 
This is how I write my own name 'Danishka' in Sinhala.

This issue causing major problem to all government and pirate organizations as well as individuals who use Fedora as they can't type Sinhala at all.



Additional info:
Seems the same issue can be reproducible with wijesekara input method.
I will add few users who use Wijesekara input method.

Comment 1 Lohan G 2018-08-16 12:27:52 UTC
I am experiencing the same problem while using Wijesekara keyboard layout. So this seems to be related to ibus-m17n as well. This happens on emacs, gedit and LibreOffice.

Fedora version : 28

Steps to reproduce:
1. Start Gedit
2. Switch to Sinhala (wijesekara keyboard layout)
3. Type keys vksIal kjSka
4. Hit space to separate it from the next word. 

This adds a space to the last character of the first word, and deletes it when you start typing the second word:

Example 1:
Expected result
ඩනිෂ්ක නවීන් (vksIal kjSka) 

Actual result
ඩිෂ් නීන් (vsIa kSka)

Example 2 (single word)
Expected result
ඩනිෂ්ක (vksIal)

Actual result
ඩිෂ් ක (vsIa l)

Comment 2 Parag Nemade 2018-08-16 12:41:51 UTC
Please provide more information. I understood what to type and can get to type the words. I typed those 2 words but now at where/what position you are using delete key?

Comment 3 Danishka Navin 2018-08-16 12:49:52 UTC
HI Parag,

Thanks for your prompt reply here.

When I use ibus-sayura, I use thse keys DnisHwk.
ඩනඉෂවක this is the actual (individual characters I get if I type them with a delay to understand the issue)

01. When I type D I get ඩ 
02. then n - I get character න => ඩන appearing in the UI.
03. then i - I get the character ඉ but it delete the previous character 'න' and endedup with ඩඉ 

I was using LibreOffice 6.0 with ibus-sayura.

Comment 4 Lohan G 2018-08-16 14:28:55 UTC
Delete key was not used during the entire process.

Comment 5 Parag Nemade 2018-08-17 08:40:34 UTC
I am not understanding what is happening at your side but I did test Sayura and Wijesekara input methods and both are working fine for me. e.g.
If I type in Libreoffice Writer using Sayura "Dni " continuously I got ඩනි. I have not used Delete key here.

I have these packages
$ rpm -qa m17n-db m17n-lib ibus-m17n harfbuzz pango libreoffice-writer 
harfbuzz-1.7.5-3.fc28.x86_64
m17n-lib-1.8.0-1.fc28.x86_64
m17n-db-1.8.0-3.fc28.noarch
libreoffice-writer-6.0.6.1-5.fc28.x86_64
ibus-m17n-1.3.4-26.fc28.x86_64
pango-1.42.3-1.fc28.x86_64

Comment 6 Danishka Navin 2018-08-17 09:07:04 UTC
Created attachment 1476586 [details]
Screen capture of issue with ibus

Comment 7 Danishka Navin 2018-08-17 09:09:03 UTC
My system have been upgraded from Fedora 27 to Fedora 28.

[danishka@hanthana ~]$ rpm -qa m17n-db m17n-lib ibus-m17n ibus-sayura harfbuzz pango libreoffice-writer 
harfbuzz-1.7.5-3.fc28.i686
m17n-lib-1.8.0-1.fc28.x86_64
libreoffice-writer-6.0.4.2-2.fc28.x86_64
ibus-m17n-1.3.4-25.fc28.x86_64
ibus-sayura-1.3.2-13.fc28.x86_64
m17n-db-1.8.0-3.fc28.noarch
pango-1.42.1-2.fc28.i686
pango-1.42.1-2.fc28.x86_64
harfbuzz-1.7.5-3.fc28.x86_64

I noticed that I was using old version of Pango compared to Parag's system.

I did updated pango but no luck.

[danishka@hanthana ~]$ rpm -qa m17n-db m17n-lib ibus-m17n ibus-sayura harfbuzz pango libreoffice-writer 
harfbuzz-1.7.5-3.fc28.i686
m17n-lib-1.8.0-1.fc28.x86_64
libreoffice-writer-6.0.4.2-2.fc28.x86_64
ibus-m17n-1.3.4-25.fc28.x86_64
ibus-sayura-1.3.2-13.fc28.x86_64
pango-1.42.3-1.fc28.x86_64
m17n-db-1.8.0-3.fc28.noarch
pango-1.42.3-1.fc28.i686
harfbuzz-1.7.5-3.fc28.x86_64

Comment 8 Pravin Satpute 2018-08-17 09:25:23 UTC
I was also able to reproduce this issue but after upgrading system and restarting does not reproduce this issue.

@Danishka please update your system, restart and try again. I see below packages are still not updated at your end.

1. libreoffice-writer-6.0.6.1-5.fc28.x86_64 ->    libreoffice-writer-6.0.4.2-2.fc28.x86_64
2. ibus-m17n-1.3.4-26.fc28.x86_64  ->  ibus-m17n-1.3.4-25.fc28.x86_64

Comment 9 Danishka Navin 2018-08-17 11:25:10 UTC
Hi Pravin,

Thanks for the feedback.

I have updated the system and rebooted.
Now I can't reproduce this issue but lets wait for others to test.

Thanks again!

Comment 10 Pravin Satpute 2018-08-20 05:17:40 UTC
Great, glad to know. Its working for you now.

Comment 11 Parag Nemade 2018-09-10 02:56:29 UTC
Any updates here? I think this is working fine. Will close this bug after 1 week if no further updates added here.


Note You need to log in before you can comment on or make changes to this bug.