Bug 161810 - modules.pcimap handling broken
modules.pcimap handling broken
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kudzu (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On: 146213
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-06-27 11:20 EDT by Bill Nottingham
Modified: 2014-03-16 22:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2005-667
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 12:57:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2005-06-27 11:20:52 EDT
+++ This bug was initially created as a clone of Bug #146213 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
I have discovered the reason why the nvidia driver doesn't autoload
properly at bootup, like any other PCI device should.  Kudzu's
handling of modules.pcimap doesn't match the kernel's algorithm. 
Specifically, Kudzu doesn't handle the case where a vendor is defined
but device is PCI_ANY_ID (0xffffffff).  It also totally ignores the
class and class_mask.  I added another device entry for my specific
card, and then kmodule properly reported "VIDEO nvidia".

# pci module         vendor     device     subvendor  subdevice  class
     class_mask driver_data
nvidia               0x000010de 0xffffffff 0xffffffff 0xffffffff
0x00030000 0xffffffff 0x0
nvidia               0x000010de 0x00000140 0xffffffff 0xffffffff
0x00000000 0x00000000 0x0

This problem isn't specific to the nvidia driver.  Any PCI device can
legitamately (by the kernel definition) use such a construct.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Use a kernel module which defines a PCI vendor and class, but no
specific device.    

Actual Results:  kmodule did not discover the device.

Expected Results:  kmodule returns the proper driver module for the
device.

Additional info:
Comment 2 Bill Nottingham 2005-07-12 21:49:25 EDT
Fixed in 1.1.95.13-1.
Comment 6 Red Hat Bugzilla 2005-10-05 12:57:51 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-667.html

Note You need to log in before you can comment on or make changes to this bug.