Bug 1618512 - JBoss templates not clearing Git Reference and Context Directory [NEEDINFO]
Summary: JBoss templates not clearing Git Reference and Context Directory
Keywords:
Status: CLOSED DUPLICATE of bug 1605136
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-16 19:47 UTC by Veer Muchandi
Modified: 2018-08-18 17:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-18 17:52:19 UTC
Target Upstream Version:
spadgett: needinfo? (veer)


Attachments (Terms of Use)

Description Veer Muchandi 2018-08-16 19:47:10 UTC
Description of problem:
If you try to deploy your own code using JBoss templates, and if you clear the values in Git Reference and Context Directory, those values are getting defaulted to the default values in the template

Version-Release number of selected component (if applicable):
3.10, 3.9. 3.7

How reproducible:
always

Steps to Reproduce:
1. Create an application using a template. Example: JBoss EAP 6.4 (no https)
Select a Git repository url that is not the default value (example: https://github.com/VeerMuchandi/kitchensink-example)
Clear the values in the fields "Git Reference" and "Context Directory"
and create the application
2.The build fails. When you check build configuration, the values for Git Reference is "6.4.x" and the value for Context directory is "kitchensink".
3.If you edit the build config again and remove these values, the build will be successful.

Actual results
Build fails

Expected results:
Build should be successful


Additional info:

Comment 1 Ben Parees 2018-08-16 19:58:11 UTC
please point us to the specific template you were using so we can recreate.

Comment 2 Veer Muchandi 2018-08-16 20:13:58 UTC
Template: JBoss EAP 6.4 (no https)

Comment 3 Ben Parees 2018-08-16 20:16:16 UTC
I suspect this is simply working as designed as the console has no way to distinguish between "leave this empty" and "use the default value for this parameter".

The template sets a default value.

https://github.com/openshift/library/blob/master/official/eap/templates/eap64-basic-s2i.json#L326-L332

but i'll let Sam confirm.

Comment 4 Samuel Padgett 2018-08-17 01:10:31 UTC
Have you enabled template service broker?

This looks like it's the same as bug 1605136.

Comment 5 Samuel Padgett 2018-08-18 17:52:19 UTC

*** This bug has been marked as a duplicate of bug 1605136 ***


Note You need to log in before you can comment on or make changes to this bug.