Bug 1618561 - libssh_threads.so.4: cannot open shared object file
Summary: libssh_threads.so.4: cannot open shared object file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libssh
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anderson Sasaki
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1618616
TreeView+ depends on / blocked
 
Reported: 2018-08-17 00:24 UTC by Neal Becker
Modified: 2018-09-30 01:10 UTC (History)
8 users (show)

Fixed In Version: libssh-0.8.3-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-30 01:10:05 UTC


Attachments (Terms of Use)

Description Neal Becker 2018-08-17 00:24:55 UTC
Description of problem:

Just ran update, now x2goclient cannot start, says:
libssh_threads.so.4: cannot open shared object file

Version-Release number of selected component (if applicable):

x2goclient-4.1.1.1-1.fc28.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jos de Kloe 2018-08-17 10:55:30 UTC
seeing the same on my side.
A downgrade of libssh like this:
   sudo dnf downgrade libssh.x86_64 libssh.i686
enables me to run the x2goclient again.

Comment 2 Neal Becker 2018-08-17 11:53:55 UTC
It looks to me that only the symlink was missing.  I did 
sudo dnf reinstall libssh
lrwxrwxrwx. 1 root root     15 Aug 15 03:48 /usr/lib64/libssh.so.4 -> libssh.so.4.5.1

Comment 3 Orion Poplawski 2018-08-17 14:15:41 UTC
I don't understand why the symlink sometimes disappears on libssh upgrade.  But this isn't an x2goclient problem.

Comment 4 Bas Mevissen 2018-08-19 14:29:13 UTC
Only a forced manual re-installation of the latest version of libssh and libssh-devel (libssh-0.8.1-4.fc28) made x2goclient work again.

However, the links are still not 100% correct:

$ ll /usr/lib64/libssh[._]*
lrwxrwxrwx. 1 root root     11 Aug 16 16:42 /usr/lib64/libssh.so -> libssh.so.4
lrwxrwxrwx. 1 root root     15 Aug 16 16:42 /usr/lib64/libssh.so.4 -> libssh.so.4.5.1
-rwxr-xr-x. 1 root root 524856 Aug 16 16:42 /usr/lib64/libssh.so.4.5.1
lrwxrwxrwx. 1 root root     15 Aug 16 16:42 /usr/lib64/libssh_threads.so.4 -> libssh.so.4.5.1
lrwxrwxrwx. 1 root root     15 Aug 16 16:42 /usr/lib64/libssh_threads.so.4.5.1 -> libssh.so.4.5.1

It still misses the link for /usr/lib64/libssh_threads.so -> libssh_threads.so.4 to make building against libssh_threads impossible.

Comment 5 Bas Mevissen 2018-09-14 23:54:51 UTC
$ rpm -qa libssh libssh-devel
libssh-devel-0.8.2-1.fc28.x86_64
libssh-0.8.2-1.fc28.x86_64

$ ls -l /usr/lib64/{libssh.*,libssh_threads.*} 
lrwxrwxrwx. 1 root root     11 Aug 30 10:40 /usr/lib64/libssh.so -> libssh.so.4
lrwxrwxrwx. 1 root root     15 Aug 30 10:40 /usr/lib64/libssh.so.4 -> libssh.so.4.6.0
-rwxr-xr-x. 1 root root 524880 Aug 30 10:40 /usr/lib64/libssh.so.4.6.0
lrwxrwxrwx. 1 root root     15 Aug 30 10:40 /usr/lib64/libssh_threads.so.4 -> libssh.so.4.6.0
lrwxrwxrwx. 1 root root     15 Aug 30 10:40 /usr/lib64/libssh_threads.so.4.6.0 -> libssh.so.4.6.0

Still missing is

lrwxrwxrwx. 1 root root     23 Sep 15 01:28 /usr/lib64/libssh_threads.so -> libssh_threads.so.4.6.0

which I had to create manually to compile x2goclient-4.1.2.1-1.fc29.src.rpm for fc28. Same with released package x2goclient-4.1.1.1-1.fc28.src.rpm, which cannot be rebuild with current state of libssh.

So the situation has definitly not improved since my last post.

Why is this link removed during the lifetime of fc28 after all? 

BTW. Looking at fc29 libssh, there is still support for libssh_thread.so.4. So also there I would expect the .so to exist. I'm actually wondering how the x2goclient package can be build on fc29 at all, as it will need the .so as well.

This bug should go up in priority because the recent versions of libssh break the build of existing and released Fedora 28 packages.

Comment 6 Andreas Schneider 2018-09-25 07:55:34 UTC
We have added this that a recompile is not needed, but if you rebuild x2goclient you should remove linking against libssh_threads.so.

Comment 7 Bas Mevissen 2018-09-25 08:47:27 UTC
Understood. However, I still feel this change should not be done during the lifetime of Fedora 28. Now it depends on the version of the libssh package whether one can recompile a released src.rpm.

For Fedora 29, I would recommend moving the libssh_threads.so.* symlinks to a separate package that is not installed by default. Possibly followed by removal in Fedora 30.

Comment 8 Fedora Update System 2018-09-27 13:29:54 UTC
libssh-0.8.3-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-576bea0c62

Comment 9 Bas Mevissen 2018-09-27 13:46:11 UTC
After upgrading to version mentioned in #8:

$ ls -l /usr/lib64/libssh.* /usr/lib64/libssh_threads.*
lrwxrwxrwx 1 root root     11 Sep 27 15:21 /usr/lib64/libssh.so -> libssh.so.4
lrwxrwxrwx 1 root root     15 Sep 27 15:21 /usr/lib64/libssh.so.4 -> libssh.so.4.7.0
-rwxr-xr-x 1 root root 547064 Sep 27 15:21 /usr/lib64/libssh.so.4.7.0
lrwxrwxrwx 1 root root     11 Sep 27 15:21 /usr/lib64/libssh_threads.so -> libssh.so.4
lrwxrwxrwx 1 root root     15 Sep 27 15:21 /usr/lib64/libssh_threads.so.4 -> libssh.so.4.7.0
lrwxrwxrwx 1 root root     15 Sep 27 15:21 /usr/lib64/libssh_threads.so.4.7.0 -> libssh.so.4.7.0

Looks perfect, thanks!

Comment 10 Fedora Update System 2018-09-27 18:42:52 UTC
libssh-0.8.3-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-576bea0c62

Comment 11 Fedora Update System 2018-09-30 01:10:05 UTC
libssh-0.8.3-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.