Bug 161889 - server-error-service-unavailable when configuring printer with cups http://localhost:631
server-error-service-unavailable when configuring printer with cups http://lo...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: cups (Show other bugs)
3.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: 168424
  Show dependency treegraph
 
Reported: 2005-06-28 02:42 EDT by Corne Mureau
Modified: 2015-06-22 09:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0034
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 10:48:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cups error log (1.69 KB, text/plain)
2005-06-28 05:08 EDT, Corne Mureau
no flags Details
ppd file (8.96 KB, application/x-gzip)
2005-06-28 05:39 EDT, Corne Mureau
no flags Details
err_output (212.10 KB, text/plain)
2005-06-28 07:21 EDT, Corne Mureau
no flags Details
cups error log with patch 1.1.17-13.3.32.0.0.2 (1.90 KB, text/plain)
2005-09-30 07:45 EDT, Corne Mureau
no flags Details
cups error log with patch 1.1.17-13.3.32.0.0.2 (2.19 KB, text/plain)
2005-09-30 07:58 EDT, Corne Mureau
no flags Details
err_output with patch 1.1.17-13.3.32.0.0.2 (382.38 KB, text/plain)
2005-09-30 08:00 EDT, Corne Mureau
no flags Details
Screenshot error message (63.82 KB, image/png)
2005-10-03 02:22 EDT, Corne Mureau
no flags Details
cups error log with patch cups-1.1.17-13.3.32.0.0.3 (1.81 KB, text/plain)
2005-10-03 02:33 EDT, Corne Mureau
no flags Details
err_output with patch 1.1.17-13.3.32.0.0.3 (97.92 KB, text/plain)
2005-10-03 02:34 EDT, Corne Mureau
no flags Details
err_output with patch 1.1.17-13.3.32.0.0.3 (247.21 KB, text/plain)
2005-10-03 06:08 EDT, Corne Mureau
no flags Details
cups error log with patch cups-1.1.17-13.3.32.0.0.3 (2.45 MB, text/plain)
2005-10-03 06:09 EDT, Corne Mureau
no flags Details
cups error log with patch cups-1.1.17-13.3.32.0.0.4 (2.70 MB, text/plain)
2005-10-03 07:10 EDT, Corne Mureau
no flags Details
err_output with patch cups-1.1.17-13.3.32.0.0.4 (279.84 KB, text/plain)
2005-10-03 07:11 EDT, Corne Mureau
no flags Details

  None (edit)
Description Corne Mureau 2005-06-28 02:42:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050512 Red Hat/1.7.8-1.1.3.1

Description of problem:
When I configure the printer options of printer through the cups admin http://localhost:631, I get the error message server-error-service-unavailable instead of a nice configured printer.

Version-Release number of selected component (if applicable):
cups-1.1.17-13.3.27

How reproducible:
Always

Steps to Reproduce:
1. download the PPD-file NRG-DSm645-PS.ppd
2. copy the file to the directory /usr/share/cups/model/
3. restart cups (service cups restart)
4. start http://localhost:631
5. add a printer with the new PPD-file
6. configure some printer options (NOT modify)
7. click continue button
  

Actual Results:  Admin

Error:

    server-error-service-unavailable

Copyright 1993-2002 Easy Software Products, All Rights Reserved. The Common UNIX Printing System, CUPS, and the CUPS logo are the trademark property of Easy Software Products. All other trademarks are the property of their respective owners. 

Expected Results:  The new printer options should be saved to the PPD-file in the directory /etc/cups/ppd.

Additional info:

When I try to reproduce this error on a Fedora Core 2 box everythings turns out fine and the configuration is saved correct. So I don't think it is a problem with the specific PPD-file.
Comment 1 Tim Waugh 2005-06-28 04:19:17 EDT
What does /var/log/cups/error_log contain at that point?
Comment 2 Corne Mureau 2005-06-28 05:08:27 EDT
Created attachment 116048 [details]
cups error log
Comment 3 Tim Waugh 2005-06-28 05:20:54 EDT
Could you attach the PPD file please?
Comment 4 Corne Mureau 2005-06-28 05:39:14 EDT
Created attachment 116049 [details]
ppd file
Comment 5 Tim Waugh 2005-06-28 05:59:40 EDT
It is possible that this has the same cause as bug #138123.

Could you try the test packages I made to address that?  They are referenced in
bug #138123 comment #69.
Comment 6 Corne Mureau 2005-06-28 06:34:00 EDT
1. I stopped cups (service cups stop)
2. I installed the following test packages:

ftp://people.redhat.com/twaugh/tmp/cups-rhel3/i386/cups-1.1.17-13.3.27.0.0.6.i386.rpm
ftp://people.redhat.com/twaugh/tmp/cups-rhel3/i386/cups-libs-1.1.17-13.3.27.0.0.6.i386.rpm

3. I started cups (service cups start)
4. I deleted my printer definition.
5. I created a new printer

Unfortunately my problem still exists.
Comment 7 Tim Waugh 2005-06-28 06:39:24 EDT
Same error_log messages?

What you can do in that case is the following (as root):

mkdir /tmp/cups
chmod a+x /tmp/cups
touch /tmp/cups/err_output
chmod a+w /tmp/cups/err_output
service cups restart

Please delete the printer definition and re-create it, and then attach
/tmp/cups/err_output.  Thanks.
Comment 8 Corne Mureau 2005-06-28 07:21:28 EDT
Created attachment 116054 [details]
err_output
Comment 10 Tim Waugh 2005-06-29 16:09:24 EDT
Confirmed -- I see this here with that PPD file too.
Comment 14 Tim Waugh 2005-06-30 07:07:25 EDT
This has the same root cause as bug #161952.

*** This bug has been marked as a duplicate of 161952 ***
Comment 15 Tim Waugh 2005-09-30 04:17:38 EDT
******
******
******

See bug #161952 comment #17.  Ignore attachments prior to this comment #15.

******
******
******
Comment 16 Tim Waugh 2005-09-30 04:19:07 EDT
Corne, please provide this information:

Version-Release number of selected component

Steps to Reproduce (if different from original report above)

Actual results

Expected results

Comment 17 Corne Mureau 2005-09-30 04:41:43 EDT
Cups-1.1.17-13.3.32

For all other information see original bug comments.

Can we change the priority to high ? I have to edit all the ppd-files in the
organisation by hand which is taking a lot of time.
Comment 19 Tim Waugh 2005-09-30 07:03:19 EDT
With 13.3.27 I could reproduce the problem here as you described.  With 13.3.32
I cannot.

I have built a package with debugging support enabled, 1.1.17-13.3.32.0.0.2:

  ftp://people.redhat.com/twaugh/tmp/cups-rhel3/i386/

Please try it out and follow the instructions in comment #7.  Please be sure to
clear out the error_log file first, like this:

service cups stop
>/var/log/cups/error_log

When you have reproduced the problem with this package, please attach:

1. /var/log/cups/error_log
2. /tmp/cups/err_output

Thanks.
Comment 20 Corne Mureau 2005-09-30 07:45:59 EDT
Created attachment 119458 [details]
cups error log with patch 1.1.17-13.3.32.0.0.2
Comment 21 Corne Mureau 2005-09-30 07:58:53 EDT
Created attachment 119459 [details]
cups error log with patch 1.1.17-13.3.32.0.0.2
Comment 22 Corne Mureau 2005-09-30 08:00:05 EDT
Created attachment 119460 [details]
err_output with patch 1.1.17-13.3.32.0.0.2
Comment 23 Tim Waugh 2005-09-30 11:27:59 EDT
It looks very much like the IPP client is getting an error due to the fact that
the server has (for some reason) closed its socket.

Can you confirm that the message you get is 'server-error-service-unavailable'
and not 'client-error-not-authorized'?

I have built a new test package with a patch that I am hopeful will fix this
problem.  Please fetch 1.1.17-13.3.32.0.0.3:

  ftp://people.redhat.com/twaugh/tmp/cups-rhel3/i386/
Comment 24 Corne Mureau 2005-10-03 02:22:00 EDT
Created attachment 119523 [details]
Screenshot error message
Comment 25 Corne Mureau 2005-10-03 02:33:41 EDT
Created attachment 119524 [details]
cups error log with patch cups-1.1.17-13.3.32.0.0.3
Comment 26 Corne Mureau 2005-10-03 02:34:39 EDT
Created attachment 119525 [details]
err_output with patch 1.1.17-13.3.32.0.0.3
Comment 27 Corne Mureau 2005-10-03 02:35:24 EDT
Even with cups-1.1.17-13.3.32.0.0.3 I am still experiencing the same problem.
Comment 28 Tim Waugh 2005-10-03 05:49:40 EDT
1. Curiously enough the err_output file only has output from the cupsd process
(the scheduler), and not the admin.cgi process that it spawns.  I think the
/etc/cups/err_output file (and directory) probably does not have the right
permissions.  Please use the chmod commands in comment #7 to fix this.

2. Could you please change the LogLevel line in /etc/cups/cupsd.conf to read
like this?:

LogLevel debug2

Then please run:

service cups stop
>/var/log/cups/error_log
>/tmp/cups/err_output

Sorry to ask, but could you please try again and attach the new logs?
Comment 29 Corne Mureau 2005-10-03 06:08:10 EDT
Created attachment 119541 [details]
err_output with patch 1.1.17-13.3.32.0.0.3
Comment 30 Corne Mureau 2005-10-03 06:09:53 EDT
Created attachment 119542 [details]
cups error log with patch cups-1.1.17-13.3.32.0.0.3
Comment 31 Tim Waugh 2005-10-03 06:44:50 EDT
I have built a new test package with another patch in addition to the last one.
 Please fetch 1.1.17-13.3.32.0.0.4:

  ftp://people.redhat.com/twaugh/tmp/cups-rhel3/i386/

and try again.  Thanks!
Comment 32 Corne Mureau 2005-10-03 07:10:16 EDT
Created attachment 119543 [details]
cups error log with patch cups-1.1.17-13.3.32.0.0.4
Comment 33 Corne Mureau 2005-10-03 07:11:24 EDT
Created attachment 119544 [details]
err_output with patch cups-1.1.17-13.3.32.0.0.4
Comment 34 Corne Mureau 2005-10-03 07:15:55 EDT
Dear Tim,

Everything is now working as expected.
Thank you very much for your efforts.
I attached the output files for you. Maybe you want to check them out.
Can I keep using these packages or is it better for me to wait for the official
release ?
Comment 40 Tim Waugh 2005-10-12 11:09:23 EDT
Thank you for testing.

Those packages are experimental and still contain some debugging code (which
could slow the scheduler down or fill up disk space).  It would be better to
wait for the official update packages if possible.
Comment 44 Red Hat Bugzilla 2006-03-15 10:48:58 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0034.html

Note You need to log in before you can comment on or make changes to this bug.