Bug 161890 - Unable to login as admin to configure my Login manager in kcontrol
Unable to login as admin to configure my Login manager in kcontrol
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Kcontrol >> Login Manager >> Cannot e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-28 03:34 EDT by Rohith V
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-28 04:00:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rohith V 2005-06-28 03:34:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I launched kcontrol. I selected "Login Manager". I wanted to configure my Login manager so I clicked on "Administrator Mode" tab. It prompts for password and I did enter a valid password. The password dialog box accepts and vanishes, but I am still in "Login Manager" as a non-admin. Hence I cannot configure any of the features in the "Login Manager". This is a consistent behaviour on my system. Some  times after I enter the password I see a totally different screen i.e the right side frame which initially shows all system administrator configurable features and a theor description, will jump to say "Internet & Network".

Version-Release number of selected component (if applicable):
kdebase-3.4.0-5

How reproducible:
Always

Steps to Reproduce:
1. Launch kcontrol
2. Choose Login Manager
3. Click on "Administrator Mode". It prompts for password.
4. Enter password and press enter.
5. The password is accepted but I am still in non-admin mode.
  

Actual Results:  I am not logged in as admin and hence cannot configure any features of "Login Manager". Sometimes it jumps to a totally different option in kcontrol.

Expected Results:  I should have been logged in as admin with the right frame bordered in "RED"

Additional info:
Comment 1 Ngo Than 2005-06-28 04:00:39 EDT
It's not reproduceable in FC4 with KDE updates.
Comment 2 Rohith V 2005-07-11 09:34:46 EDT
Yes, I did an yum upgrade on kdebase and it works for me now.

Note You need to log in before you can comment on or make changes to this bug.