Bug 161896 - Grep "Segmentation fault" using Perl regular expression
Grep "Segmentation fault" using Perl regular expression
Status: CLOSED DUPLICATE of bug 157964
Product: Fedora
Classification: Fedora
Component: grep (Show other bugs)
3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-28 05:35 EDT by Robert Jackson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-28 05:36:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Jackson 2005-06-28 05:35:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050416 Fedora/1.0.3-1.3.1 Firefox/1.0.3

Description of problem:
I was using grep with a Perl regular expression to find files containing blank lines, but with some whitespace (i.e. a tab or a space).

One file (from about 20) caused grep to Segmentation fault.  This file was unique from the others since the last line was empty (i.e. it has an additional newline at the end).

I found that creating a file with a single newline caused the same Segmentation fault.

Version-Release number of selected component (if applicable):
grep-2.5.1-7.8

How reproducible:
Always

Steps to Reproduce:
1. echo "\n" > temp.txt
2. grep -P '^\s+$' temp.txt


Actual Results:  Segmentation fault

Expected Results:  No Segmentation fault


Additional info:

I tried the same command on serveral different Ferdora platforms, and all give the same Segmentation fault.  Specifically:

RedHat Linux 9 (i686)
Fedora Core 1 (i686)
Fedora Core 3 (i686)
Fedora Core 3 (x86_64)
Comment 1 Tim Waugh 2005-06-28 05:36:29 EDT
You keep resubmitting this: don't.

*** This bug has been marked as a duplicate of 157964 ***
Comment 2 Robert Jackson 2005-06-28 05:46:13 EDT
I'm ever so sorry.  I thought I had a firefox bookmark set up to view the
original bug report, but unfortunately clicking the bookmark actually
resubmitted the bug.

Note You need to log in before you can comment on or make changes to this bug.