Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1618983

Summary: openstack deployment failed - Failed running docker-puppet.py for haproxy
Product: Red Hat OpenStack Reporter: Ronnie Rasouli <rrasouli>
Component: openstack-tripleoAssignee: James Slagle <jslagle>
Status: CLOSED DUPLICATE QA Contact: Gurenko Alex <agurenko>
Severity: high Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: aschultz, bperkins, mburns, ratailor, yprokule
Target Milestone: ---Keywords: ZStream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-08-24 11:31:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
failures list logs
none
mistral logs none

Description Ronnie Rasouli 2018-08-19 08:30:58 UTC
Created attachment 1476863 [details]
failures list logs

Description of problem:

RHOS13 puddle 08-14-4 failed on overcloud deployment 

            "Notice: hiera(): Cannot load backend module_data: cannot load such file -- hiera/backend/module_data_backend",
            "",
            "2018-08-16 15:24:32,738 ERROR: 22715 -- + mkdir -p /etc/puppet",
            "+ cp -a /tmp/puppet-etc/auth.conf /tmp/puppet-etc/hiera.yaml /tmp/puppet-etc/hieradata /tmp/puppet-etc/modules /tmp/puppet-etc/puppet.conf /tmp/puppet-etc/ssl /etc/puppet",
            "+ rm -Rf /etc/puppet/ssl",
            "+ echo '{\"step\": 6}'",
            "+ TAGS=",
            "+ '[' -n file,file_line,concat,augeas,cron,haproxy_config ']'",
            "+ TAGS='--tags file,file_line,concat,augeas,cron,haproxy_config'",
            "+ origin_of_time=/var/lib/config-data/haproxy.origin_of_time",
            "+ touch /var/lib/config-data/haproxy.origin_of_time",
            "+ sync",
            "+ set +e",
            "+ FACTER_hostname=controller-2",
            "+ FACTER_uuid=docker",
            "+ /usr/bin/puppet apply --summarize --detailed-exitcodes --color=false --logdest syslog --logdest console --modulepath=/etc/puppet/modules:/usr/share/openstack-puppet/modules --tags file,file_line,concat,augeas,cron,haproxy_config /etc/config.pp",
            "Failed to get D-Bus connection: Operation not permitted",

Version-Release number of selected component (if applicable):

puppet-tripleo-8.3.4-6.el7ost.noarch
openstack-tripleo-common-8.6.3-10.el7ost.noarch

How reproducible:
most likely

Steps to Reproduce:
1. deploy openstack with 3controllers, 1 compute, 3 ceph
2.
3.

Actual results:
openstack deployment failed

Expected results:


Additional info:

Comment 1 Ronnie Rasouli 2018-08-19 08:59:49 UTC
Created attachment 1476866 [details]
mistral logs

Comment 4 Rajesh Tailor 2018-08-24 11:31:23 UTC

*** This bug has been marked as a duplicate of bug 1613161 ***