Bug 1619295 - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64 / libreoffice-pdfimport-1:6.0.6.1-7.fc29.x86_64
Summary: nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: poppler
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F29BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-08-20 14:26 UTC by Miro Hrončok
Modified: 2018-08-23 13:29 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-23 12:38:16 UTC


Attachments (Terms of Use)

Description Miro Hrončok 2018-08-20 14:26:44 UTC
Description of problem:
I cannot upgrade form F28 to F29:

Error: 
 Problem 1: problem with installed package libreoffice-pdfimport-1:6.0.6.2-1.fc28.x86_64
  - libreoffice-pdfimport-1:6.0.6.2-1.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by libreoffice-pdfimport-1:6.0.6.1-7.fc29.x86_64
 Problem 2: problem with installed package gdal-libs-2.2.4-2.fc28.x86_64
  - gdal-libs-2.2.4-2.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 3: problem with installed package gdal-2.2.4-2.fc28.x86_64
  - gdal-2.2.4-2.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-2.2.4-7.fc29.x86_64
 Problem 10: problem with installed package gdal-devel-2.2.4-2.fc28.x86_64
  - package gdal-devel-2.2.4-7.fc29.x86_64 requires gdal-libs(x86-64) = 2.2.4-7.fc29, but none of the providers can be installed
  - gdal-devel-2.2.4-2.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 11: problem with installed package libreoffice-draw-1:6.0.6.2-1.fc28.x86_64
  - package libreoffice-draw-1:6.0.6.1-7.fc29.x86_64 requires libreoffice-pdfimport(x86-64) = 1:6.0.6.1-7.fc29, but none of the providers can be installed
  - libreoffice-draw-1:6.0.6.2-1.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by libreoffice-pdfimport-1:6.0.6.1-7.fc29.x86_64
 Problem 13: problem with installed package python2-gdal-2.2.4-2.fc28.x86_64
  - package python2-gdal-2.2.4-7.fc29.x86_64 requires gdal-libs(x86-64) = 2.2.4-7.fc29, but none of the providers can be installed
  - python2-gdal-2.2.4-2.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 15: package libreoffice-1:6.0.6.1-7.fc29.x86_64 requires libreoffice-draw(x86-64) = 1:6.0.6.1-7.fc29, but none of the providers can be installed
  - problem with installed package libreoffice-1:6.0.6.2-1.fc28.x86_64
  - package libreoffice-draw-1:6.0.6.1-7.fc29.x86_64 requires libreoffice-pdfimport(x86-64) = 1:6.0.6.1-7.fc29, but none of the providers can be installed
  - libreoffice-1:6.0.6.2-1.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by libreoffice-pdfimport-1:6.0.6.1-7.fc29.x86_64
 Problem 16: package qgis-2.18.20-1.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - problem with installed package qgis-2.18.20-1.fc28.x86_64
  - package gdal-libs-2.2.4-2.fc28.x86_64 requires libcfitsio.so.5()(64bit), but none of the providers can be installed
  - qgis-2.18.20-1.fc28.x86_64 does not belong to a distupgrade repository
  - cfitsio-3.430-1.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 17: package cloudcompare-2.9.1-2.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package gdal-libs-2.2.4-2.fc28.x86_64 requires libdap.so.23()(64bit), but none of the providers can be installed
  - problem with installed package cloudcompare-2.9.1-1.fc28.x86_64
  - libdap-3.18.3-4.fc27.x86_64 does not belong to a distupgrade repository
  - cloudcompare-2.9.1-1.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 22: package liblas-1.8.0-23.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package gdal-libs-2.2.4-2.fc28.x86_64 requires libpoppler.so.73()(64bit), but none of the providers can be installed
  - problem with installed package liblas-1.8.0-21.fc28.x86_64
  - poppler-0.62.0-4.fc28.x86_64 does not belong to a distupgrade repository
  - liblas-1.8.0-21.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 25: package gdal-libs-2.2.4-2.fc28.x86_64 requires libpoppler.so.73()(64bit), but none of the providers can be installed
  - cannot install both poppler-0.67.0-1.fc29.x86_64 and poppler-0.62.0-4.fc28.x86_64
  - package opencv-core-3.4.1-6.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package cups-filters-1.20.3-7.fc29.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - problem with installed package opencv-core-3.4.1-3.fc28.x86_64
  - problem with installed package cups-filters-1.20.0-9.fc28.x86_64
  - opencv-core-3.4.1-3.fc28.x86_64 does not belong to a distupgrade repository
  - cups-filters-1.20.0-9.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 26: package gdal-libs-2.2.4-2.fc28.x86_64 requires libpoppler.so.73()(64bit), but none of the providers can be installed
  - cannot install both poppler-0.67.0-1.fc29.x86_64 and poppler-0.62.0-4.fc28.x86_64
  - package postgis-2.4.3-5.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package inkscape-0.92.3-5.fc29.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - problem with installed package postgis-2.4.3-3.fc28.x86_64
  - problem with installed package inkscape-0.92.3-2.fc28.x86_64
  - postgis-2.4.3-3.fc28.x86_64 does not belong to a distupgrade repository
  - inkscape-0.92.3-2.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 28: package gdal-libs-2.2.4-2.fc28.x86_64 requires libpoppler.so.73()(64bit), but none of the providers can be installed
  - cannot install both poppler-0.67.0-1.fc29.x86_64 and poppler-0.62.0-4.fc28.x86_64
  - package opencv-core-3.4.1-6.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package poppler-glib-0.67.0-1.fc29.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - package opencv-3.4.1-6.fc29.x86_64 requires opencv-core(x86-64) = 3.4.1-6.fc29, but none of the providers can be installed
  - problem with installed package poppler-glib-0.62.0-4.fc28.x86_64
  - problem with installed package opencv-3.4.1-3.fc28.x86_64
  - poppler-glib-0.62.0-4.fc28.x86_64 does not belong to a distupgrade repository
  - opencv-3.4.1-3.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 30: package opencv-core-3.4.1-6.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package gdal-libs-2.2.4-2.fc28.x86_64 requires libpoppler.so.73()(64bit), but none of the providers can be installed
  - package opencv-3.4.1-6.fc29.x86_64 requires opencv-core(x86-64) = 3.4.1-6.fc29, but none of the providers can be installed
  - cannot install both poppler-0.67.0-1.fc29.x86_64 and poppler-0.62.0-4.fc28.x86_64
  - package python3-opencv-3.4.1-6.fc29.x86_64 requires opencv(x86-64) = 3.4.1-6.fc29, but none of the providers can be installed
  - package poppler-utils-0.67.0-1.fc29.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - problem with installed package python3-opencv-3.4.1-3.fc28.x86_64
  - problem with installed package poppler-utils-0.62.0-4.fc28.x86_64
  - python3-opencv-3.4.1-3.fc28.x86_64 does not belong to a distupgrade repository
  - poppler-utils-0.62.0-4.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 31: package OpenImageIO-1.8.12-3.fc29.x86_64 requires libopencv_core.so.3.4()(64bit), but none of the providers can be installed
  - package opencv-core-3.4.1-3.fc28.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package opencv-core-3.4.1-6.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package gdal-libs-2.2.4-2.fc28.x86_64 requires libpoppler.so.73()(64bit), but none of the providers can be installed
  - cannot install both poppler-0.67.0-1.fc29.x86_64 and poppler-0.62.0-4.fc28.x86_64
  - package texlive-luatex-7:20180414-19.fc29.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - problem with installed package texlive-luatex-7:20180414-12.fc28.x86_64
  - problem with installed package OpenImageIO-1.8.12-1.fc28.x86_64
  - texlive-luatex-7:20180414-12.fc28.x86_64 does not belong to a distupgrade repository
  - OpenImageIO-1.8.12-1.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 32: package OpenImageIO-1.8.12-3.fc29.x86_64 requires libopencv_core.so.3.4()(64bit), but none of the providers can be installed
  - package opencv-core-3.4.1-3.fc28.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package opencv-core-3.4.1-6.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package gdal-libs-2.2.4-2.fc28.x86_64 requires libpoppler.so.73()(64bit), but none of the providers can be installed
  - cannot install both poppler-0.67.0-1.fc29.x86_64 and poppler-0.62.0-4.fc28.x86_64
  - package texlive-pdftex-7:20180414-19.fc29.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - package blender-1:2.79b-6.fc29.x86_64 requires libOpenImageIO.so.1.8()(64bit), but none of the providers can be installed
  - problem with installed package texlive-pdftex-7:20180414-12.fc28.x86_64
  - problem with installed package blender-1:2.79b-6.fc28.x86_64
  - package OpenImageIO-1.8.12-1.fc28.x86_64 requires libraw_r.so.16()(64bit), but none of the providers can be installed
  - texlive-pdftex-7:20180414-12.fc28.x86_64 does not belong to a distupgrade repository
  - blender-1:2.79b-6.fc28.x86_64 does not belong to a distupgrade repository
  - LibRaw-0.18.13-1.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 33: package opencv-contrib-3.4.1-6.fc29.x86_64 requires libopencv_core.so.3.4()(64bit), but none of the providers can be installed
  - package opencv-core-3.4.1-3.fc28.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package opencv-core-3.4.1-6.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package gdal-libs-2.2.4-2.fc28.x86_64 requires libpoppler.so.73()(64bit), but none of the providers can be installed
  - cannot install both poppler-0.67.0-1.fc29.x86_64 and poppler-0.62.0-4.fc28.x86_64
  - package texlive-xetex-7:20180414-19.fc29.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - problem with installed package texlive-xetex-7:20180414-12.fc28.x86_64
  - problem with installed package opencv-contrib-3.4.1-3.fc28.x86_64
  - texlive-xetex-7:20180414-12.fc28.x86_64 does not belong to a distupgrade repository
  - opencv-contrib-3.4.1-3.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 34: package simarrange-0.0-18.20170316git8238ce5.fc29.x86_64 requires libopencv_core.so.3.4()(64bit), but none of the providers can be installed
  - package opencv-core-3.4.1-3.fc28.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package opencv-core-3.4.1-6.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package gdal-libs-2.2.4-2.fc28.x86_64 requires libpoppler.so.73()(64bit), but none of the providers can be installed
  - cannot install both poppler-0.67.0-1.fc29.x86_64 and poppler-0.62.0-4.fc28.x86_64
  - package cups-filters-1.20.3-7.fc29.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - package cups-1:2.2.8-2.fc29.x86_64 requires cups-filters, but none of the providers can be installed
  - problem with installed package simarrange-0.0-17.20170316git8238ce5.fc28.x86_64
  - package cups-filters-1.20.0-9.fc28.x86_64 requires cups-filters-libs(x86-64) = 1.20.0-9.fc28, but none of the providers can be installed
  - package dcpl2500dcupswrapper-3.2.0-1.i386 requires cups, but none of the providers can be installed
  - simarrange-0.0-17.20170316git8238ce5.fc28.x86_64 does not belong to a distupgrade repository
  - cups-filters-libs-1.20.0-9.fc28.x86_64 does not belong to a distupgrade repository
  - cups-1:2.2.6-18.fc28.x86_64 does not belong to a distupgrade repository
  - problem with installed package dcpl2500dcupswrapper-3.2.0-1.i386
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64
 Problem 35: package plater-1:2.0.0-0.7.rc5.fc29.noarch requires simarrange, but none of the providers can be installed
  - package simarrange-0.0-17.20170316git8238ce5.fc28.x86_64 requires libopencv_core.so.3.4()(64bit), but none of the providers can be installed
  - package simarrange-0.0-18.20170316git8238ce5.fc29.x86_64 requires libopencv_core.so.3.4()(64bit), but none of the providers can be installed
  - package opencv-core-3.4.1-3.fc28.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package opencv-core-3.4.1-6.fc29.x86_64 requires libgdal.so.20()(64bit), but none of the providers can be installed
  - package gdal-libs-2.2.4-2.fc28.x86_64 requires libpoppler.so.73()(64bit), but none of the providers can be installed
  - cannot install both poppler-0.67.0-1.fc29.x86_64 and poppler-0.62.0-4.fc28.x86_64
  - package cups-filters-1.20.3-7.fc29.x86_64 requires libpoppler.so.78()(64bit), but none of the providers can be installed
  - package foomatic-4.0.13-4.fc29.x86_64 requires cups-filters >= 1.0.42, but none of the providers can be installed
  - package cups-filters-1.20.0-9.fc28.x86_64 requires libqpdf.so.18()(64bit), but none of the providers can be installed
  - problem with installed package plater-1:2.0.0-0.5.rc5.fc28.noarch
  - problem with installed package foomatic-4.0.12-23.fc28.x86_64
  - qpdf-libs-7.1.1-6.fc28.x86_64 does not belong to a distupgrade repository
  - plater-1:2.0.0-0.5.rc5.fc28.noarch does not belong to a distupgrade repository
  - foomatic-4.0.12-23.fc28.x86_64 does not belong to a distupgrade repository
  - nothing provides libpoppler.so.74()(64bit) needed by gdal-libs-2.2.4-7.fc29.x86_64


Additional info: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/KTPNGFA6MPKCD6XWNP3BMBHTVC2CZGYK/

Comment 1 Fedora Blocker Bugs Application 2018-08-20 14:35:35 UTC
Proposed as a Blocker for 29-beta by Fedora user churchyard using the blocker tracking app because:

 For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from a fully updated, clean default installation of each of the last two stable Fedora releases with that package set installed.

libreoffice-pdfimport is installed in  Fedora Workstation.

Comment 2 Geoffrey Marr 2018-08-20 20:07:58 UTC
Discussed during the 2018-08-20 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criteria:

"For each one of the release-blocking package sets, it must be possible to successfully complete a direct upgrade from a fully updated, clean default installation of each of the last two stable Fedora releases with that package set installed. ... The upgraded system must include all packages that would be present on the system after a default installation from install media..."

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2018-08-20/f29-blocker-review.2018-08-20-16.00.txt

Comment 3 Marek Kašík 2018-08-20 23:55:55 UTC
It seems that libreoffice was successfully built as libreoffice-6.1.0.3-1.fc29 today (thank you Caolan).
GDAL does not build for more than 1 month. #1606875 says that GDAL will be removed if it won't build before branching and it did not build.

Comment 4 Marek Kašík 2018-08-23 12:38:16 UTC
This issue has been resolved by Pavel Raiskup which fixed the bug #1606875. I'm closing this.

Comment 5 Miro Hrončok 2018-08-23 13:29:50 UTC
I can confirm that those problems are no longer reported when I attempt an upgrade. Thanks.


Note You need to log in before you can comment on or make changes to this bug.