This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 161953 - clamav-milter could use some extra files to ease setup
clamav-milter could use some extra files to ease setup
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-28 14:29 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-28 15:32:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2005-06-28 14:29:59 EDT
Description of problem:
clamav-milter requires a fair amount of setup to get the associated clamd
working (namely learning about clamd-wrapper).  But, it seems like default files
could be easily provided (in addition to /etc/clamd.d/milter.conf).  Or perhaps
in a clamav-server-milter package. E.g.:

/etc/rc.d/init.d/clamd.milter:
#!/bin/bash
#
# chkconfig: - 75 25
# description: The clamd server running for milter

CLAMD_SERVICE=milter
. /usr/share/clamav/clamd-wrapper

(this could be enabled with chkconfig --add clamd.milter)

/etc/sysconfig/clamd.milter:
CLAMD_CONFIGFILE=/etc/clamd.d/milter.conf
CLAMD_SOCKET=/var/run/clamd.milter/clamd.sock
CLAMD_OPTIONS=

/etc/logrotate.d/clamd.milter:
/var/log/clamd.milter {
        monthly
        notifempty
        missingok

        postrotate
                killall -HUP clamd.milter 2>/dev/null || :
        endscript
}

And the /var/run/clamd.milter directory:
 
drwxr-xr-x  2 clamilt clamilt 4096 Jun 28 12:04 /var/run/clamd.milter

Version-Release number of selected component (if applicable):
clamav-milter-0.86.1-2.fc3
Comment 1 Enrico Scholz 2005-06-28 15:32:56 EDT
clamav-milter does not need a separate 'clamd' daemon; since version 0.81 the
internal mode is the default one.

'clamav-milter' itself should work out-of-the-box (after commenting out the
'Example' line in /etc/clamd.d/milter.conf); for testing the '-blo' option might
be added in /etc/sysconfig/clamav-milter, but upstream does not seem to like
these options by default.

Note You need to log in before you can comment on or make changes to this bug.