Bug 1619839 - ceph-iscsi: fix perf issues with xcopy
Summary: ceph-iscsi: fix perf issues with xcopy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: iSCSI
Version: 3.2
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: 3.2
Assignee: Mike Christie
QA Contact: Madhavi Kasturi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-21 21:22 UTC by Mike Christie
Modified: 2019-01-03 19:02 UTC (History)
5 users (show)

Fixed In Version: tcmu-runner-1.4.0-1.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:01:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github open-iscsi tcmu-runner pull 469 None None None 2018-09-12 16:18:41 UTC
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:01 UTC

Description Mike Christie 2018-08-21 21:22:29 UTC
Description of problem:

The tcmu-runner xcopy support does at most 1 512K IO at a time. It reads 512K, then writes it, then repeats.

Ideally, for rbd we should add offload support similar to what was done for write same and compare and write.

In the near term and to if needed to handle xcopys that do not cover entire ceph objects, we should fix the emulated xcopy support to work like the emulated unmap where we can break up a unmap into multiple parts that at executed in parallel.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Harish NV Rao 2018-08-23 05:55:29 UTC
@Mike, will this be fixed in 3.2? if yes then please change the target release field.

Comment 10 errata-xmlrpc 2019-01-03 19:01:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.