Bug 1620020 - Namespace reservation does not work
Summary: Namespace reservation does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.0
Assignee: Stefan Schimanski
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-22 08:34 UTC by Xingxing Xia
Modified: 2019-06-04 10:40 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:41 UTC

Description Xingxing Xia 2018-08-22 08:34:42 UTC
Description of problem:
Following the latest https://github.com/openshift/kubernetes-namespace-reservation , namespace reservation does not work.

Version-Release number of selected component (if applicable):
openshift v3.11.0-0.19.0
kubernetes v1.11.0+d4cacc0

How reproducible:
Always

Steps to Reproduce:
Follow https://github.com/openshift/kubernetes-namespace-reservation

Actual results:
`kubectl create namespace deads` or `oc new-project deads` can succeed

Expected results:
Should fail and produce "Error from server (Forbidden): "deads" is reserved"

Additional info:

Comment 1 David Eads 2018-08-22 12:04:29 UTC
Possibly an enablement thing.

Comment 2 Stefan Schimanski 2018-08-23 14:35:38 UTC
Towards enabling webhooks by default:
- https://github.com/openshift/origin/pull/20743
- https://github.com/openshift/origin/pull/20744

Comment 3 Stefan Schimanski 2018-09-12 15:21:43 UTC
https://github.com/openshift/origin/pull/20953 and https://github.com/openshift/origin/pull/20945 still have to merge into release-3.11.

Comment 6 Xingxing Xia 2018-11-12 06:57:09 UTC
Verified in v4.0.0-0.52.0 per https://jira.coreos.com/browse/MSTR-199 comment I added. Please move this bug to ON_QA. Thx

Comment 9 errata-xmlrpc 2019-06-04 10:40:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.