Bug 162005 - Cannot download RPM to install - Firefox tries to play it as music
Cannot download RPM to install - Firefox tries to play it as music
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
http://www.adobe.com/products/acrobat...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-28 21:01 EDT by P Wolf
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-29 08:45:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Wolf 2005-06-28 21:01:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Firefox opens an .rpm as media file, when in fact it is RPM package!  See referenced URL to download Adobe Reader.  "Download" button runs javascript that directs browser to an URL ending in .rpm but there is no chance to save it before the tab changes to a big gray media player.  The media tab should "save-as" if the rpm file is not playable media.

Version-Release number of selected component (if applicable):
firefox-1.0.4-4

How reproducible:
Always

Steps to Reproduce:
1.Go to download Adobe Reader from the referenced URL
2.Select (rpm) package
3.Press Download
  

Actual Results:  Tab briefly showed web page saying something like "download is starting automatically", then turned all gray and seemed to be displaying a media player

Expected Results:  I wanted to download the RPM file; it is an installable package.

Additional info:
Comment 1 Warren Togami 2005-06-28 21:49:57 EDT
This is not firefox's fault.  .rpm is associated with Real Player due to MIME
type associations on the web server.
Comment 2 Christopher Aillon 2005-06-29 08:45:51 EDT
Compare the output of:

> HEAD
http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/os/Fedora/RPMS/firefox-1.0.4-4.i386.rpm
| grep Content-Type
Content-Type: application/x-rpm

vs. 

> HEAD
http://ardownload.adobe.com/pub/adobe/reader/unix/7x/7.0/enu/AdobeReader_enu-7.0.0-2.i386.rpm
| grep Content-Type
Content-Type: audio/x-pn-realaudio-plugin

Note You need to log in before you can comment on or make changes to this bug.