Bug 1620055 - Error when starting qpid-dispatch-router 1.2.0
Summary: Error when starting qpid-dispatch-router 1.2.0
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qpid-dispatch   
(Show other bugs)
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Irina Boverman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-22 10:29 UTC by pascal.pascher
Modified: 2019-02-21 02:56 UTC (History)
5 users (show)

Fixed In Version: qpid-dispatch-1.5.0-1.el7 qpid-dispatch-1.5.0-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-02-21 02:38:02 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description pascal.pascher 2018-08-22 10:29:47 UTC
Description of problem:
Error when starting qpid-dispatch-router 1.2.0

Version-Release number of selected component (if applicable):
1.2.0

How reproducible:
always

Steps to Reproduce:
1. start qpid-dispatch-router

Actual results:
log:

systemd[1]: Started Qpid Dispatch router daemon.
systemd[1]: Starting Qpid Dispatch router daemon...
qdrouterd[13453]: 2018-08-21 11:21:25.278980 +0200 ERROR (error) Python: AttributeError: 'module' object has no attribute '__import__'
qdrouterd[13453]: 2018-08-21 11:21:25.279507 +0200 ERROR (error) Traceback (most recent call last):
qdrouterd[13453]: File "/usr/lib/qpid-dispatch/python/qpid_dispatch_internal/dispatch.py", line 151, in <module>
qdrouterd[13453]: builtin_import = builtins.__import__
qdrouterd[13453]: AttributeError: 'module' object has no attribute '__import__'
systemd[1]: qdrouterd.service: main process exited, code=exited, status=1/FAILURE
systemd[1]: Unit qdrouterd.service entered failed state.
systemd[1]: qdrouterd.service failed.


Expected results:
service starts without error

Additional info:
- downgrading to 1.1.0 fixes the issue
- applying commit https://github.com/apache/qpid-dispatch/commit/7285a47dcdd255af5ecc8d9c95fe8bdd28fb981d from version 1.3.0 fixes the issue

Comment 1 Jonathon Turel 2018-10-15 19:09:35 UTC
Not sure how this will relate to a fix, but the problem seems to be related to the presence of the python2-future RPM on the system. When I remove it qdrouterd will start without this or any other error.

Comment 2 Ted Ross 2018-10-15 19:25:30 UTC
This is probably related to this upstream issue:  https://issues.apache.org/jira/browse/DISPATCH-1091

Comment 3 Jonathon Turel 2018-10-15 20:21:15 UTC
That sounds like the culprit - thanks for sharing

Comment 4 Fedora Update System 2019-01-11 14:52:19 UTC
qpid-dispatch-1.4.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-07d1837fd7

Comment 5 Fedora Update System 2019-01-12 02:30:54 UTC
qpid-dispatch-1.4.1-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-07d1837fd7

Comment 6 Fedora Update System 2019-01-15 22:20:40 UTC
qpid-dispatch-1.5.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a610e44d3a

Comment 7 Fedora Update System 2019-01-16 03:31:32 UTC
qpid-dispatch-1.5.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a610e44d3a

Comment 8 Fedora Update System 2019-01-16 21:28:08 UTC
qpid-dispatch-1.5.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd2d41b24c

Comment 9 Fedora Update System 2019-01-17 03:03:18 UTC
qpid-dispatch-1.5.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd2d41b24c

Comment 10 Fedora Update System 2019-01-29 20:10:32 UTC
qpid-dispatch-1.4.1-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-07d1837fd7

Comment 11 Fedora Update System 2019-01-29 20:14:25 UTC
qpid-dispatch-1.5.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-a610e44d3a

Comment 12 Fedora Update System 2019-01-29 20:17:25 UTC
qpid-dispatch-1.5.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd2d41b24c

Comment 13 Fedora Update System 2019-01-30 01:58:33 UTC
qpid-dispatch-1.5.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-a610e44d3a

Comment 14 Fedora Update System 2019-01-30 02:22:43 UTC
qpid-dispatch-1.5.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-dd2d41b24c

Comment 15 Fedora Update System 2019-02-21 02:38:02 UTC
qpid-dispatch-1.5.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2019-02-21 02:56:37 UTC
qpid-dispatch-1.5.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.