Bug 1620116 - Gluster cli doesn't show an error message when creating a disperse volume using IP addresses
Summary: Gluster cli doesn't show an error message when creating a disperse volume usi...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: GlusterFS
Classification: Community
Component: cli
Version: 4.1
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-22 13:17 UTC by jimmybob-leon
Modified: 2018-10-05 02:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-05 02:21:07 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description jimmybob-leon 2018-08-22 13:17:19 UTC
Description of problem:
Gluster cli doesn't throw an error and just shows the help for gluster volume create... When trying to create a volume with IP adresses. 




Version-Release number of selected component (if applicable): 4.1 Latest gluster cli server


How reproducible:

i.e. gluster volume create gv0 disperse 192.168.0.2:/home/gluster

Gives the gluster volume create help page out. And doesn't say, you need atleast two arguments. 


Steps to Reproduce:
1. gluster volume create gv0 disperse 192.168.0.2:/home/gluster



Actual results:
Gives the gluster volume create help page out. And doesn't say, you need atleast two arguments. 

Expected results:
This command requires atleast two arguments...

Additional info:
Ubuntu 18.04 LTS Azure VM

Gluster log > cli-cmd-parser.c:781:cli_cmd_volume_create_parse] 0-cli: Unable to parse create volume CLI

Comment 1 Atin Mukherjee 2018-10-05 02:21:07 UTC
In case of an incomplete command, the cli throws up a general usage of the command. As of now, it doesn't explicitly mention what's missing and that's how it's been designed. Technically it's not a bug.

For eg :

root@50f5b3253050:/home/rhs-glusterfs# gluster v create

Usage:
volume create <NEW-VOLNAME> [stripe <COUNT>] [replica <COUNT> [arbiter <COUNT>]] [disperse [<COUNT>]] [disperse-data <COUNT>] [redundancy <COUNT>] [transport <tcp|rdma|tcp,rdma>] <NEW-BRICK>?<vg_name>... [force]


Note You need to log in before you can comment on or make changes to this bug.