Bug 1620124 - In production webpacked_plugins_js_for $PLUGIN doesn't load the js if the plugin doesn't provide the sources
Summary: In production webpacked_plugins_js_for $PLUGIN doesn't load the js if the plu...
Keywords:
Status: CLOSED DUPLICATE of bug 1620126
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Ewoud Kohl van Wijngaarden
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-22 13:36 UTC by Marek Hulan
Modified: 2019-04-01 20:27 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-07 07:49:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 24371 0 None None None 2018-08-22 13:36:26 UTC

Description Marek Hulan 2018-08-22 13:36:23 UTC
On nightly production install some components from foreman_ansible were not showing on the page. The issue was webpackage_plugins_js ignored plugins which didn't provide "webpack/index.js" in their root even though the plugin provided the precompiled assets.

Also webpacked_plugins_js fails silently if it can't find the required js

Comment 1 Marek Hulan 2018-08-22 13:36:30 UTC
Created from redmine issue http://projects.theforeman.org/issues/24371

Comment 3 Satellite Program 2018-08-22 14:10:18 UTC
Upstream bug assigned to ekohlvan

Comment 4 Satellite Program 2018-08-22 14:10:21 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/24371 has been resolved.

Comment 5 Marek Hulan 2018-09-07 07:49:32 UTC
closing as double click issue

*** This bug has been marked as a duplicate of bug 1620126 ***


Note You need to log in before you can comment on or make changes to this bug.