Bug 162025 - squid-2.5.STABLE6-3.4E.9 crashes...(md5?)
squid-2.5.STABLE6-3.4E.9 crashes...(md5?)
Status: CLOSED DUPLICATE of bug 165367
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: squid (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Depends On:
  Show dependency treegraph
Reported: 2005-06-29 05:31 EDT by Vasiliy Kotikov
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-11 05:34:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
zipped file with cache.log and squid.conf (18.47 KB, application/x-zip-compressed)
2005-06-29 05:31 EDT, Vasiliy Kotikov
no flags Details

  None (edit)
Description Vasiliy Kotikov 2005-06-29 05:31:06 EDT
Description of problem:
The problem appeared after updating to the latest release squid-2.5.STABLE6-3.4E.9.
After several hours squid crached...
So I had to roll back to use previous squid-2.5.STABLE6-3.4E.5

Version-Release number of selected component (if applicable):

How reproducible:
Don't know how but try to use my configuration file squid.conf.
squid.conf and cache.log are included in the field Additional Information
Actual results:
service squid was not running.
and I noticed that md5 checksum of cache was not ok.
diskd was used to store cache.

Expected results:
should be working

Additional info:
cache.log has some comment, see "2005/06/28 18:53:09| Starting Squid Cache
version 2.5.STABLE6 for i386-redhat-linux-gnu..."
Comment 1 Vasiliy Kotikov 2005-06-29 05:31:06 EDT
Created attachment 116116 [details]
zipped file with cache.log and squid.conf
Comment 2 Maciej Żenczykowski 2005-06-29 10:09:13 EDT
IMHO dup of 160704
Comment 3 Martin Stransky 2005-07-08 05:30:49 EDT
Could you please check STABLE6-3.4E.6 version? src.rpm is here:

Comment 4 Martin Stransky 2005-08-29 10:31:58 EDT
Could you please enable debugging and send me the cache.log file, when squid
crashes? Please use this one: debug_options ALL,9
p.s.: The cache.log file will be very big...
Comment 5 Vasiliy Kotikov 2005-08-30 01:08:59 EDT
http://people.redhat.com/stransky/squid/squid-2.5.STABLE6-3.4E.6.src.rpm was 
downloaded and rebuilt. It is working fine from the half of July OK. ... Ok 
I'll do upgrade to latest release thru RHN and set debug level to 9.

The log file location will be reported later.
Comment 6 Martin Stransky 2005-08-30 02:54:11 EDT
Could you please attach the /etc/squid/cachemgr.conf file?
Comment 7 Vasiliy Kotikov 2005-08-30 02:59:33 EDT
I do not have such a file... Maybe you mean squid.conf ?
Comment 8 Martin Stransky 2005-08-30 03:21:35 EDT
cachemgr.conf is a new file provided by squid-2.5.STABLE6-3.4E.9, if you still
have the 3.4E.6 package, you won't have it. If you haven't modified it, you can
forget about it.
Comment 9 Martin Stransky 2005-09-13 08:57:24 EDT
Could you please create and attach a strack trace when squid crashes? How to is
here - http://people.redhat.com/stransky/squid.html
Comment 10 Martin Stransky 2005-09-30 04:55:01 EDT
Due to PIE gdb can't read symbols from the debug package. If your squid crashes
(and it isn't a problem with assertion) and you can't obtain a stack-trace there
are new packages which aren't compiled with PIE:

Comment 11 Martin Stransky 2005-10-11 05:34:52 EDT

*** This bug has been marked as a duplicate of 165367 ***

Note You need to log in before you can comment on or make changes to this bug.