Bug 162047 - Partitioning and yaboot fail on Blue and White G3 Power Macintosh
Partitioning and yaboot fail on Blue and White G3 Power Macintosh
Status: CLOSED DUPLICATE of bug 162046
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-29 10:01 EDT by Bruce-Robert Pocock
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-29 10:13:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce-Robert Pocock 2005-06-29 10:01:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Epiphany/1.4.4

Description of problem:
Disk druid and/or Yaboot don't seem to work on Power Mac Blue&White G3




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
This is a Blue & White G3, which are notorious for firmware "issues." The machine was previously running MacOS 10.3 with all updates, including all firmware updates.

Initial attempts to boot the FC4 CD failed. The internal HP CD-RW was replaced with a generic (possibly Toshiba? but the label was removed) 24x ATAPI CD-ROM and I was able to manually boot via Command+Option+O+F (to enter Open Firmware) followed by ejecting the CD, re-inserting it, and then running "boot cd:,\\:tbxi". (Without ejecting and re-inserting I got an error that OF failed to read Block 0.)

Once into Anaconda, all seemed to go well. Using Disk Druid, I created a 1MiB Apple_Bootstrap partition, a 1GiB swap, and the remainder of the disc (about 114GiB) root partition. (No LVM) The installation ("Personal Desktop" with all defaults) proceeded normally, and the "Finished (Reboot)" screen appeared.

After ejecting the CD and rebooting, the firmware displayed the "Where is the System folder?" flashing icon.

Manually launching via OF did not work using either of "hd:1,\\:tbxi" nor "hd:1,\yaboot" nor even my guess of "hd:1,yaboot" and various possible other parititions numbers (1..5).

Booting again from the CD-ROM, "boot cd:,\\:tbxi" - "linux rescue" the root partition mounted sucessfully under /mnt/sysimage. "parted" showed that the disklabel type was "msdos" with the partitions assigned: hda1 => bootstrap, hda2 => root, hda3 => swap. "mkofboot" and "ybin" ran, apparently successfully, from the chroot, and "hmount"/"hdir" from hfsutils showed the expected 3 files on the bootstrap partition.

Suspicious of the MS-DOS disklabel type, I wiped with Parted and recreated a Macintosh disklabel. This re-arranged the partition numbers, since the Macintosh disklabel itself is considered "partition 1," 2 => bootstrap, 3 => swap, 4 => root. I also set the "root," "boot," and "swap" flags in parted.

For paranoia's sake, I also ran "mkswap", "mke2fs"+"tune2fs -j", and "hformat" on the appropriate partitions.

Re-running Anaconda, however, brings up an error in the Disk Druid step. I can sucessfully tell Anaconda to use the swap and root partitions, however, the Apple_Bootstrap partition brings up an error saying,

"The size of the Apple_Bootstrap ( 1.000 M) is bigger than the maximum allowed size of 1M"

I've tried this now with the Apple_Bootstrap size at precisely 1M (running "from 1 to 2" in parted) and slightly under (running from 0.032 - just after the disklabel - to 2), to no avail.

Additional info:
Comment 1 Bruce-Robert Pocock 2005-06-29 10:13:11 EDT

*** This bug has been marked as a duplicate of 162046 ***

Note You need to log in before you can comment on or make changes to this bug.