Bug 16205 - linuxconf requires /etc/init.d
linuxconf requires /etc/init.d
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-14 19:49 EDT by Mike Bird
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-20 07:15:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Bird 2000-08-14 19:49:53 EDT
I need a Rawhide linuxconf in order to handle IP forwarding in
/etc/sysctl.conf (see #10922)
I downloaded the latest: linuxconf-1.19r2-2.i386.rpm
It won't install because of a dependency on /etc/init.d
Not sure if this is a typo or a planned change in the directory heirarchy

(It gets worse)

I only see the failed dependency if I try to -hFv it along with
initscripts-5.44-1.i386.rpm
If I try to -hFv linuxconf on it's own, rpm hangs and needs kill -9 to
break out

The downloaded rpm's are OK according to --checksig

Current installed versions: 
  initscripts-5.35-1    (recent from Rawhide because of bug #12859)
  linuxconf-1.17r2-6  (from RedHat 6.2)
Comment 1 Nalin Dahyabhai 2000-08-20 00:15:40 EDT
This is a planned change.  The new file is owned by the new chkconfig and
initscripts packages.  It's not a hard dependency; installing the new package
with --nodeps to get around this one shouldn't hurt.
If RPM is hanging, try running it with "strace rpm -whateveroptions packages..."
and see if you can isolate where it's hanging.  Which version of RPM is it?
Comment 2 Mike Bird 2000-08-20 07:15:18 EDT
We were and are using rpm-3.0.5-9.6x.  We've been thrashing around since 
submitting the report and as a result the behavior has changed.  With 
initscripts-5.35-1 in place we were able to upgrade linuxconf-1.17r2-6 to 
linuxconf-1.19r2-2.

We're now trying to upgrade to initscripts-5.44-1 but this gaves a failed 
dependency on /etc/init.d which is an existing symbolic link.  It looks as 
though initscripts thinks that it's going to delete the link.

Also, the newly installed linuxconf won't run.  It needs libncurses.so.5 to run 
but the RPM doesn't "require" it.  (Yeah, I'll download an RPM from RawHide to 
fix it but I thought you'd want to know.)
Comment 3 Trond Eivind Glomsrxd 2000-09-13 18:24:14 EDT
It requires it because it references /etc/init.d/functions.

Note You need to log in before you can comment on or make changes to this bug.