Bug 162105 - REMOTE X APPLICATION FAILES ON THE LOCAL MACHINE
REMOTE X APPLICATION FAILES ON THE LOCAL MACHINE
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xterm (Show other bugs)
4.0
ia32e Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-29 17:54 EDT by Farid Afshar
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-29 18:25:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Farid Afshar 2005-06-29 17:54:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
Xapps on remote systems fail to run on the local machine: 
[root@rhodan ~]# xhost +
access control disabled, clients can connect from any host
[root@rhodan ~]# set|grep DIS
DISPLAY=:0.0
[root@rhodan ~]# export DISPLAY=rhodan:0.0
[root@rhodan ~]# xclock
Error: Can't open display: rhodan:0.0

I can no longer run an x application on a remote system and display it on the local machine. THIS USED WORK WITH EARLIER RED HAT OS.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.xhost +
2.export DISPLAY=local machine name (e.g. rohdan)
3.xclock
  

Actual Results:  Error: Can't open display: rhodan:0.0

Expected Results:  xclock should have been loaded and running

Additional info:

I see this only with Red Hat Enterprise Linux AS release 4 (Nahant)
Comment 1 Mike A. Harris 2005-06-29 18:25:14 EDT
X11 over TCP is disabled by default in all Red Hat operating system releases
since about Red Hat Linux 7.0 and must be manually re-enabled by the
administrator or user prior to remote X11 applications working over direct
TCP.

Red Hat strongly recommends using ssh with X11 forwarding instead of enabling
communication with the X server over TCP, as ssh traffic is far more secure.
By default however, X11 forwarding is disabled in openssh in RHEL4, so must
be manually enabled.

If you have an appropriate support contract with Red Hat, please
contact Red Hat global support services at http://www.redhat.com/apps/support
or via telephone at 1-888-RED-HAT1 if you require assistance reconfiguring
your system to use ssh with X11 forwarding, or to enable the X server to
listen to TCP connections.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.