Bug 16211 - Installer adds conflicting options ZAxisMapping and Emulate3Buttons in 3.3.x XF86Config
Summary: Installer adds conflicting options ZAxisMapping and Emulate3Buttons in 3.3.x ...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard: Winston gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-15 02:21 UTC by Brian Ryner
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-20 00:29:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Ryner 2000-08-15 02:21:27 UTC
If you select a wheel-mouse during the install (such as Logitech
MouseMan+/FirstMouse+), and a 3.3.x X server is installed, the installer
will put both "ZAxisMapping 4 5" and "Emulate3Buttons" in the XF86Config
file.  The Emulate3Buttons option causes the ZAxisMapping to not work at
all.  It does not seem to do this in the XF86Config-4 file.

Comment 1 Glen Foster 2000-08-15 19:10:26 UTC
This defect is considered MUST-FIX for Winston Gold release

Comment 2 Trond Eivind Glomsrxd 2000-08-16 22:24:36 UTC
I'll need to fix that for XConfigurator as well...

Comment 3 Trond Eivind Glomsrxd 2000-08-16 22:36:32 UTC
Fixed for Xconfigurator in CVS

Comment 4 Adrian Likins 2000-08-19 05:27:26 UTC
Post fresh install, emulate3Buttons doesnt seem to work
on RC1. Running mouseconfig and then Xconfigurator
seems to make it work again.

Comment 5 Matt Wilson 2000-08-19 20:02:14 UTC
The installer does not write "emulate3" for the  Logitech
MouseMan+/FirstMouse+.  Are you sure that's the one you selected?

This was a GUI install?


Comment 6 Trond Eivind Glomsrxd 2000-08-19 20:06:52 UTC
That's not the issue, the point is that ZAxisMapping 4 5 is now written
unconditionally for XFree 3.3, which it can't: It can't be written when
emulate3button is set.

Comment 7 Trond Eivind Glomsrxd 2000-08-19 20:37:32 UTC
Turned off ZAxisMapping by default, and commented the option.

Comment 8 Brian Ryner 2000-08-19 20:45:49 UTC
Hm, I was afraid this might happen with this bug.  Why can't you just keep track
of which mice on the list have a wheel, and insert the ZAxisMapping and NOT
insert Emulate3Buttons for those mice, and do the reverse for all other mice?


Comment 9 Trond Eivind Glomsrxd 2000-08-19 20:51:39 UTC
We don't have information about wheels...

The best thing would be to add the ZAxisMapping line if emulate3buttons isn't
set, but I'm not that familiar with the installer and don't want to introduce
code changes now.

Comment 10 Brian Ryner 2000-08-19 21:06:26 UTC
This just seems a little less than optimal... I originally filed the bug because
the wheel didn't work automatically after configuration, and with this
resolution, it still won't.

Why does this problem only happen in the 3.3.6 XF86Config?  Is Emulate3Buttons
not used at all in the 4.0 config?


Comment 11 Trond Eivind Glomsrxd 2000-08-19 21:18:32 UTC
XFree4 does it another way - Option "Emulate3Buttons" "True" or something
similar.

Comment 12 Brian Ryner 2000-08-20 00:29:01 UTC
Yes, but the generated XF86Config-4 file did not have the Emulate3Buttons
option, only the ZAxisMapping option... which is why that configuration works
for a wheel mouse.



Note You need to log in before you can comment on or make changes to this bug.