Bug 162111 - lynx -use_mouse freezes on start
lynx -use_mouse freezes on start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lynx (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-29 18:39 EDT by Bertil Askelid
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-30 14:03:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bertil Askelid 2005-06-29 18:39:49 EDT
Description of problem:

lynx -use_mose is unable to start fully but freezes in the middle before comming up.

Version-Release number of selected component (if applicable):

lynx-2.8.5-23

How reproducible:

Always.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2005-06-30 07:18:54 EDT
Works fine here.  Could you describe your problem a bit more fully?
Comment 2 Bertil Askelid 2005-06-30 12:52:33 EDT
   I've been doing some more digging to recreate exactly what is
   happening and why.

   I can start "lynx -use_mouse" without any problems and full
   functionality in xterm and rxvt. I first start the xterm with the
   command

      xterm +sb -sl 0

   and then manually type the lynx command on the csh command
   line.  Ditto rxvt. No problems.

   However, when I combine the two:

      xterm +sb -sl 0 -e lynx -use_mouse

   I only get a blank xterm screen. Something is happening as I type "q"
   and then "y" to get out of lynx and close the xterm.

   For

      rxvt +sb -sl 0 -e lynx -use_mouse

   the rxvt window shows nothing and reacts to nothing. Has to be killed
   from X.

   Versions:

      lynx-2.8.5-23
      xterm-200-6
      rxvt-2.7.10-1
Comment 3 Tim Waugh 2005-06-30 13:46:24 EDT
Here's what I get.  Both of these work fine:

rxvt +sb -sl 0 -tn xterm -e lynx -use_mouse
xterm +sb -sl 0 -e lynx -use_mouse

If I omit '-tn' from the rxvt command line lynx cannot start because the TERM
environment variable gets set (for some reason) to xterm-debian.

So I still don't see the problem here. :-/
Comment 4 Bertil Askelid 2005-06-30 14:03:55 EDT
That does it! The "-tn xterm" option added to the rxvt command solved the
problem. For some reason, rxvt set $TERM to rxvt by default. For lynx to work it
has to be xterm as you pointed out.

Thanks! The bug can be closed!

Note You need to log in before you can comment on or make changes to this bug.