Bug 162112 - ACPI resume doesn't start /dev/sda on Inspiron 9300
ACPI resume doesn't start /dev/sda on Inspiron 9300
Status: CLOSED DUPLICATE of bug 169201
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-29 19:55 EDT by Bertil Askelid
Modified: 2015-01-04 17:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-24 15:38:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ACPI related kernel printouts from reboot for kernel-2.6.13-1.1526_FC4 (4.66 KB, text/plain)
2005-10-01 18:13 EDT, Bertil Askelid
no flags Details

  None (edit)
Description Bertil Askelid 2005-06-29 19:55:47 EDT
Description of problem:

After ACPI resume, screen is coming back, can move mouse, can type to Emacs
buffer. However, HD /dev/sda is not started. The disk lamp on my laptop is
shining constantly. Only way out is to power down the system.

I'm running Inspiron 9300 with:
~> lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root
Port (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem
Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc M22 [Radeon Mobility M300]
03:00.0 Ethernet controller: Broadcom Corporation BCM4401-B0 100Base-TX (rev 02)
03:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b3)
03:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller (rev 08)
03:01.2 Class 0805: Ricoh Co Ltd SD Card reader (rev 17)
03:03.0 Network controller: Intel Corporation PRO/Wireless 2915ABG MiniPCI
Adapter (rev 05)
04:00.0 Ethernet controller: D-Link System Inc DFE-690TXD CardBus PC Card (rev 10)
~> 


Version-Release number of selected component (if applicable):

kernel-2.6.11-1.1369_FC4

How reproducible:

Always.

Steps to Reproduce:
1.echo -n mem > /sys/power/state via /etc/apci/events and actions.
2.Goes nicely to sleep. Power lamp is slowly blinking as expected. HD, screen down.
3.Wake up by opening lid.
  
Actual results:

Screen is back up, keyboard and mouse works. HD remaines down.

Expected results:



Additional info:
Comment 1 Bertil Askelid 2005-07-02 13:56:34 EDT
Tested kernel-2.6.12-1.1387_FC4 -- same problem.
Comment 2 Dave Jones 2005-07-15 17:07:25 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 3 Bertil Askelid 2005-07-15 22:56:06 EDT
Tried this on linux-2.6.12-1.1398_FC4. Same result as before.

Here are some error printouts sent to the console while /dev/sda is stuck:

ata1: command 0xca timeout stat 0xd0 host_stat 0x4
ata1: status=0xd0 { Busy }
end_request: I/O error, dev sda sector 43589216
Buffer I/O error on device sda6 logical block 161251
lost page write due to I/O error on sda6
ATA: abnormal status 0xD0 on port 0x1F7

/dev/sda6 is mounted as "/".
Comment 4 Didier 2005-08-14 18:05:54 EDT
Bertil, which I9300 do you own ?

when suspending my I9300 (WUXGA, GeForce6800) in single user, it never resumes
(black screen, no activity) ; tested with 2.6.12-1.1398.

According to http://www.ussg.iu.edu/hypermail/linux/kernel/0505.2/1631.html,
Jens Axboe recently (?) developed some SATA resume patches.
Also, there are libata patches (which I did not try yet) on
http://www.rtr.ca/dell_i9300/ .
Comment 5 Bertil Askelid 2005-08-16 08:40:44 EDT
Inspirion 9300:

   CPU:     Intel Pentium M processor 2.00GHz stepping 08 cache 2 MByte
   IDE:     Intel 82801FBM (ICH6M) SATA Controller
   HD:      Fujitsu MHV2100AH 100 GByte @ /dev/sda
   Video:   ATI Mobility Radeon X300 128 MByte
   Monitor: 17" WUXGA 1920x1200 TrueLife
Comment 6 Thomas Mintel 2005-08-23 19:46:21 EDT
I have the same problem.  I have an inspiron 9300 and when I power to mem, all
works fine.  When I try to bring it back up there is a black screen and the
harddrive is constantly being used, but no results.  
Comment 7 Didier 2005-08-31 05:59:23 EDT
As the ACPI resume behaviour of my Inspiron 9300 (Nvidia GF6800Go instead of ATI
Mobility X300) fundamentally differs, I've created a new bug #167168.
Comment 8 Dave Jones 2005-09-30 02:09:19 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 9 Bertil Askelid 2005-10-01 18:09:43 EDT
Using kernel 2.6.13-1.1526_FC4, it goes nicely to sleep on echo -n mem >
/sys/power/state when I close the lid. Disk down, power lamp slowly pulsating.

On opening the lid, system starts up, goes through the BIOS password request,
flashes the disk lamp quickly and then gets back to a blank screen with the word
"Linu" in pretty large yellow letters in the left hand corner. And there it is
stuck. No reaction to anything. Can't go to another screen using M-C-F2 etc.
Only power cycle gets me out of this.

I'm using Inspiron 9300 w/ hw config as stated in comment #5.
Comment 10 Bertil Askelid 2005-10-01 18:13:01 EDT
Created attachment 119511 [details]
ACPI related kernel printouts from reboot for kernel-2.6.13-1.1526_FC4
Comment 11 Dave Jones 2005-11-10 14:07:30 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 12 Bertil Askelid 2005-11-12 09:13:04 EST
The bug still remains with the same symptoms as described
above. kernel-2.6.14-1.1637_FC4 does not fix it.
Comment 13 Bertil Askelid 2005-12-17 23:19:14 EST
kernel-2.6.14-1.1653_FC4 has improved the situation. I'm getting passed the
locked "Linu" screen, but now the disk is busy, generating ATA abnormal printouts. 
No printring at all to /var/log/messages after resume. Still, I can move the mouse
in X and the cursor in Emacs.

I also have this printout on the login screen:

   Debug: sleeping function called from invalid context at mm/slab.c:2486.

The following acpi/ACPI related printouts are found in /var/log/messages at reboot:

Dec 17 19:38:08 z kernel: shpchp: acpi_shpchprm:\_SB_.PCI0 evaluate _BBN fail=0x5
Dec 17 19:38:08 z kernel: shpchp: acpi_shpchprm:get_device PCI ROOT HID fail=0x5
Dec 17 19:38:11 z kernel: ibm_acpi: ec object not found

Dec 17 19:33:33 z kernel: ACPI: PCI interrupt for device 0000:04:00.0 disabled
Dec 17 19:38:00 z kernel: ACPI: PM-Timer IO Port: 0x1008
Dec 17 19:38:01 z kernel: ACPI: setting ELCR to 0200 (from 0e80)
Dec 17 19:38:01 z kernel: ACPI: bus type pci registered
Dec 17 19:38:01 z kernel: ACPI: Subsystem revision 20050916
Dec 17 19:38:01 z kernel: ACPI: Interpreter enabled
Dec 17 19:38:01 z kernel: ACPI: Using PIC for interrupt routing
Dec 17 19:38:01 z kernel: ACPI: PCI Root Bridge [PCI0] (0000:00)
Dec 17 19:38:01 z kernel: ACPI: Assume root bridge [\_SB_.PCI0] bus is 0
Dec 17 19:38:02 z kernel: ACPI: PCI Interrupt Link [LNKA] (IRQs 9 10 *11)
Dec 17 19:38:02 z kernel: ACPI: PCI Interrupt Link [LNKB] (IRQs 5 7) *10
Dec 17 19:38:02 z kernel: ACPI: PCI Interrupt Link [LNKC] (IRQs *9 10 11)
Dec 17 19:38:02 z kernel: ACPI: PCI Interrupt Link [LNKD] (IRQs 5 *7 9 10 11)
Dec 17 19:38:02 z kernel: ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 5 6 7 9 10
11 12 14 15) *0, disabled.
Dec 17 19:38:02 z kernel: ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 5 6 7 9 10
11 12 14 15) *0, disabled.
Dec 17 19:38:02 z kernel: ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 5 6 7 9 10
11 12 14 15) *0, disabled.
Dec 17 19:38:02 z kernel: pnp: PnP ACPI init
Dec 17 19:38:02 z kernel: pnp: PnP ACPI: found 10 devices
Dec 17 19:38:02 z kernel: PCI: Using ACPI for IRQ routing
Dec 17 19:38:03 z kernel: ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
Dec 17 19:38:03 z kernel: ACPI: PCI Interrupt 0000:00:01.0[A] -> Link [LNKA] ->
GSI 11 (level, low) -> IRQ 11
Dec 17 19:38:03 z kernel: ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 7
Dec 17 19:38:03 z kernel: ACPI: PCI Interrupt 0000:03:01.0[A] -> Link [LNKD] ->
GSI 7 (level, low) -> IRQ 7
Dec 17 19:38:04 z kernel: ACPI: PCI Interrupt 0000:00:01.0[A] -> Link [LNKA] ->
GSI 11 (level, low) -> IRQ 11
Dec 17 19:38:04 z kernel: ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3] C4[C3])
Dec 17 19:38:04 z kernel: ACPI: Processor [CPU0] (supports 8 throttling states)
Dec 17 19:38:04 z kernel: ACPI: Thermal Zone [THM] (47 C)
Dec 17 19:38:05 z kernel: ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
Dec 17 19:38:05 z kernel: ACPI: PCI Interrupt 0000:00:1e.3[B] -> Link [LNKB] ->
GSI 5 (level, low) -> IRQ 5
Dec 17 19:38:05 z kernel: ACPI: PCI interrupt for device 0000:00:1e.3 disabled
Dec 17 19:38:06 z kernel: ACPI wakeup devices: 
Dec 17 19:38:06 z kernel: ACPI: (supports S0 S3 S4 S5)
Dec 17 19:38:06 z kernel: ACPI: PCI Interrupt 0000:00:1f.2[B] -> Link [LNKB] ->
GSI 5 (level, low) -> IRQ 5
Dec 17 19:38:07 z kernel: ACPI: PCI Interrupt 0000:03:00.0[A] -> Link [LNKA] ->
GSI 11 (level, low) -> IRQ 11
Dec 17 19:38:08 z kernel: ACPI: PCI Interrupt 0000:03:03.0[A] -> Link [LNKB] ->
GSI 5 (level, low) -> IRQ 5
Dec 17 19:38:08 z kernel: ACPI: PCI interrupt for device 0000:03:03.0 disabled
Dec 17 19:38:08 z kernel: ACPI: PCI Interrupt 0000:00:1e.2[A] -> Link [LNKA] ->
GSI 11 (level, low) -> IRQ 11
Dec 17 19:38:08 z kernel: ACPI: PCI Interrupt 0000:00:1e.3[B] -> Link [LNKB] ->
GSI 5 (level, low) -> IRQ 5
Dec 17 19:38:08 z kernel: ACPI: PCI Interrupt 0000:00:1d.7[A] -> Link [LNKA] ->
GSI 11 (level, low) -> IRQ 11
Dec 17 19:38:09 z kernel: ACPI: PCI Interrupt 0000:00:1d.0[A] -> Link [LNKA] ->
GSI 11 (level, low) -> IRQ 11
Dec 17 19:38:09 z kernel: ACPI: PCI Interrupt 0000:00:1d.1[B] -> Link [LNKB] ->
GSI 5 (level, low) -> IRQ 5
Dec 17 19:38:09 z kernel: ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 9
Dec 17 19:38:09 z kernel: ACPI: PCI Interrupt 0000:00:1d.2[C] -> Link [LNKC] ->
GSI 9 (level, low) -> IRQ 9
Dec 17 19:38:09 z kernel: ACPI: PCI Interrupt 0000:00:1d.3[D] -> Link [LNKD] ->
GSI 7 (level, low) -> IRQ 7
Dec 17 19:38:10 z kernel: ACPI: PCI Interrupt 0000:03:01.0[A] -> Link [LNKD] ->
GSI 7 (level, low) -> IRQ 7
Dec 17 19:38:10 z kernel: ACPI: PCI Interrupt 0000:03:01.1[B] -> Link [LNKC] ->
GSI 9 (level, low) -> IRQ 9
Dec 17 19:38:10 z kernel: ACPI: AC Adapter [AC] (on-line)
Dec 17 19:38:11 z kernel: ACPI: Battery Slot [BAT0] (battery present)
Dec 17 19:38:11 z kernel: ACPI: Lid Switch [LID]
Dec 17 19:38:11 z kernel: ACPI: Power Button (CM) [PBTN]
Dec 17 19:38:11 z kernel: ACPI: Sleep Button (CM) [SBTN]
Dec 17 19:38:11 z kernel: ACPI: Video Device [VID] (multi-head: yes  rom: no 
post: no)
Dec 17 19:38:13 z kernel: ACPI: PCI Interrupt 0000:04:00.0[A] -> Link [LNKD] ->
GSI 7 (level, low) -> IRQ 7
Comment 14 Bertil Askelid 2005-12-24 13:04:57 EST
Finally, I've found an up-to-date ACPI HOWTO:

   http://www.columbia.edu/~ariel/acpi/acpi_howto.txt

In there, I found the reason to why suspend-to-RAM (S3) fails to resume
completely but instead comes up with video OK, X OK, but disk lamp continuously
lit up. So, I hope that this patch will fix the problem and my Inspiron 9300
with a SATA drive: ata1: SATA max UDMA/133 cmd 0x1F0 ctl 0x3F6 bmdma 0xBFA0 irq 14.

13.1. SATA driver

   Suspend to RAM/Resume for the SATA subsystem is incomplete. Jens Axboe has a
   patch that has worked for some people including me. If you have a laptop
   with a device that is recognized as SATA (this includes devices that are
   PATA but have a PATA->SATA bridge, like the Dell XPS Gen 2), you should
   consider     using    this    patch.    You    can    find    it    at
   [186]http://lkml.org/lkml/diff/2005/9/23/97/1 and it applies cleanly to this
   kernel. SUSE, Ubuntu, and some other distributions have this patch already
   applied. A secondary patch that is needed sometimes on SUSE kernels is at
   [187]http://lkml.org/lkml/diff/2005/9/23/129/1. Fortunately, there is some
   discussion   of   getting   this  patch  merged  real  soon  now;  see
   [188]http://lkml.org/lkml/2005/9/21/11 for the full thread.

   Symptoms of the problem include a message in your logs like
        kernel: hda: status timeout: status=0xd0 { Busy }
        kernel: hda: no DRQ after issuing MULTWRITE_EXT

   or having the hard drive LED remain on continuously and your system lock up
   after resume.
Comment 15 Dave Jones 2005-12-24 15:38:06 EST

*** This bug has been marked as a duplicate of 169201 ***

Note You need to log in before you can comment on or make changes to this bug.