Bug 16221 - updmodules build script breaks module deps
Summary: updmodules build script breaks module deps
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-15 09:09 UTC by Nigel Metheringham
Modified: 2007-04-18 16:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-15 22:49:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nigel Metheringham 2000-08-15 09:09:42 UTC
updmodules (in misc/src/trees on install directory structure), builds
a set of module dependancies for the install/BOOT kernel.
However it only allows one line of depandancies per module, and depmod
outputs one line of dependancy data *per* depedancy.
Hence this code:-
    /sbin/depmod -m $KERNELROOT/boot/System.map-$version -i -e *.o | \
          grep ':.*o' | \   ...etc

screws up the NFS dependancies for boot set built with 2.2.16 kernels.

I did a quick hack to fix this:-
    /sbin/depmod -m $KERNELROOT/boot/System.map-$version -i -e *.o | \
	  perl -pe 's/\\\n//' | \
          grep ':.*o' | \

its not good or pretty, but it works :-)

Obviously other things need modifying for 2.2.16 due to size constraints
but this one is a design showstopper

[Not checked against the current beta set]

Comment 1 Erik Troan 2000-08-15 22:49:22 UTC
Fixed in pinstripe.


Note You need to log in before you can comment on or make changes to this bug.