Bug 1622248 - Installer does not start in live images since Fedora-Rawhide-20180823.n.0 (anaconda-29.24-1.fc30)
Summary: Installer does not start in live images since Fedora-Rawhide-20180823.n.0 (an...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F29BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-08-24 21:30 UTC by Adam Williamson
Modified: 2018-09-03 18:31 UTC (History)
13 users (show)

Fixed In Version: anaconda-29.24.1-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-03 18:31:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1595415 None None None 2019-06-27 16:34:07 UTC

Internal Links: 1595415

Description Adam Williamson 2018-08-24 21:30:08 UTC
In Fedora-Rawhide-20180823.n.0 , when the KDE live install test attempts to run anaconda, it crashes. Running from a console shows the error:

anaconda 29.24-1.fc30 for Fedora 30 (pre-release) started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2 and in second TMUX pane (ctrl+b, then press 2)
 * when reporting a bug add logs from /tmp as separate text/plain attachments
Traceback (most recent call last):
  File "/sbin/anaconda", line 575, in <module>
    startup_utils.set_installation_method_from_anaconda_options(anaconda, ksdata)
  File "/usr/lib64/python3.7/site-packages/pyanaconda/startup_utils.py", line 407, in set_installation_method_from_anaconda_options
    ksdata.method.method = source.method_type
  File "/usr/lib/python3.7/site-packages/pykickstart/commands/method.py", line 91, in __setattr__
    super(FC3_Method, self).__setattr__(name, value)
  File "/usr/lib/python3.7/site-packages/pykickstart/commands/method.py", line 69, in method
    self._get_command(value).seen = True
  File "/usr/lib/python3.7/site-packages/pykickstart/commands/method.py", line 48, in _get_command
    raise AttributeError("Unknown method: {}".format(method))
AttributeError: Unknown method: livecd

I believe this is likely caused by f1d07a208339d813e1246171ea90e533982d5374 , part of the fix for https://bugzilla.redhat.com/show_bug.cgi?id=1595415 .

This is an obvious Beta blocker as it renders live installs impossible (I'm assuming the same bug will affect the Workstation live too, nothing seems KDE-specific about this).

Comment 1 Vendula Poncova 2018-08-27 13:41:59 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/1580

Comment 2 Stephen Gallagher 2018-08-27 16:34:27 UTC
+1 blocker

Comment 3 Adam Williamson 2018-08-29 21:47:54 UTC
This made it into f29 tag just before Bodhi activation, so setting ON_QA - when we finally get a working compose we can confirm it's fixed.

Comment 4 Mohan Boddu 2018-08-29 21:53:54 UTC
+1 Blocker

Comment 5 Kevin Fenzi 2018-08-29 23:05:41 UTC
+1 blocker

Comment 6 Geoffrey Marr 2018-08-30 14:41:33 UTC
Voted as a blocker in-bug:

The decision to classify this bug as an "AcceptedBlocker" (Beta) was made as it violates the following criteria:

"The installer must run when launched normally from the release-blocking images."

Comment 7 Kamil Páral 2018-09-03 13:47:24 UTC
This seems to work fine for me with Fedora-Workstation-Live-x86_64-29-20180902.n.0.iso . But somebody should verify with KDE as well.

Comment 8 Adam Williamson 2018-09-03 18:31:20 UTC
Yes, it's fine, I thought I'd closed it already.


Note You need to log in before you can comment on or make changes to this bug.