Bug 1622325 - Documentation needs to be updated to show "zstd" is an option for btrfs mount compression
Summary: Documentation needs to be updated to show "zstd" is an option for btrfs mount...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: btrfs-progs
Version: 27
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Josef Bacik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-26 05:55 UTC by Rick
Modified: 2018-09-22 19:45 UTC (History)
6 users (show)

Fixed In Version: btrfs-progs-4.17.1-1.fc28 btrfs-progs-4.17.1-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-11 16:54:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Rick 2018-08-26 05:55:22 UTC
Description of problem:

Documentation related to btrfs compression options needs to be upgraded.

Version-Release number of selected component (if applicable):

util-linux-2.30.2-3.fc27.x86_64
btrfs-progs-4.11.1-3.fc27.x86_64
Others?

How reproducible:

Every time.

Steps to Reproduce:
1. man mount or man 5 btrfs
2. Read about compression options
3. Note lack of "zstd" documentation

Actual results:

Only "zlib", "lzo", and "no" are mentioned in the documentation

Expected results:

All compression options for btrfs, including "zstd" should be documented.

Additional info:

Note that the "zstd" compression option has been available and working for some time now.  The actual "zstd" compression seems to work fine.  It's just that the documentation hasn't caught up yet.  I also wonder if there are other filesystems that have a compression option and their docs need to be updated too.

Comment 1 Karel Zak 2018-09-06 09:48:48 UTC
$ whereis -m btrfs
btrfs: /usr/share/man/man8/btrfs.8.gz /usr/share/man/man5/btrfs.5.gz

$ rpm -qf /usr/share/man/man5/btrfs.5.gz
btrfs-progs-4.11.1-3.fc27.x86_64

Reassign to btrfs-progs.

Comment 2 Rick 2018-09-06 09:56:27 UTC
Note that the documentation for the mount command in util-linux also needs to be updated.

Comment 3 Karel Zak 2018-09-06 11:03:38 UTC
The man page mount.8 does not contain btrfs section any more (since util-linux v2.32 -- f28). I have doubts it's important enough to fix it in F27 by any extra patch.

Comment 4 Rick 2018-09-06 11:38:45 UTC
Understood.

Comment 5 Fedora Update System 2018-09-06 12:41:53 UTC
btrfs-progs-4.17.1-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-7234288f31

Comment 6 Fedora Update System 2018-09-06 12:42:03 UTC
btrfs-progs-4.17.1-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9dba618394

Comment 7 Eric Sandeen 2018-09-06 12:55:20 UTC
I pushed btrfs-progs-4.17.1 to testing. 

from the current btrfs(5):


       compress, compress=type, compress-force, compress-force=type
           (default: off)

           Control BTRFS file data compression. Type may be specified as zlib,
           lzo, zstd or no (for no compression, used for remounting).

...

       compress_zstd
           (since: 4.14)

           the zstd compression has been used on the filesystem, either as a
           mount option or via btrfs filesystem defrag.

Comment 8 Fedora Update System 2018-09-07 15:18:34 UTC
btrfs-progs-4.17.1-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9dba618394

Comment 9 Fedora Update System 2018-09-07 17:11:24 UTC
btrfs-progs-4.17.1-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-7234288f31

Comment 10 Fedora Update System 2018-09-11 16:54:42 UTC
btrfs-progs-4.17.1-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2018-09-22 19:45:53 UTC
btrfs-progs-4.17.1-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.