Bug 16224 - Backspace is not working right
Summary: Backspace is not working right
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: termcap   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-15 10:37 UTC by Richard Allen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-15 10:37:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Allen 2000-08-15 10:37:46 UTC
When I telnet/rlogin/ssh into non RedHat (or non linux..  cant say. I only
use RedHat) systems backspace always acts up.  If that other system is
running bash then the problem is not as severe, since bash recognises ^H
and ^?.  However, if I start vi or any other terminal program things go
amok again.   RedHat 6.2 is like this also.  6.1 and older was ok.

Comment 1 Bernhard Rosenkraenzer 2000-08-15 11:27:48 UTC
I presume this happens in X only?
If so, it's because we changed the xterm definition to match standards; the
other OSes you're telnetting to need fixing.
Alternatively, add our xterm entry to their termcap database under a different
name and export TERM=xterm-redhat or whatever.

Comment 2 Richard Allen 2000-08-15 12:16:42 UTC
Hmm..  ok.  So I need to submit bugreports to atleast HP, Sun, NCR and SCO ?

remy# uname -a
HP-UX remy B.10.20 E 9000/813 2003456460 8-user license
remy# echo $TERM
vt100
remy# ^?
ksh: ^?:  not found




Note You need to log in before you can comment on or make changes to this bug.