Bug 162254 - Unable to execute netbootimage created with mkzimage
Unable to execute netbootimage created with mkzimage
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ppc64-utils (Show other bugs)
4.0
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks: 176344
  Show dependency treegraph
 
Reported: 2005-07-01 13:56 EDT by David Huffman
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-21 13:45:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.registers from OF Prompt (520 bytes, text/plain)
2005-07-01 14:57 EDT, David Huffman
no flags Details

  None (edit)
Description David Huffman 2005-07-01 13:56:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Unable to execute the kernel from network boot image (zImage.initrd) created using /usr/bin/mkzimage script.

Version-Release number of selected component (if applicable):
vmlinuz-2.6.9-5.EL zImage.stub-2.6.9-5.EL

How reproducible:
Always

Steps to Reproduce:
1. Create custom initrd image (works on other Linux platforms)
2. run the command: mkzimage vmlinuz-2.6.9-5.EL no no storix-initrd.img zImage.stub-2.6.9-5.EL zImage.initrd.storix
3. Copy image to bootp server and network boot IBM 7044-170 pSeries

Actual Results:  When attempting to boot, the error message is as follows:

Load Addr=0x4000 MaxSize=0xbfc000
Final Packet Count=6317 Final File Size=3234300 bytes
DEFAULT CATCH!, code fff00300 at %SRR0: 00c1d278 %SRR1: 00003030
ok>

Expected Results:  Should have at least seen the kernel executing and kernel load messages. The custom initrd is not the cause because the kernel should at least still execute.

Additional info:
Comment 1 Paul Nasrat 2005-07-01 14:21:05 EDT
Can you also attach the ouput of

.registers

from the of prompt.
Comment 2 David Huffman 2005-07-01 14:57:40 EDT
Created attachment 116250 [details]
.registers from OF Prompt
Comment 3 David Huffman 2005-07-01 15:00:05 EDT
Just in case... 
Clients Fix Pt Regs: 
00 00000000 0121ffe0 00000000 00000000 00000000 00c1b320 00000000 00000000 
08 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 
10 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 
18 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000 
Special Regs: 
%IV: 00000000 %SRR0: 00400000 %SRR1: 00003000 %MQ: 00000000 
%CR: 00000000 %LR: 00000000 %CTR: 00000000 %XER: 00000000 
%DAR: 00000000 %DSISR: 00000000 %SDRI: 013c0000 %ASR: 00000000 
ok> 
 
 
Comment 4 Paul Nasrat 2005-11-28 14:26:06 EST
Dave - have you seen this?
Comment 7 David Woodhouse 2006-05-02 11:24:51 EDT
I don't recall seeing this except when the image has been too large, no.
Comment 9 Peter Jones 2006-08-21 13:45:45 EDT
This looks like the image is to big.  I'm NAKing this for 4.5 and closing it. 
If there's solid evidence found that this is not the problem, please re-open the
bug and add that data.

Note You need to log in before you can comment on or make changes to this bug.