Bug 1622602 - SELinux prevents 389-admin from managing certificates
Summary: SELinux prevents 389-admin from managing certificates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-27 14:59 UTC by Akshay Adhikari
Modified: 2018-10-30 10:10 UTC (History)
8 users (show)

Fixed In Version: selinux-policy-3.13.1-227.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:09:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
ausearch results from the machine (920.45 KB, text/plain)
2018-08-27 14:59 UTC, Akshay Adhikari
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:10:13 UTC

Description Akshay Adhikari 2018-08-27 14:59:59 UTC
Created attachment 1478981 [details]
ausearch results from the machine

Description of problem:

When using redhat-idm-console, it's no longer possible to manage certificates.

Version-Release number of selected component (if applicable):

selinux-policy-3.13.1-219.el7

How reproducible:

Every time when SE Linux is running in Enforcing Mode
 
Steps to Reproduce:
1. Set-up RHDS(10.3) with the console.

2. Run redhat-idm-console -u <admin> -w <passowrd> -a https://$(hostname -f):<port>

3. Click on Directory Manager or Administration Server, then click on open.

4. Under the Task-tab click on Manage Certificate.

5. Change the Security Device password, leave all fields empty, click on OK.

Actual results:
Change Security Device Password window is getting closed.

Expected results:
Should give Error: You should enter Old Password.

Additional info:

Comment 10 errata-xmlrpc 2018-10-30 10:09:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.