Bug 1623136 - fritzing contains proprietary software
Summary: fritzing contains proprietary software
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fritzing   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
high
Target Milestone: ---
Assignee: Ed Marshall
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-Legal
TreeView+ depends on / blocked
 
Reported: 2018-08-28 14:43 UTC by Mikolaj Izdebski
Modified: 2018-09-21 05:22 UTC (History)
2 users (show)

Fixed In Version: fritzing-0.9.2b-15.fc27 fritzing-0.9.2b-15.fc28 fritzing-0.9.2b-15.fc29
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-09-07 15:23:09 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikolaj Izdebski 2018-08-28 14:43:01 UTC
fritzing contains bundled Twitter4J software which is not built from source and is non-free.

META-INF/LICENSE.txt file contained in '/usr/share/fritzing/sketches/core/Fritzing Creator Kit DE+EN/creator-kit-de/Processing/twitter4j-core-2.2.5.jar' contains the following sentence:

> Twitter4J includes software from JSON.org to parse JSON response from the Twitter API. You can see the license term at http://www.JSON.org/license.html

This license is listed among "bad licenses" which are not allowed in Fedora
https://fedoraproject.org/wiki/Licensing:Main#Bad_Licenses

The license says:

> The Software shall be used for Good, not Evil.

which viotales "freedom 0" of The Free Software Definition and does not meet "No Discrimination Against Fields of Endeavor" criterium of The Open Source Definition.

Please remove proprietary software from Fedora.

Comment 1 Tom "spot" Callaway 2018-08-28 14:49:13 UTC
Yeah, this is a no-brainer. If fritzing cannot work without twitter4j, it needs to be removed from Fedora entirely.

Comment 2 Ed Marshall 2018-08-28 15:57:16 UTC
Well that's fun. :( This looks like a straightforward removal; it's only used as part of two example Processing sketches. I'll try to get a new version rolled today that pulls that out.

Comment 3 Fedora Update System 2018-08-28 17:23:13 UTC
fritzing-0.9.2b-15.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5e609261cf

Comment 4 Fedora Update System 2018-08-28 17:23:19 UTC
fritzing-0.9.2b-15.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d4847f32aa

Comment 5 Fedora Update System 2018-08-28 17:23:25 UTC
fritzing-0.9.2b-15.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-553600a1e1

Comment 6 Mikolaj Izdebski 2018-08-28 21:34:22 UTC
Thank you for quick response and update, much appreciated!

Comment 7 Fedora Update System 2018-08-29 19:04:56 UTC
fritzing-0.9.2b-15.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-d4847f32aa

Comment 8 Fedora Update System 2018-08-29 23:13:26 UTC
fritzing-0.9.2b-15.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-d4847f32aa

Comment 9 Fedora Update System 2018-08-30 04:23:13 UTC
fritzing-0.9.2b-15.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-553600a1e1

Comment 10 Fedora Update System 2018-08-30 05:54:57 UTC
fritzing-0.9.2b-15.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5e609261cf

Comment 11 Fedora Update System 2018-09-07 15:23:09 UTC
fritzing-0.9.2b-15.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2018-09-07 16:15:16 UTC
fritzing-0.9.2b-15.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2018-09-21 05:22:09 UTC
fritzing-0.9.2b-15.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.