Bug 1623272 - composes fail with lorax 29.11 due to incorrect armhfp/aarch64 package install directives
Summary: composes fail with lorax 29.11 due to incorrect armhfp/aarch64 package instal...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lorax
Version: 29
Hardware: All
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F29BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2018-08-28 20:56 UTC by Adam Williamson
Modified: 2018-08-31 13:31 UTC (History)
4 users (show)

Fixed In Version: lorax-29.12-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-31 13:31:47 UTC


Attachments (Terms of Use)

Description Adam Williamson 2018-08-28 20:56:40 UTC
F29 compose Fedora-29-20180828.n.0 failed due to lorax trying to install a package on armhfp and aarch64 that is not available:

https://koji.fedoraproject.org/koji/taskinfo?taskID=29344716

DEBUG util.py:439:  2018-08-28 08:32:09,630: installpkg grub2-tools-efi failed: no package matched
DEBUG util.py:439:  installpkg grub2-tools-efi failed: no package matched
DEBUG util.py:439:  2018-08-28 08:32:09,630: template command error in runtime-install.tmpl:
DEBUG util.py:439:  template command error in runtime-install.tmpl:
DEBUG util.py:439:  2018-08-28 08:32:09,631:   installpkg grub2-tools-efi
DEBUG util.py:439:    installpkg grub2-tools-efi
DEBUG util.py:439:  2018-08-28 08:32:09,632:   Exception: Required installpkg failed.

This was an error in a recent change by pbrobinson:

https://github.com/weldr/lorax/commit/94453ff94eddee41f537134154bae7a537924a10

that commit added `installpkg grub2-tools-efi` for armhfp and aarch64, but the package is actually only available on x86_64.

This has now been corrected upstream and a new release made, and there is an update pending for F29, but we need a bug for the blocker process - F29 is in Beta freeze and obviously we need to push this through the freeze. It is an automatic blocker per https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process#Automatic_blockers - "Bugs which entirely prevent the composition of one or more of the release-blocking images required to be built for a currently-pending (pre-)release".

Comment 1 Fedora Update System 2018-08-28 20:57:43 UTC
lorax-29.12-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4dfc6b0eca

Comment 2 Fedora Update System 2018-08-29 19:05:37 UTC
lorax-29.12-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4dfc6b0eca

Comment 3 Fedora Update System 2018-08-29 23:13:40 UTC
lorax-29.12-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4dfc6b0eca

Comment 4 Fedora Update System 2018-08-31 01:35:05 UTC
lorax-29.12-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4dfc6b0eca

Comment 5 Fedora Update System 2018-08-31 13:31:47 UTC
lorax-29.12-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.