Bug 1623385 - [admin] List storage class on page all the time
Summary: [admin] List storage class on page all the time
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-29 09:05 UTC by Yadan Pei
Modified: 2019-06-04 10:40 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: By default, resources on list pages are not listed when no projects are available. Consequence: Cluster level storage classes were not listed when users do not have any projects. Fix: Add a special case to allow cluster level storage classes to be listed even when no projects are available. Result: Cluster level resources will be listed on the storage class list page when user has no projects.
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:41 UTC

Description Yadan Pei 2018-08-29 09:05:39 UTC
Description of problem:
When user doesn't have a project, storage class page will not show cluster storage classes, it's better if we can show it because every user has ability to view them no matter he/she has project or not

Version-Release number of selected component (if applicable):
registry.dev.redhat.io/openshift3/ose-console                   v3.11.0             20856b6879509       283MB
openshift v3.11.0-0.24.0

How reproducible:
Always

Steps to Reproduce:
1.Check if cluster has storageclass created
# oc get sc
NAME                 PROVISIONER            AGE
standard (default)   kubernetes.io/cinder   4h
2.A user without projects login to admin console
3.Go to Storage -> Storage Classes page

Actual results:
3. No Storage Class is listed on page

Expected results:
3. cluster-wide resource sc/standard should be listed on page although user don't have projects

Additional info:

Comment 1 Samuel Padgett 2018-08-30 12:01:23 UTC
Since we're showing roles on the roles page, we should probably be consistent here. I notice as well we are in fact fetching the data even if we're showing a "fake" list, so we already have the storage classes.

Comment 2 Jon Jackson 2018-12-17 21:59:27 UTC
https://github.com/openshift/console/pull/708

Comment 3 Jon Jackson 2018-12-18 19:24:41 UTC
https://github.com/openshift/console/pull/708

Comment 5 Yadan Pei 2019-01-15 03:32:27 UTC
Checked on 

$ oc get clusterversion
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE     STATUS
version   4.0.0-0.nightly-2019-01-15-010905   True        False         44m       Cluster version is 4.0.0-0.nightly-2019-01-15-010905

$ oc get pods openshift-console-76d9f7dc54-6hgs6  -n openshift-console -o yaml | grep -i image
    image: registry.svc.ci.openshift.org/ocp/4.0-art-latest-2019-01-15-010905@sha256:ba056d05b2b7005fdba3de4deefcd14c2ce91e1b7878b63f32ac72caa6ce3a01

$ sudo podman images
registry.svc.ci.openshift.org/ocp/4.0-art-latest-2019-01-15-010905@sha256   ba056d05b2b7005fdba3de4deefcd14c2ce91e1b7878b63f32ac72caa6ce3a01   4043d65804a8   6 hours ago     261 MB

$ sudo podman inspect 4043d65804a8
...
            "Labels": {
                "io.openshift.source-repo-commit": "a62eaa43f2aab9a817a3fb66e1c8b88d5ef100da",
                "io.openshift.source-repo-url": "https://github.com/openshift/console",
                "io.openshift.tags": "openshift,console",
                "maintainer": "Samuel Padgett <spadgett@redhat.com>",
                "name": "openshift/ose-console",
                "release": "0.139.0.0",
                "summary": "Provides the latest release of Red Hat Enterprise Linux 7 in a fully featured and supported base image.",
                "url": "https://access.redhat.com/containers/#/registry.access.redhat.com/openshift/ose-console/images/v4.0.0-0.139.0.0",
                "vcs-ref": "f871de84d993327ecc723846bbac3959a36103c1",
                "vcs-type": "git",
                "vendor": "Red Hat, Inc.",
                "version": "v4.0.0"
....


$ cd $GOPATH/src/github.com/openshift/console & git pull
$ git log a62eaa43f2aab9a817a3fb66e1c8b88d5ef100da | grep '#708'                   // it shows PR is included in this 4.0.0-0.nightly-2019-01-15-010905 build
    Merge pull request #708 from TheRealJon/refactor-new-user-experience


but when a fresh new(no project) user logins to cluster console, goes to Storage -> Storage Classes page, it still shows "No Storage Classes Found"

Assign back

Comment 7 Samuel Padgett 2019-04-22 19:19:35 UTC
Follow on fix: https://github.com/openshift/console/pull/1468

Comment 9 Yadan Pei 2019-05-05 06:54:16 UTC
A fresh new user logins to admin console, visit Storage -> Storage Classes page, it shows existing storage class on page

verified on 4.1.0-0.nightly-2019-05-04-210601

console commit: https://github.com/openshift/console/commit/47f5e8e4a15303a15f138070753ab41c3e8fac3c

Comment 11 errata-xmlrpc 2019-06-04 10:40:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.