Bug 162347 - (fc4idecdoops) kernel panics when dvd/cd is inserted, normal boot without cd/dvd
kernel panics when dvd/cd is inserted, normal boot without cd/dvd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
: 162295 162327 162348 162353 162359 162389 162640 162695 162879 162961 163002 163077 Ash (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-02 18:37 EDT by Koenraad Heijlen
Modified: 2007-11-30 17:11 EST (History)
30 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 14:19:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix spin lock problem (558 bytes, patch)
2005-07-09 22:08 EDT, Nathan G. Grennan
no flags Details | Diff
Fix ide-cd crash (2.58 KB, patch)
2005-07-12 08:03 EDT, Alan Cox
no flags Details | Diff

  None (edit)
Description Koenraad Heijlen 2005-07-02 18:37:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I updated to 2.6.12-1.1387_FC4 and when I rebooted I had a CD in the DVD-drive. The computer froze right after the 'setting hostname' section. When I remove the CD or DVD I have no problem booting. When I insert it at a later stage (eg. when working in GNOME the machines agains locks up solid). 

So I tried booting without rhgb and saw a panic scrolling across my screen. What is the best way to capture this? (using sysrq and emergency sync doesn't seem to help)

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1387_FC4

How reproducible:
Always

Steps to Reproduce:
1. boot with CD in drive
2. load 2.6.12-1.1387_FC4 kernel

Actual Results:  Kernel panics, the machine locks up.

Additional info:

So I tried this with the old version kernel-2.6.11-1.1369_FC4 and I had no problems.
Comment 1 Pontus Fuchs 2005-07-05 08:06:43 EDT
I have exactly the same problem. Here is the output from booting with serial
console which shows the BUG.


Linux version 2.6.12-1.1387_FC4 (bhcompile@decompose.build.redhat.com) (gcc vers

ion 4.0.0 20050519 (Red Hat 4.0.0-8)) #1 Fri Jul 1 12:41:40 EDT 2005

BIOS-provided physical RAM map:

 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)

 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)

 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)

 BIOS-e820: 0000000000100000 - 000000003fffa000 (usable)

 BIOS-e820: 000000003fffa000 - 000000003ffff000 (ACPI data)

 BIOS-e820: 000000003ffff000 - 0000000040000000 (ACPI NVS)

 BIOS-e820: 00000000fec00000 - 00000000fec01000 (reserved)

 BIOS-e820: 00000000fee00000 - 00000000fee01000 (reserved)

 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)

127MB HIGHMEM available.

896MB LOWMEM available.

Using x86 segment limits to approximate NX protection

DMI 2.3 present.

ACPI: PM-Timer IO Port: 0xe408

Allocating PCI resources starting at 40000000 (gap: 40000000:bec00000)

Built 1 zonelists

Kernel command line: ro root=LABEL=/ noapic console=ttyS0,115200

Initializing CPU#0

CPU 0 irqstacks, hard=c0455000 soft=c0454000

PID hash table entries: 4096 (order: 12, 65536 bytes)

Detected 2800.647 MHz processor.

Using pmtmr for high-res timesource

Console: colour VGA+ 80x25

Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)

Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)

Memory: 1033832k/1048552k available (2507k kernel code, 13916k reserved, 689k da

ta, 184k init, 131048k highmem)

Checking if this processor honours the WP bit even in supervisor mode... Ok.

Security Framework v1.0.0 initialized

SELinux:  Initializing.

SELinux:  Starting in permissive mode

selinux_register_security:  Registering secondary module capability

Capability LSM initialized as secondary

Mount-cache hash table entries: 512

CPU: Trace cache: 12K uops, L1 D cache: 8K

CPU: L2 cache: 512K

Intel machine check architecture supported.

Intel machine check reporting enabled on CPU#0.

CPU0: Intel P4/Xeon Extended MCE MSRs (12) available

CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz stepping 07

Enabling fast FPU save and restore... done.

Enabling unmasked SIMD FPU exception support... done.

Checking 'hlt' instruction... OK.

ACPI: setting ELCR to 0200 (from 0820)

checking if image is initramfs... it is

Freeing initrd memory: 1080k freed

NET: Registered protocol family 16

PCI: PCI BIOS revision 2.10 entry at 0xf1670, last bus=1

PCI: Using configuration type 1

mtrr: v2.0 (20020519)

ACPI: Subsystem revision 20050309

ACPI: Interpreter enabled

ACPI: Using PIC for interrupt routing

ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 7 10 *11 15)

ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 7 10 *11 15)

ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 7 10 *11 15)

ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 7 11 15) *0, disabled.

ACPI: PCI Interrupt Link [LNKE] (IRQs 3 4 *5 6 7 10 11 14 15)

ACPI: PCI Interrupt Link [LNKF] (IRQs 3 4 *5 6 7 10 11 14 15)

ACPI: PCI Interrupt Link [LNKG] (IRQs 3 4 *5 6 7 10 11 14 15)

ACPI: PCI Interrupt Link [LNKH] (IRQs 3 4 *5 6 7 10 11 14 15)

ACPI: PCI Root Bridge [PCI0] (0000:00)

PCI: Probing PCI hardware (bus 00)

Uncovering SIS963 that hid as a SIS503 (compatible=1)

Enabling SiS 96x SMBus.

ACPI: Power Resource [FN0] (off)

Linux Plug and Play Support v0.97 (c) Adam Belay

pnp: PnP ACPI init

pnp: PnP ACPI: found 16 devices

usbcore: registered new driver usbfs

usbcore: registered new driver hub

PCI: Using ACPI for IRQ routing

PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report

pnp: 00:02: ioport range 0xe400-0xe47f could not be reserved

pnp: 00:02: ioport range 0xe480-0xe4ff has been reserved

pnp: 00:02: ioport range 0xe800-0xe81f has been reserved

pnp: 00:02: ioport range 0x480-0x48f has been reserved

pnp: 00:0f: ioport range 0x3f0-0x3f1 has been reserved

pnp: 00:0f: ioport range 0x290-0x297 has been reserved

pnp: 00:0f: ioport range 0x500-0x507 has been reserved

Simple Boot Flag at 0x3a set to 0x1

apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16ac)

apm: overridden by ACPI.

audit: initializing netlink socket (disabled)

audit(1120571581.370:1): initialized

highmem bounce pool size: 64 pages

Total HugeTLB memory allocated, 0

VFS: Disk quotas dquot_6.5.1

Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)

SELinux:  Registering netfilter hooks

Initializing Cryptographic API

ksign: Installing public key data

Loading keyring

- Added public key 6BD781E88D5E157

- User ID: Red Hat, Inc. (Kernel Module GPG key)

pci_hotplug: PCI Hot Plug PCI Core version: 0.5

ACPI: Fan [FAN0] (on)

ACPI: CPU0 (power states: C1[C1] C2[C2] C3[C3])

ACPI: Processor [CPU0] (supports 8 throttling states)

ACPI: Thermal Zone [THRM] (55 C)

isapnp: Scanning for PnP cards...

isapnp: No Plug & Play device found

Real Time Clock Driver v1.12

Linux agpgart interface v0.101 (c) Dave Jones

agpgart: Detected SiS 648 chipset

agpgart: AGP aperture is 64M @ 0xe8000000

PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12

i8042.c: Detected active multiplexing controller, rev 1.1.

serio: i8042 AUX0 port at 0x60,0x64 irq 12

serio: i8042 AUX1 port at 0x60,0x64 irq 12

serio: i8042 AUX2 port at 0x60,0x64 irq 12

serio: i8042 AUX3 port at 0x60,0x64 irq 12

serio: i8042 KBD port at 0x60,0x64 irq 1

Serial: 8250/16550 driver $Revision: 1.90 $ 76 ports, IRQ sharing enabled

ÿttyS0 at I/O 0x3f8 (irq = 4) is a 16550A

ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A

ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A

ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 11

PCI: setting IRQ 11 as level-triggered

ACPI: PCI Interrupt 0000:00:02.6[C] -> Link [LNKC] -> GSI 11 (level, low) -> IRQ

 11

io scheduler noop registered

io scheduler anticipatory registered

io scheduler deadline registered

io scheduler cfq registered

RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize

Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2

ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx

SIS5513: IDE controller at PCI slot 0000:00:02.5

SIS5513: chipset revision 0

SIS5513: not 100% native mode: will probe irqs later

SIS5513: SiS 962/963 MuTIOL IDE UDMA133 controller

    ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hda:DMA, hdb:pio

    ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdc:DMA, hdd:pio

hda: TOSHIBA DVD-ROM SD-R2312, ATAPI CD/DVD-ROM drive

ide0 at 0x1f0-0x1f7,0x3f6 on irq 14

hdc: IC25N060ATMR04-0, ATA DISK drive

ide1 at 0x170-0x177,0x376 on irq 15

hdc: max request size: 1024KiB

hdc: 117210240 sectors (60011 MB) w/7884KiB Cache, CHS=16383/255/63, UDMA(100)

hdc: cache flushes supported

 hdc: hdc1 hdc2 hdc3 hdc4

hda: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)

Uniform CD-ROM driver Revision: 3.20

ide-floppy driver 0.99.newide

usbcore: registered new driver hiddev

usbcore: registered new driver usbhid

drivers/usb/input/hid-core.c: v2.01:USB HID core driver

mice: PS/2 mouse device common for all mice

md: md driver 0.90.1 MAX_MD_DEVS=256, MD_SB_DISKS=27

NET: Registered protocol family 2

IP: routing cache hash table of 2048 buckets, 64Kbytes

TCP established hash table entries: 262144 (order: 9, 2097152 bytes)

TCP bind hash table entries: 65536 (order: 8, 1835008 bytes)

TCP: Hash tables configured (established 262144 bind 65536)

Initializing IPsec netlink socket

NET: Registered protocol family 1

NET: Registered protocol family 17

ACPI wakeup devices:

PCI1 USB0 USB1 USB2 USB3 MC97  LAN MPCI

ACPI: (supports S0 S1 S3 S4 S5)

Freeing unused kernel memory: 184k freed

Red Hat nash version 4.2.15 starting

Mounted /proc filesystem

Mounting sysfs

Creating /dev

Starting udev

Loading jbd.ko module

Loading ext3.ko module

Creating root device

input: AT Translated Set 2 keyboard on isa0060/serio0

Mounting root filesystem

kjournald starting.  Commit interval 5 seconds

EXT3-fs: mounted filesystem with ordered data mode.

Switching to new root

unmounting old /proc

unmounting old /sys

Synaptics Touchpad, model: 1, fw: 4.6, id: 0x925ea1, caps: 0x80471b/0x0

input: SynPS/2 Synaptics TouchPad on isa0060/serio4

SELinux:  Disabled at runtime.

SELinux:  Unregistering netfilter hooks

INIT: version 2.85 booting

                Welcome to Fedora Core

                Press 'I' to enter interactive startup.

Starting udev:  [  OK  ]

Initializing hardware...  storage network audio done[  OK  ]

Setting clock  (localtime): Tue Jul  5 13:53:20 CEST 2005 [  OK  ]

Setting hostname localhost.localdomain:  [  OK  ]

------------[ cut here ]------------

kernel BUG at include/linux/blkdev.h:607!

invalid operand: 0000 [#1]

Modules linked in: dm_mod video button battery asus_acpi ac ohci1394 ieee1394 ye

nta_socket rsrc_nonstatic pcmcia_core ohci_hcd ehci_hcd i2c_sis96x i2c_core snd_

intel8x0m snd_intel8x0 snd_ac97_codec snd_seq_dummy snd_seq_oss snd_seq_midi_eve

nt snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundc

ore snd_page_alloc sk98lin floppy joydev ext3 jbd

CPU:    0

EIP:    0060:[<c02af6d8>]    Not tainted VLI

EFLAGS: 00010046   (2.6.12-1.1387_FC4)

EIP is at __ide_end_request+0x118/0x125

eax: 00000001   ebx: c1ab42bc   ecx: 00000001   edx: c1ab42bc

esi: 00000000   edi: c0495b10   ebp: c0495b10   esp: c0455f00

ds: 007b   es: 007b   ss: 0068

Process swapper (pid: 0, threadinfo=c0455000 task=c03c1ca0)

Stack: c1ab42bc 00000000 c1b08660 c02be984 00000040 00000012 c1b08660 00000082

       c02bf337 00000013 c0495b10 c1b08620 00000001 00000086 00000012 c0495b10

       00000012 c1b08660 c02c019d 00000086 21f79740 000f41ff 00000003 00000012

Call Trace:

 [<c02be984>] cdrom_end_request+0xc9/0x29d

 [<c02bf337>] cdrom_timer_expiry+0x0/0x5a

 [<c02c019d>] cdrom_pc_intr+0x90/0x21a

 [<c02b1cb8>] ide_intr+0x341/0x60e

 [<c0108c4a>] timer_interrupt+0x7c/0x1b5

 [<c02c010d>] cdrom_pc_intr+0x0/0x21a

 [<c01507fd>] handle_IRQ_event+0x2e/0x5a

 [<c01508dc>] __do_IRQ+0xb3/0x347

 [<c0105b1d>] do_IRQ+0x4a/0x82

 =======================

 [<c0103c0e>] common_interrupt+0x1a/0x20

 [<c024a62c>] acpi_processor_idle+0xf0/0x24c

 [<c01010a6>] cpu_idle+0x34/0x4c

 [<c042170a>] start_kernel+0x15d/0x1b7

 [<c04212f7>] unknown_bootoption+0x0/0x1b6

Code: 50 14 89 f8 ff 92 88 04 00 00 e9 31 ff ff ff 8b 47 10 89 da e8 fb f0 fd ff

 e9 50 ff ff ff 0f 0b 3f 00 c7 67 39 c0 e9 fc fe ff ff <0f> 0b 5f 02 97 4f 39 c0

 e9 40 ff ff ff 55 57 56 53 83 ec 24 89

 <0>Kernel panic - not syncing: Fatal exception in interrupt

 [<c0120908>] panic+0x45/0x1e2

 [<c0104614>] die+0x222/0x2c4

 [<c011970b>] fixup_exception+0xb/0x20

 [<c01048ea>] do_invalid_op+0x0/0xab

 [<c010498c>] do_invalid_op+0xa2/0xab

 [<c02af6d8>] __ide_end_request+0x118/0x125

 [<c018116b>] end_bio_bh_io_sync+0x0/0x4d

 [<c0155e3c>] mempool_free+0x67/0x1ca

 [<c01818be>] bio_destructor+0x1e/0x33

 [<c0103c6b>] error_code+0x4f/0x54

 [<c02af6d8>] __ide_end_request+0x118/0x125

 [<c02be984>] cdrom_end_request+0xc9/0x29d

 [<c02bf337>] cdrom_timer_expiry+0x0/0x5a

 [<c02c019d>] cdrom_pc_intr+0x90/0x21a

 [<c02b1cb8>] ide_intr+0x341/0x60e

 [<c0108c4a>] timer_interrupt+0x7c/0x1b5

 [<c02c010d>] cdrom_pc_intr+0x0/0x21a

 [<c01507fd>] handle_IRQ_event+0x2e/0x5a

 [<c01508dc>] __do_IRQ+0xb3/0x347

 [<c0105b1d>] do_IRQ+0x4a/0x82

 =======================

 [<c0103c0e>] common_interrupt+0x1a/0x20

 [<c024a62c>] acpi_processor_idle+0xf0/0x24c

 [<c01010a6>] cpu_idle+0x34/0x4c

 [<c042170a>] start_kernel+0x15d/0x1b7

 [<c04212f7>] unknown_bootoption+0x0/0x1b6

 Badness in panic at kernel/panic.c:119 (Not tainted)

 [<c0120a8d>] panic+0x1ca/0x1e2

 [<c0104614>] die+0x222/0x2c4

 [<c011970b>] fixup_exception+0xb/0x20

 [<c01048ea>] do_invalid_op+0x0/0xab

 [<c010498c>] do_invalid_op+0xa2/0xab

 [<c02af6d8>] __ide_end_request+0x118/0x125

 [<c018116b>] end_bio_bh_io_sync+0x0/0x4d

 [<c0155e3c>] mempool_free+0x67/0x1ca

 [<c01818be>] bio_destructor+0x1e/0x33

 [<c0103c6b>] error_code+0x4f/0x54

 [<c02af6d8>] __ide_end_request+0x118/0x125

 [<c02be984>] cdrom_end_request+0xc9/0x29d

 [<c02bf337>] cdrom_timer_expiry+0x0/0x5a

 [<c02c019d>] cdrom_pc_intr+0x90/0x21a

 [<c02b1cb8>] ide_intr+0x341/0x60e

 [<c0108c4a>] timer_interrupt+0x7c/0x1b5

 [<c02c010d>] cdrom_pc_intr+0x0/0x21a

 [<c01507fd>] handle_IRQ_event+0x2e/0x5a

 [<c01508dc>] __do_IRQ+0xb3/0x347

 [<c0105b1d>] do_IRQ+0x4a/0x82

 =======================

 [<c0103c0e>] common_interrupt+0x1a/0x20

 [<c024a62c>] acpi_processor_idle+0xf0/0x24c

 [<c01010a6>] cpu_idle+0x34/0x4c

 [<c042170a>] start_kernel+0x15d/0x1b7

 [<c04212f7>] unknown_bootoption+0x0/0x1b6

Comment 2 Srihari Vijayaraghavan 2005-07-06 06:23:21 EDT
Kernel BUG at blkdev.h:607 while playing a DVD on 2.6.12-1.1387_FC4. Same, when
I leave an audio CD on the drive during the system boot.

Thanks
Hari

PS: No problems with vanilla 2.6.13-rc2 though.
Comment 3 Jani Ollikainen 2005-07-06 10:01:54 EDT
Me too!

Complete system freeze when inserting for example FC4 DVD (which has been used
to install FC4).. and if booting it inside dvd drive.

Older kernel "2.6.11-1.1369_FC4" works a-ok..
Comment 4 Alexandre Oliva 2005-07-06 11:24:44 EDT
*** Bug 162295 has been marked as a duplicate of this bug. ***
Comment 5 Alexandre Oliva 2005-07-06 11:25:00 EDT
*** Bug 162327 has been marked as a duplicate of this bug. ***
Comment 6 Alexandre Oliva 2005-07-06 11:25:30 EDT
*** Bug 162348 has been marked as a duplicate of this bug. ***
Comment 7 Alexandre Oliva 2005-07-06 11:25:32 EDT
*** Bug 162353 has been marked as a duplicate of this bug. ***
Comment 8 Alexandre Oliva 2005-07-06 11:26:06 EDT
*** Bug 162359 has been marked as a duplicate of this bug. ***
Comment 9 Alexandre Oliva 2005-07-06 11:26:20 EDT
*** Bug 162389 has been marked as a duplicate of this bug. ***
Comment 10 Alexandre Oliva 2005-07-06 11:34:41 EDT
FWIW, I've experienced this with some rawhide kernels of the same vintage, but
the latest rawhide kernels don't have this problem any more.
Comment 11 Anil Kumar Sharma 2005-07-07 08:23:09 EDT
(In reply to comment #10)
> FWIW, I've experienced this with some rawhide kernels of the same vintage, but
> the latest rawhide kernels don't have this problem any more.

Well please mention the url for the rawhide u've used. I plan to revert back to 
2.6.11. if rawhide has some issues.
Comment 12 Dave Jones 2005-07-07 19:06:04 EDT
*** Bug 162695 has been marked as a duplicate of this bug. ***
Comment 13 Per Nystrom 2005-07-07 19:10:43 EDT
I noticed that the hardware for this bug is x86_64, but I want to point out that
this is happening to me on a P4 (i686 according to uname -m), so more than just
one architecture is affected.

Comment 14 Lonni J Friedman 2005-07-07 22:29:37 EDT
Same problem here with Mobile Intel(R) Pentium(R) III CPU - M  1133MHz (a
laptop). Soon as I insert a DVD, I get a full lockup.  Data/ISO9660 CDs work fine.
Comment 15 Andre Robatino 2005-07-08 01:12:08 EDT
  Bug still exists with kernel-2.6.12-1.1390_FC4.  I have the bug with a Duron CPU.
Comment 16 Neal Becker 2005-07-08 06:50:24 EDT
Seems to be fixed for me with 1390 
Comment 17 Robert Murphey 2005-07-08 14:53:28 EDT
No CD/DVD lockups using 2.6.11-1.1369_FC4smp

With 2.6.12-1.1387_FC4smp and 2.6.12-1.1390_FC4smp, the system will deadlock
during the inital read of a mixed mode data/audio CD that is placed in the
drive, eventually forcing poweroff to regain control and reboot/resync of the
drive mirrors.

Have disabled all settings in /etc/sysconfig/harddisk* and verified deadlock
still occurs.

Booting with disc in the drive will cause panic mentioned above, at least the
tail end of the output on the console looks very similar.

Intel P4-HT 3GHz CPU, MSI Neo2-V Intel 865-based motherboard
hda and hdc are Western Digital WD1000BB
hdb TDK DVDRW0404N
Comment 18 Samuli Kärkkäinen 2005-07-09 21:42:23 EDT
Happens to me with kernel 1390, didn't happen with 1387 or any earlier kernel.
AMD64, south bridge K8T800/K8T890, IDE controller
VT82C586A/B/VT82C686/A/B/VT823x/A/C, HL-DT-ST GCC-4480B DVD drive.
Comment 19 Nathan G. Grennan 2005-07-09 22:05:52 EDT
I was talking to someone in #fedora who was having this problem. I tried to
reproduce it, and was successful. I setup a serial console and got the kernel
bug   :607 error above. I tracked it down on the kernel mailing list. It is a
known bug and Linus applied the patch to fix it in 2.6.13-rc1. I will attach the
patch after this entry.

I installed 2.6.12-1.1425_FC5 from development and no longer experience the
error. I would really like to see a kernel that fixes this issue as errata for fc4.
Comment 20 Nathan G. Grennan 2005-07-09 22:08:13 EDT
Created attachment 116555 [details]
Patch to fix spin lock problem
Comment 21 Nathan G. Grennan 2005-07-09 22:17:55 EDT
It may have been 2.6.13-rc2 instead of 2.6.13-rc1. Here is url to a message from
Linus on the kernel mailing list that mentions the bug fix from Hugh Dickins. I
think Linus also mentions it at the top of the message.

http://marc.theaimsgroup.com/?l=linux-kernel&m=112062998403160&w=2
Comment 22 Dave Jones 2005-07-11 16:56:45 EDT
The patch you reference fixes broken code that changed in 2.6.13rc.
This bug occurs in 2.6.12, so that's a seperate issue.
Comment 23 Nathan G. Grennan 2005-07-11 17:26:04 EDT
Ok, well, either way this issue is fixed with the latest development kernels.
Comment 24 Wayne Walker 2005-07-11 20:31:02 EDT
*** Bug 162961 has been marked as a duplicate of this bug. ***
Comment 25 Alan Cox 2005-07-12 08:00:13 EDT
Doh, tried to reuse __ide_end_request but that can cause double request dequeueing.

Fix attached
Comment 26 Alan Cox 2005-07-12 08:03:02 EDT
Created attachment 116651 [details]
Fix ide-cd crash
Comment 27 Dave Jones 2005-07-12 18:01:09 EDT
*** Bug 163002 has been marked as a duplicate of this bug. ***
Comment 28 Dave Jones 2005-07-12 18:02:40 EDT
*** Bug 163077 has been marked as a duplicate of this bug. ***
Comment 29 Shahms E. King 2005-07-12 18:05:44 EDT
*** Bug 162640 has been marked as a duplicate of this bug. ***
Comment 30 Dave Jones 2005-07-12 18:08:39 EDT
*** Bug 162879 has been marked as a duplicate of this bug. ***
Comment 31 Andre Robatino 2005-07-15 13:30:10 EDT
  Fixed for me with 2.6.12-1.1398_FC4.
Comment 32 Dave Jones 2005-07-15 14:21:20 EDT
*** Bug 163309 has been marked as a duplicate of this bug. ***
Comment 33 Robert Murphey 2005-07-15 16:22:37 EDT
Well, it seems fixed for me in 2.6.12-1.1398_FC4smp.
I dropped in the CDXA disc that was 100% guaranteed to deadlock, and the XA
tracks are playing as I type this (yay Wipeout3:SE soundtrack!), so it seems to
be working again. Thanks for the fix folks!
Comment 34 Geraldo Veiga 2005-07-17 11:27:44 EDT
(In reply to comment #33)
> Well, it seems fixed for me in 2.6.12-1.1398_FC4smp.
> I dropped in the CDXA disc that was 100% guaranteed to deadlock, and the XA
> tracks are playing as I type this (yay Wipeout3:SE soundtrack!), so it seems to
> be working again. Thanks for the fix folks!

It looks like every time I update the kernel the problem goes away, only to come
back latter with a vengeance.

I am running kernel 2.6.12-1.1398_FC4.  CDs worked after kernel update, stopped
working after a brief period of bliss. Same symptoms as before, including the
occasional kernel panic and freeze.
-----
Jul 17 12:09:53 localhost kernel: hdb: status error: status=0x58 { DriveReady
SeekComplete DataRequest }
Jul 17 12:09:53 localhost kernel: ide: failed opcode was: unknown
Jul 17 12:09:53 localhost kernel: hdb: drive not ready for command
Jul 17 12:09:54 localhost kernel: hdb: status error: status=0x7f { DriveReady
DeviceFault SeekComplete DataRequest CorrectedError Index Error }
...
Jul 17 12:25:23 localhost kernel: hdb: status error: error=0x7f {
IllegalLengthIndication EndOfMedia AbortedCommand MediaChangeRequested
LastFailedSense=0x07 }
Jul 17 12:25:23 localhost kernel: ide: failed opcode was: unknown
Jul 17 12:25:23 localhost kernel: hdb: drive not ready for command

...

Repeats ad infinitum
Comment 35 Moke 2005-07-18 20:15:42 EDT
Out of curiosity I stuck a CD into my drive, and rebooted my box using 
1398_FC4. It did report about a page of errors as it attempted to read the CD, 
but eventually continued and booted up normally. That's the GOOD news.

The bad news is that it continued to show the same problem even after I moved 
the CD drive below the HD in the BIOS boot sequence. 

I then rebooted with a Knoppix CD in the drive. The system still checked the 
drive, this time found something that it liked, and booted with no errors.
Comment 36 Gérard Milmeister 2005-07-26 18:16:43 EDT
I have similar problems with kernel-2.6.12-1.1390_FC4 and kernel-2.6.12-1.1398_FC4
. The following messages appear in /var/log/messages when I try to rip an audio CD:
Jul 27 00:05:06 scriabin kernel: hdd: DMA timeout retry
Jul 27 00:05:06 scriabin kernel: hdd: timeout waiting for DMA
Jul 27 00:05:06 scriabin kernel: hdd: status timeout: status=0xd8 { Busy }
Jul 27 00:05:06 scriabin kernel: ide: failed opcode was: unknown
Jul 27 00:05:06 scriabin kernel: hdd: drive not ready for command
Jul 27 00:05:06 scriabin kernel: hdd: ATAPI reset complete
Jul 27 00:05:11 scriabin kernel: hdd: irq timeout: status=0x80 { Busy }
Jul 27 00:05:11 scriabin kernel: ide: failed opcode was: unknown
Jul 27 00:05:11 scriabin kernel: hdd: ATAPI reset complete
etc...

Eventually the system will lock up.
I disabled DMA on the CD drive and only got (once):
Jul 27 00:11:05 scriabin kernel: hdd: irq timeout: status=0xd0 { Busy }
Jul 27 00:11:05 scriabin kernel: ide: failed opcode was: unknown
Jul 27 00:11:05 scriabin kernel: hdd: ATAPI reset complete

With the previous kernels I have been able to rip CDs with DMA on without any
problems.
Comment 37 Geraldo Veiga 2005-09-02 18:28:52 EDT
Out of curiosity. When would this fix see the light of day? I just upgraded to
kernel-2.6.12-1.1447_FC4 and CD reader is still non-functional.
Comment 38 Geraldo Veiga 2005-10-01 11:45:52 EDT
Everytime a new kernel update is realease I have a little hope that the CD
Reader might be back.   This is kernel-2.6.13-1.1526_FC4, but the problem is
still there:

From /var/log/messages:

-----
Oct  1 12:35:22 ggv-win32 kernel: hdb: status error: status=0x58 { DriveReady
SeekComplete DataRequest }
Oct  1 12:35:22 ggv-win32 kernel: ide: failed opcode was: unknown
Oct  1 12:35:22 ggv-win32 kernel: hdb: drive not ready for command
Oct  1 12:35:22 ggv-win32 kernel: hdb: status error: status=0x7f { DriveReady
DeviceFault SeekComplete DataRequest CorrectedError Index Error }
Oct  1 12:35:22 ggv-win32 kernel: hdb: status error: error=0x7f {
IllegalLengthIndication EndOfMedia AbortedCommand MediaChangeRequested
LastFailedSense=0x07 }Oct  1 12:35:22 ggv-win32 kernel: ide: failed opcode was:
unknown
Oct  1 12:35:22 ggv-win32 kernel: hdb: DMA disabled
Oct  1 12:35:22 ggv-win32 kernel: hdb: drive not ready for command
Oct  1 12:35:22 ggv-win32 kernel: hdb: ATAPI reset complete
Oct  1 12:35:22 ggv-win32 kernel: hdb: status error: status=0x7f { DriveReady
DeviceFault SeekComplete DataRequest CorrectedError Index Error }
Oct  1 12:35:22 ggv-win32 kernel: hdb: status error: error=0x7f {
IllegalLengthIndication EndOfMedia AbortedCommand MediaChangeRequested
LastFailedSense=0x07 }
-----

Repeats ad eternum.  Is this a bug that should go away with this fix?

Note You need to log in before you can comment on or make changes to this bug.