Bug 1623471 - Spurious connection errors: "Server did not return a valid TLS certificate"
Summary: Spurious connection errors: "Server did not return a valid TLS certificate"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnutls
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nikos Mavrogiannopoulos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F29BetaFreezeException F29FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2018-08-29 12:58 UTC by Dennis Gilmore
Modified: 2018-09-12 02:54 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-12 02:54:55 UTC


Attachments (Terms of Use)

Description Dennis Gilmore 2018-08-29 12:58:07 UTC
Description of problem:
after upgrading to fedora 29 from fedora 28 In evolution I was getting lot of TLS errors for the accounts I have setup in gnome-online-accounts. In an effort to clear things up I tried to recreate an account and it is not able to do so.

setting up a google account fails with 
Something went wrong
Sorry, something went wrong there. Try again.
at random points, sometimes its after entering the email sometimes after agreeing to the permissions. in the end you get a message "Server did not return a valid TLS certificate"


Version-Release number of selected component (if applicable):

gnome-online-accounts-3.29.91-1.fc29.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Dennis Gilmore 2018-08-30 14:21:14 UTC
proposing as a Fedora 29 final blocker under the criteria 
Default application functionality

All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test

as it is the functionality of gnome-online-accounts and evolution are not functional

Comment 3 Dennis Gilmore 2018-08-31 22:11:14 UTC
after some digging and finding fwupdmgr broken it seems gnutls is broken in regards to tls 1.3

fwupdmgr  refresh
Fetching metadata https://cdn.fwupd.org/downloads/firmware.xml.gz
Downloading…           [***************************************]
Fetching signature https://cdn.fwupd.org/downloads/firmware.xml.gz.asc

Failed to download https://cdn.fwupd.org/downloads/firmware.xml.gz.asc: SSL handshake failed

I will leave it up to QA to decide, however I think this is a Beta blocker

Comment 4 Dennis Gilmore 2018-09-01 14:55:39 UTC
[dennis@sokar ~]$ gnutls-cli cdn.fwupd.org --resume
Processed 151 CA certificate(s).
Resolving 'cdn.fwupd.org:443'...
Connecting to '94.100.23.126:443'...
- Certificate type: X.509
- Got a certificate list of 2 certificates.
- Certificate[0] info:
 - subject `CN=cdn.fwupd.org', issuer `CN=Let's Encrypt Authority X3,O=Let's Encrypt,C=US', serial 0x034cfd240fcbcfa672eb8eab649135d2cb31, RSA key 2048 bits, signed using RSA-SHA256, activated `2018-08-15 00:00:18 UTC', expires `2018-11-13 00:00:18 UTC', pin-sha256="Kv7dHvham7rCXFhvBssersHoA66oZhSYLnT9Axt1I0A="
	Public Key ID:
		sha1:7005e54668e7a320708640968cfb12fe613f392f
		sha256:2afedd1ef85a9bbac25c586f06cb1eaec1e803aea86614982e74fd031b752340
	Public Key PIN:
		pin-sha256:Kv7dHvham7rCXFhvBssersHoA66oZhSYLnT9Axt1I0A=

- Certificate[1] info:
 - subject `CN=Let's Encrypt Authority X3,O=Let's Encrypt,C=US', issuer `CN=DST Root CA X3,O=Digital Signature Trust Co.', serial 0x0a0141420000015385736a0b85eca708, RSA key 2048 bits, signed using RSA-SHA256, activated `2016-03-17 16:40:46 UTC', expires `2021-03-17 16:40:46 UTC', pin-sha256="YLh1dUR9y6Kja30RrAn7JKnbQG/uEtLMkBgFF2Fuihg="
- Status: The certificate is trusted. 
- Description: (TLS1.2)-(ECDHE-SECP256R1)-(RSA-SHA512)-(AES-128-GCM)
- Session ID: CC:63:F8:C1:9C:2D:D9:6E:B4:67:AC:4C:B6:34:43:3B:76:80:00:06:9B:0B:7F:40:8A:67:02:75:2F:AA:CE:DE
- Ephemeral EC Diffie-Hellman parameters
 - Using curve: SECP256R1
 - Curve size: 256 bits
- Version: TLS1.2
- Key Exchange: ECDHE-RSA
- Server Signature: RSA-SHA512
- Cipher: AES-128-GCM
- MAC: AEAD
- Options: safe renegotiation,
- Handshake was completed
- Disconnecting


- Connecting again- trying to resume previous session
Resolving 'cdn.fwupd.org:443'...
Connecting to '94.100.23.126:443'...
- Description: (TLS1.2)-(ECDHE-SECP256R1)-(AES-128-GCM)
- Session ID: CC:63:F8:C1:9C:2D:D9:6E:B4:67:AC:4C:B6:34:43:3B:76:80:00:06:9B:0B:7F:40:8A:67:02:75:2F:AA:CE:DE
- Ephemeral EC Diffie-Hellman parameters
 - Using curve: SECP256R1
 - Curve size: 256 bits
- Version: TLS1.2
- Key Exchange: ECDHE-RSA
- Cipher: AES-128-GCM
- MAC: AEAD
- Options: safe renegotiation,
- Resume Handshake was completed
*** This is a resumed session

- Simple Client Mode:

^C
[dennis@sokar ~]$ gnutls-cli cdn.fwupd.org --rehandshake
Processed 151 CA certificate(s).
Resolving 'cdn.fwupd.org:443'...
Connecting to '94.100.23.126:443'...
- Certificate type: X.509
- Got a certificate list of 2 certificates.
- Certificate[0] info:
 - subject `CN=cdn.fwupd.org', issuer `CN=Let's Encrypt Authority X3,O=Let's Encrypt,C=US', serial 0x034cfd240fcbcfa672eb8eab649135d2cb31, RSA key 2048 bits, signed using RSA-SHA256, activated `2018-08-15 00:00:18 UTC', expires `2018-11-13 00:00:18 UTC', pin-sha256="Kv7dHvham7rCXFhvBssersHoA66oZhSYLnT9Axt1I0A="
	Public Key ID:
		sha1:7005e54668e7a320708640968cfb12fe613f392f
		sha256:2afedd1ef85a9bbac25c586f06cb1eaec1e803aea86614982e74fd031b752340
	Public Key PIN:
		pin-sha256:Kv7dHvham7rCXFhvBssersHoA66oZhSYLnT9Axt1I0A=

- Certificate[1] info:
 - subject `CN=Let's Encrypt Authority X3,O=Let's Encrypt,C=US', issuer `CN=DST Root CA X3,O=Digital Signature Trust Co.', serial 0x0a0141420000015385736a0b85eca708, RSA key 2048 bits, signed using RSA-SHA256, activated `2016-03-17 16:40:46 UTC', expires `2021-03-17 16:40:46 UTC', pin-sha256="YLh1dUR9y6Kja30RrAn7JKnbQG/uEtLMkBgFF2Fuihg="
- Status: The certificate is trusted. 
- Description: (TLS1.2)-(ECDHE-SECP256R1)-(RSA-SHA512)-(AES-128-GCM)
- Session ID: 11:FE:3E:63:12:A2:7E:B3:C9:4B:71:51:45:92:10:E6:7E:98:4B:AC:F8:81:E2:B3:E3:35:F7:EB:5E:77:1E:F0
- Ephemeral EC Diffie-Hellman parameters
 - Using curve: SECP256R1
 - Curve size: 256 bits
- Version: TLS1.2
- Key Exchange: ECDHE-RSA
- Server Signature: RSA-SHA512
- Cipher: AES-128-GCM
- MAC: AEAD
- Options: safe renegotiation,
- Handshake was completed

- Simple Client Mode:

*** Fatal error: The TLS connection was non-properly terminated.
*** ReHandshake has failed
GnuTLS error: The TLS connection was non-properly terminated.

Comment 5 Dennis Gilmore 2018-09-01 18:47:50 UTC
this broke in gnutls-3.6.3-1.fc29 if I downgrade to 3.6.2 everything works fine

Comment 6 Adam Williamson 2018-09-01 22:12:43 UTC
Same here, +1 Final blocker. Also would give this a Beta FE, for a targeted fix.

Comment 7 Patrick Uiterwijk 2018-09-01 22:17:52 UTC
+1 final blocker, +1 beta FE.

Comment 8 Michael Catanzaro 2018-09-02 22:19:58 UTC
(In reply to Dennis Gilmore from comment #0)
> Description of problem:
> after upgrading to fedora 29 from fedora 28 In evolution I was getting lot
> of TLS errors for the accounts I have setup in gnome-online-accounts. In an
> effort to clear things up I tried to recreate an account and it is not able
> to do so.
> 
> setting up a google account fails with 
> Something went wrong
> Sorry, something went wrong there. Try again.
> at random points, sometimes its after entering the email sometimes after
> agreeing to the permissions. in the end you get a message "Server did not
> return a valid TLS certificate"

Hmmm... I included a flawed change in glib-networking 2.57.90 that resulted in this error occurring quite regularly. It is "fixed" -- reverted until I can debug it -- in glib-networking 2.57.92 (which hasn't reached Fedora yet). That should explain the difficulties with evolution, the problem with fwupd, and for the gnome-online-accounts problem described in https://www.mail-archive.com/debian-bugs-dist@lists.debian.org/msg1622818.html.

That cannot explain any problems you've experienced with gnutls-cli, since gnutls-cli doesn't use glib-networking. It also doesn't explain why downgrading gnutls resolved your problems. I could speculate that perhaps the breakage only occurs when glib-networking 2.57.90 is combined with GnuTLS 3.6.3. (My glib-networking changes were tested against 3.6.2, and I was quite surprised when I discovered there were problems with the release.) That seems plausible, but I don't know.

Note that your tests in comment #4 indicate a TLS 1.2 connection is in use, so it can't be a problem with TLS 1.3. Also note that downgrading a failed TLS 1.3 connection to a 1.2 connection is not necessary or desirable (because the TLS 1.3 handshake is painstakingly designed to look like a 1.2 handshake to peers that don't support 1.3 yet).

Finally: note that Fedora 28 already has GnuTLS 3.6.3, and these problems aren't occurring there.

So Dennis, I am going to prepare a glib-networking update; please test it alongside both GnuTLS 3.6.2 and 3.6.3 and see if that resolves your issues.

Comment 9 Fedora Update System 2018-09-02 22:34:25 UTC
glib-networking-2.58.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-692ec0f693

Comment 10 Adam Williamson 2018-09-03 05:30:09 UTC
To be clear: I had the same problem as Dennis (on my F29 box), and downgrading gnutls (and killing all Evo processes and restarting it) solved it for me also.

(I can also confirm that gnutls 3.6.3 on Fedora 28 seems OK, I am running that combo on *this* system, and Evo is OK).

Comment 11 Debarshi Ray 2018-09-03 08:57:57 UTC
Dennis, Michael: Thanks for chasing this! Saved me some time. :)

Comment 12 Michael Catanzaro 2018-09-03 12:47:52 UTC
(In reply to Adam Williamson from comment #10) 
> (I can also confirm that gnutls 3.6.3 on Fedora 28 seems OK, I am running
> that combo on *this* system, and Evo is OK).

That just furthers my suspicion that this problem only occurs in combination with both glib-networking 2.57.90 and GnuTLS 3.6.3.

I don't have time to investigate more now, but I'm looking forward to tracking this down in the future.

Comment 13 Fedora Update System 2018-09-04 09:03:15 UTC
glib-networking-2.58.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-692ec0f693

Comment 14 Dennis Gilmore 2018-09-04 14:38:13 UTC
with gnutls-3.6.3-4.fc29.x86_64 and glib-networking-2.58.0-1.fc29.x86_64 everything except for "gnutls-cli cdn.fwupd.org --rehandshake" seems to be working okay

Comment 15 Geoffrey Marr 2018-09-04 20:47:04 UTC
Discussed during the 2018-09-04 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedFreezeException" was made as 
this breaks major functionality of Evolution and other apps which are included in the Workstation live, thus cannot be fully fixed with an update.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-04/f29-blocker-review.2018-09-04-16.01.txt

Comment 16 Adam Williamson 2018-09-04 23:28:03 UTC
Kamil, can you check if this resolves your Epiphany and GNOME Software issues too? Thanks!

Comment 17 Kamil Páral 2018-09-05 08:49:08 UTC
(In reply to Adam Williamson from comment #16)
> Kamil, can you check if this resolves your Epiphany and GNOME Software
> issues too? Thanks!

Yes, it does. Great. Unfortunately it seems the compose process failed for that update, see https://bodhi.fedoraproject.org/updates/glib-networking-2.58.0-1.fc29#comment-829962

Comment 18 Fedora Update System 2018-09-08 05:40:39 UTC
yelp-xsl-3.30.0-1.fc29 yelp-3.30.0-1.fc29 webkit2gtk3-2.22.0-3.fc29 vala-0.42.0-1.fc29 tracker-miners-2.1.4-2.fc29 tracker-2.1.4-3.fc29 template-glib-3.30.0-2.fc29 sysprof-3.30.0-1.fc29 swell-foop-3.30.0-1.fc29 sushi-3.30.0-1.fc29 simple-scan-3.30.0-1.fc29 shotwell-0.29.92-1.fc29 seahorse-3.30-1.fc29 rygel-0.36.2-2.fc29 pygobject3-3.30.0-1.fc29 pyatspi-2.30.0-1.fc29 polari-3.30.0-1.fc29 orca-3.29.92-1.fc29 nautilus-3.30.0-2.fc29 mutter-3.30.0-1.fc29 lightsoff-3.30.0-1.fc29 libsoup-2.64.0-2.fc29 librsvg2-2.44.2-2.fc29 libdazzle-3.30.0-1.fc29 jsonrpc-glib-3.30.0-2.fc29 iagno-3.30.0-1.fc29 gvfs-1.38.0-1.fc29 gucharmap-11.0.2-2.fc29 gtksourceview4-4.0.3-2.fc29 gtksourceview3-3.24.9-4.fc29 gtk3-3.24.0-3.fc29 gtk-doc-1.29-1.fc29 gsettings-desktop-schemas-3.28.1-2.fc29 gobject-introspection-1.58.0-2.fc29 gnome-user-docs-3.30.0-1.fc29 gnome-tweaks-3.30.0-1.fc29 gnome-taquin-3.30.0-1.fc29 gnome-sudoku-3.30.0-1.fc29 gnome-software-3.30.0-1.fc29 gnome-shell-extensions-3.30.0-1.fc29 gnome-shell-3.30.0-1.fc29 gnome-settings-daemon-3.30.0-1.fc29 gnome-session-3.30.0-1.fc29 gnome-screenshot-3.30.0-1.fc29 gnome-power-manager-3.30.0-1.fc29 gnome-photos-3.30.0-1.fc29 gnome-packagekit-3.30.0-1.fc29 gnome-online-miners-3.30.0-1.fc29 gnome-online-accounts-3.30.0-3.fc29 gnome-nibbles-3.24.1-1.fc29 gnome-music-3.30.0-1.fc29 gnome-multi-writer-3.30.0-1.fc29 gnome-mines-3.30.0-1.fc29 gnome-maps-3.30.0-1.fc29 gnome-logs-3.30.0-1.fc29 gnome-initial-setup-3.29.92-1.fc29 gnome-getting-started-docs-3.30.0-1.fc29 gnome-font-viewer-3.30.0-1.fc29 gnome-disk-utility-3.30.0-1.fc29 gnome-desktop3-3.30.0-2.fc29 gnome-control-center-3.30.0-1.fc29 gnome-contacts-3.30-1.fc29 gnome-color-manager-3.30.0-1.fc29 gnome-clocks-3.30.0-1.fc29 gnome-chess-3.30.0-1.fc29 gnome-characters-3.29.91-1.fc29 gnome-calendar-3.30.0-1.fc29 gnome-calculator-3.30.0-1.fc29 gnome-builder-3.30.0-2.fc29 gnome-boxes-3.30.0-2.fc29 gnome-backgrounds-3.30.0-1.fc29 gnome-2048-3.30.0-1.fc29 glib2-2.58.0-1.fc29 glib-networking-2.58.0-2.fc29 gedit-plugins-3.30.0-1.fc29 gedit-3.30.0-2.fc29 gdm-3.30.0-3.fc29 gdk-pixbuf2-2.38.0-2.fc29 five-or-more-3.30.0-1.fc29 file-roller-3.30.0-1.fc29 evince-3.30.0-2.fc29 epiphany-3.30.0-1.fc29 devhelp-3.30.0-2.fc29 dconf-editor-3.30.0-1.fc29 dconf-0.30.0-1.fc29 cheese-3.30.0-2.fc29 bijiben-3.30.0-1.fc29 baobab-3.30.0-1.fc29 atomix-3.30.0.1-1.fc29 atk-2.29.92-2.fc29 at-spi2-core-2.30.0-2.fc29 at-spi2-atk-2.30.0-1.fc29 anjuta-3.28.0-7.fc29 amtk-5.0.0-2.fc29 aisleriot-3.22.6-1.fc29 adwaita-icon-theme-3.30.0-1.fc29 abattis-cantarell-fonts-0.111-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-85d637c544

Comment 19 Fedora Update System 2018-09-08 16:11:50 UTC
abattis-cantarell-fonts-0.111-1.fc29, adwaita-icon-theme-3.30.0-1.fc29, aisleriot-3.22.6-1.fc29, amtk-5.0.0-2.fc29, anjuta-3.28.0-7.fc29, at-spi2-atk-2.30.0-1.fc29, at-spi2-core-2.30.0-2.fc29, atk-2.29.92-2.fc29, atomix-3.30.0.1-1.fc29, baobab-3.30.0-1.fc29, bijiben-3.30.0-1.fc29, cheese-3.30.0-2.fc29, dconf-0.30.0-1.fc29, dconf-editor-3.30.0-1.fc29, devhelp-3.30.0-2.fc29, epiphany-3.30.0-1.fc29, evince-3.30.0-2.fc29, file-roller-3.30.0-1.fc29, five-or-more-3.30.0-1.fc29, gdk-pixbuf2-2.38.0-2.fc29, gdm-3.30.0-3.fc29, gedit-3.30.0-2.fc29, gedit-plugins-3.30.0-1.fc29, glib-networking-2.58.0-2.fc29, glib2-2.58.0-1.fc29, gnome-2048-3.30.0-1.fc29, gnome-backgrounds-3.30.0-1.fc29, gnome-boxes-3.30.0-2.fc29, gnome-builder-3.30.0-2.fc29, gnome-calculator-3.30.0-1.fc29, gnome-calendar-3.30.0-1.fc29, gnome-characters-3.29.91-1.fc29, gnome-chess-3.30.0-1.fc29, gnome-clocks-3.30.0-1.fc29, gnome-color-manager-3.30.0-1.fc29, gnome-contacts-3.30-1.fc29, gnome-control-center-3.30.0-1.fc29, gnome-desktop3-3.30.0-2.fc29, gnome-disk-utility-3.30.0-1.fc29, gnome-font-viewer-3.30.0-1.fc29, gnome-getting-started-docs-3.30.0-1.fc29, gnome-initial-setup-3.29.92-1.fc29, gnome-logs-3.30.0-1.fc29, gnome-maps-3.30.0-1.fc29, gnome-mines-3.30.0-1.fc29, gnome-multi-writer-3.30.0-1.fc29, gnome-music-3.30.0-1.fc29, gnome-nibbles-3.24.1-1.fc29, gnome-online-accounts-3.30.0-3.fc29, gnome-online-miners-3.30.0-1.fc29, gnome-packagekit-3.30.0-1.fc29, gnome-photos-3.30.0-1.fc29, gnome-power-manager-3.30.0-1.fc29, gnome-screenshot-3.30.0-1.fc29, gnome-session-3.30.0-1.fc29, gnome-settings-daemon-3.30.0-1.fc29, gnome-shell-3.30.0-1.fc29, gnome-shell-extensions-3.30.0-1.fc29, gnome-software-3.30.0-1.fc29, gnome-sudoku-3.30.0-1.fc29, gnome-taquin-3.30.0-1.fc29, gnome-tweaks-3.30.0-1.fc29, gnome-user-docs-3.30.0-1.fc29, gobject-introspection-1.58.0-2.fc29, gsettings-desktop-schemas-3.28.1-2.fc29, gtk-doc-1.29-1.fc29, gtk3-3.24.0-3.fc29, gtksourceview3-3.24.9-4.fc29, gtksourceview4-4.0.3-2.fc29, gucharmap-11.0.2-2.fc29, gvfs-1.38.0-1.fc29, iagno-3.30.0-1.fc29, jsonrpc-glib-3.30.0-2.fc29, libdazzle-3.30.0-1.fc29, librsvg2-2.44.2-2.fc29, libsoup-2.64.0-2.fc29, lightsoff-3.30.0-1.fc29, mutter-3.30.0-1.fc29, nautilus-3.30.0-2.fc29, orca-3.29.92-1.fc29, polari-3.30.0-1.fc29, pyatspi-2.30.0-1.fc29, pygobject3-3.30.0-1.fc29, rygel-0.36.2-2.fc29, seahorse-3.30-1.fc29, shotwell-0.29.92-1.fc29, simple-scan-3.30.0-1.fc29, sushi-3.30.0-1.fc29, swell-foop-3.30.0-1.fc29, sysprof-3.30.0-1.fc29, template-glib-3.30.0-2.fc29, tracker-2.1.4-3.fc29, tracker-miners-2.1.4-2.fc29, vala-0.42.0-1.fc29, webkit2gtk3-2.22.0-3.fc29, yelp-3.30.0-1.fc29, yelp-xsl-3.30.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-85d637c544

Comment 20 Fedora Update System 2018-09-10 12:46:19 UTC
abattis-cantarell-fonts-0.111-1.fc29 adwaita-icon-theme-3.30.0-1.fc29 aisleriot-3.22.6-1.fc29 amtk-5.0.0-2.fc29 anjuta-3.28.0-7.fc29 at-spi2-atk-2.30.0-1.fc29 at-spi2-core-2.30.0-2.fc29 atk-2.30.0-1.fc29 atomix-3.30.0.1-1.fc29 baobab-3.30.0-1.fc29 bijiben-3.30.0-1.fc29 cheese-3.30.0-2.fc29 dconf-0.30.0-1.fc29 dconf-editor-3.30.0-1.fc29 devhelp-3.30.0-2.fc29 epiphany-3.30.0-1.fc29 evince-3.30.0-2.fc29 file-roller-3.30.0-1.fc29 five-or-more-3.30.0-1.fc29 gdk-pixbuf2-2.38.0-4.fc29 gdm-3.30.0-3.fc29 gedit-3.30.0-2.fc29 gedit-plugins-3.30.0-1.fc29 gjs-1.54.0-2.fc29 glib-networking-2.58.0-2.fc29 glib2-2.58.0-1.fc29 gnome-2048-3.30.0-1.fc29 gnome-backgrounds-3.30.0-1.fc29 gnome-boxes-3.30.0-2.fc29 gnome-builder-3.30.0-2.fc29 gnome-calculator-3.30.0-1.fc29 gnome-calendar-3.30.0-1.fc29 gnome-characters-3.29.91-1.fc29 gnome-chess-3.30.0-1.fc29 gnome-clocks-3.30.0-2.fc29 gnome-color-manager-3.30.0-1.fc29 gnome-contacts-3.30-1.fc29 gnome-control-center-3.30.0-1.fc29 gnome-desktop3-3.30.0-2.fc29 gnome-disk-utility-3.30.0-1.fc29 gnome-font-viewer-3.30.0-1.fc29 gnome-getting-started-docs-3.30.0-1.fc29 gnome-initial-setup-3.29.92-1.fc29 gnome-logs-3.30.0-1.fc29 gnome-maps-3.30.0-1.fc29 gnome-mines-3.30.0-1.fc29 gnome-multi-writer-3.30.0-1.fc29 gnome-music-3.30.0-1.fc29 gnome-nibbles-3.24.1-1.fc29 gnome-online-accounts-3.30.0-3.fc29 gnome-online-miners-3.30.0-1.fc29 gnome-packagekit-3.30.0-1.fc29 gnome-photos-3.30.0-1.fc29 gnome-power-manager-3.30.0-1.fc29 gnome-screenshot-3.30.0-1.fc29 gnome-session-3.30.0-1.fc29 gnome-settings-daemon-3.30.0-1.fc29 gnome-shell-3.30.0-1.fc29 gnome-shell-extensions-3.30.0-1.fc29 gnome-software-3.30.0-1.fc29 gnome-sudoku-3.30.0-2.fc29 gnome-taquin-3.30.0-1.fc29 gnome-tweaks-3.30.0-1.fc29 gnome-user-docs-3.30.0-1.fc29 gobject-introspection-1.58.0-2.fc29 gpaste-3.30.1-1.fc29 gsettings-desktop-schemas-3.28.1-2.fc29 gtk-doc-1.29-1.fc29 gtk3-3.24.0-3.fc29 gtksourceview3-3.24.9-4.fc29 gtksourceview4-4.0.3-2.fc29 gucharmap-11.0.2-2.fc29 gvfs-1.38.0-1.fc29 iagno-3.30.0-1.fc29 jsonrpc-glib-3.30.0-2.fc29 libdazzle-3.30.0-1.fc29 librsvg2-2.44.2-2.fc29 libsoup-2.64.0-2.fc29 lightsoff-3.30.0-1.fc29 mozjs60-60.1.0-1.fc29 mutter-3.30.0-1.fc29 nautilus-3.30.0-2.fc29 orca-3.29.92-1.fc29 polari-3.30.0-1.fc29 pyatspi-2.30.0-1.fc29 pygobject3-3.30.0-1.fc29 rygel-0.36.2-2.fc29 seahorse-3.30-1.fc29 shotwell-0.29.92-1.fc29 simple-scan-3.30.0-1.fc29 sushi-3.30.0-1.fc29 swell-foop-3.30.0-1.fc29 sysprof-3.30.0-1.fc29 template-glib-3.30.0-2.fc29 tracker-2.1.4-3.fc29 tracker-miners-2.1.4-2.fc29 vala-0.42.0-1.fc29 webkit2gtk3-2.22.0-3.fc29 yelp-3.30.0-1.fc29 yelp-xsl-3.30.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-85d637c544

Comment 21 Fedora Update System 2018-09-11 06:13:30 UTC
abattis-cantarell-fonts-0.111-1.fc29, adwaita-icon-theme-3.30.0-1.fc29, aisleriot-3.22.6-1.fc29, amtk-5.0.0-2.fc29, anjuta-3.28.0-7.fc29, at-spi2-atk-2.30.0-1.fc29, at-spi2-core-2.30.0-2.fc29, atk-2.30.0-1.fc29, atomix-3.30.0.1-1.fc29, baobab-3.30.0-1.fc29, bijiben-3.30.0-1.fc29, cheese-3.30.0-2.fc29, dconf-0.30.0-1.fc29, dconf-editor-3.30.0-1.fc29, devhelp-3.30.0-2.fc29, epiphany-3.30.0-1.fc29, evince-3.30.0-2.fc29, file-roller-3.30.0-1.fc29, five-or-more-3.30.0-1.fc29, gdk-pixbuf2-2.38.0-4.fc29, gdm-3.30.0-3.fc29, gedit-3.30.0-2.fc29, gedit-plugins-3.30.0-1.fc29, gjs-1.54.0-2.fc29, glib-networking-2.58.0-2.fc29, glib2-2.58.0-1.fc29, gnome-2048-3.30.0-1.fc29, gnome-backgrounds-3.30.0-1.fc29, gnome-boxes-3.30.0-2.fc29, gnome-builder-3.30.0-2.fc29, gnome-calculator-3.30.0-1.fc29, gnome-calendar-3.30.0-1.fc29, gnome-characters-3.29.91-1.fc29, gnome-chess-3.30.0-1.fc29, gnome-clocks-3.30.0-2.fc29, gnome-color-manager-3.30.0-1.fc29, gnome-contacts-3.30-1.fc29, gnome-control-center-3.30.0-1.fc29, gnome-desktop3-3.30.0-2.fc29, gnome-disk-utility-3.30.0-1.fc29, gnome-font-viewer-3.30.0-1.fc29, gnome-getting-started-docs-3.30.0-1.fc29, gnome-initial-setup-3.29.92-1.fc29, gnome-logs-3.30.0-1.fc29, gnome-maps-3.30.0-1.fc29, gnome-mines-3.30.0-1.fc29, gnome-multi-writer-3.30.0-1.fc29, gnome-music-3.30.0-1.fc29, gnome-nibbles-3.24.1-1.fc29, gnome-online-accounts-3.30.0-3.fc29, gnome-online-miners-3.30.0-1.fc29, gnome-packagekit-3.30.0-1.fc29, gnome-photos-3.30.0-1.fc29, gnome-power-manager-3.30.0-1.fc29, gnome-screenshot-3.30.0-1.fc29, gnome-session-3.30.0-1.fc29, gnome-settings-daemon-3.30.0-1.fc29, gnome-shell-3.30.0-1.fc29, gnome-shell-extensions-3.30.0-1.fc29, gnome-software-3.30.0-1.fc29, gnome-sudoku-3.30.0-2.fc29, gnome-taquin-3.30.0-1.fc29, gnome-tweaks-3.30.0-1.fc29, gnome-user-docs-3.30.0-1.fc29, gobject-introspection-1.58.0-2.fc29, gpaste-3.30.1-1.fc29, gsettings-desktop-schemas-3.28.1-2.fc29, gtk-doc-1.29-1.fc29, gtk3-3.24.0-3.fc29, gtksourceview3-3.24.9-4.fc29, gtksourceview4-4.0.3-2.fc29, gucharmap-11.0.2-2.fc29, gvfs-1.38.0-1.fc29, iagno-3.30.0-1.fc29, jsonrpc-glib-3.30.0-2.fc29, libdazzle-3.30.0-1.fc29, librsvg2-2.44.2-2.fc29, libsoup-2.64.0-2.fc29, lightsoff-3.30.0-1.fc29, mozjs60-60.1.0-1.fc29, mutter-3.30.0-1.fc29, nautilus-3.30.0-2.fc29, orca-3.29.92-1.fc29, polari-3.30.0-1.fc29, pyatspi-2.30.0-1.fc29, pygobject3-3.30.0-1.fc29, rygel-0.36.2-2.fc29, seahorse-3.30-1.fc29, shotwell-0.29.92-1.fc29, simple-scan-3.30.0-1.fc29, sushi-3.30.0-1.fc29, swell-foop-3.30.0-1.fc29, sysprof-3.30.0-1.fc29, template-glib-3.30.0-2.fc29, tracker-2.1.4-3.fc29, tracker-miners-2.1.4-2.fc29, vala-0.42.0-1.fc29, webkit2gtk3-2.22.0-3.fc29, yelp-3.30.0-1.fc29, yelp-xsl-3.30.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-85d637c544

Comment 22 Fedora Update System 2018-09-11 08:02:55 UTC
abattis-cantarell-fonts-0.111-1.fc29 adwaita-icon-theme-3.30.0-1.fc29 aisleriot-3.22.6-1.fc29 amtk-5.0.0-2.fc29 anjuta-3.28.0-7.fc29 at-spi2-atk-2.30.0-1.fc29 at-spi2-core-2.30.0-2.fc29 atk-2.30.0-1.fc29 atomix-3.30.0.1-1.fc29 baobab-3.30.0-1.fc29 bijiben-3.30.0-1.fc29 cheese-3.30.0-2.fc29 dconf-0.30.0-1.fc29 dconf-editor-3.30.0-1.fc29 devhelp-3.30.0-2.fc29 epiphany-3.30.0-1.fc29 evince-3.30.0-2.fc29 file-roller-3.30.0-1.fc29 five-or-more-3.30.0-1.fc29 gdk-pixbuf2-2.38.0-4.fc29 gdm-3.30.0-3.fc29 gedit-3.30.0-2.fc29 gedit-plugins-3.30.0-1.fc29 gjs-1.54.0-2.fc29 glib-networking-2.58.0-2.fc29 glib2-2.58.0-1.fc29 gnome-2048-3.30.0-1.fc29 gnome-backgrounds-3.30.0-1.fc29 gnome-boxes-3.30.0-2.fc29 gnome-builder-3.30.0-2.fc29 gnome-calculator-3.30.0-1.fc29 gnome-calendar-3.30.0-1.fc29 gnome-characters-3.29.91-1.fc29 gnome-chess-3.30.0-1.fc29 gnome-clocks-3.30.0-2.fc29 gnome-color-manager-3.30.0-1.fc29 gnome-contacts-3.30-1.fc29 gnome-control-center-3.30.0-1.fc29 gnome-desktop3-3.30.0-2.fc29 gnome-disk-utility-3.30.0-1.fc29 gnome-font-viewer-3.30.0-1.fc29 gnome-getting-started-docs-3.30.0-1.fc29 gnome-initial-setup-3.29.92-1.fc29 gnome-logs-3.30.0-1.fc29 gnome-maps-3.30.0-1.fc29 gnome-mines-3.30.0-1.fc29 gnome-multi-writer-3.30.0-1.fc29 gnome-music-3.30.0-1.fc29 gnome-nibbles-3.24.1-1.fc29 gnome-online-accounts-3.30.0-3.fc29 gnome-online-miners-3.30.0-1.fc29 gnome-packagekit-3.30.0-1.fc29 gnome-photos-3.30.0-1.fc29 gnome-power-manager-3.30.0-1.fc29 gnome-screenshot-3.30.0-1.fc29 gnome-session-3.30.0-1.fc29 gnome-settings-daemon-3.30.0-1.fc29 gnome-shell-3.30.0-1.fc29 gnome-shell-extensions-3.30.0-1.fc29 gnome-software-3.30.0-1.fc29 gnome-sudoku-3.30.0-2.fc29 gnome-taquin-3.30.0-1.fc29 gnome-tweaks-3.30.0-1.fc29 gnome-user-docs-3.30.0-1.fc29 gobject-introspection-1.58.0-2.fc29 gpaste-3.30.1-1.fc29 gsettings-desktop-schemas-3.28.1-2.fc29 gtk-doc-1.29-1.fc29 gtk3-3.24.0-4.fc29 gtksourceview3-3.24.9-4.fc29 gtksourceview4-4.0.3-2.fc29 gucharmap-11.0.2-2.fc29 gvfs-1.38.0-1.fc29 iagno-3.30.0-1.fc29 jsonrpc-glib-3.30.0-2.fc29 libdazzle-3.30.0-1.fc29 librsvg2-2.44.2-2.fc29 libsoup-2.64.0-2.fc29 lightsoff-3.30.0-1.fc29 mozjs60-60.1.0-1.fc29 mutter-3.30.0-1.fc29 nautilus-3.30.0-2.fc29 orca-3.29.92-1.fc29 polari-3.30.0-1.fc29 pyatspi-2.30.0-1.fc29 pygobject3-3.30.0-1.fc29 rygel-0.36.2-2.fc29 seahorse-3.30-1.fc29 shotwell-0.29.92-1.fc29 simple-scan-3.30.0-1.fc29 sushi-3.30.0-1.fc29 swell-foop-3.30.0-1.fc29 sysprof-3.30.0-1.fc29 template-glib-3.30.0-2.fc29 tracker-2.1.4-3.fc29 tracker-miners-2.1.4-2.fc29 vala-0.42.0-1.fc29 webkit2gtk3-2.22.0-3.fc29 yelp-3.30.0-1.fc29 yelp-xsl-3.30.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-85d637c544

Comment 23 Fedora Update System 2018-09-12 02:54:55 UTC
abattis-cantarell-fonts-0.111-1.fc29, adwaita-icon-theme-3.30.0-1.fc29, aisleriot-3.22.6-1.fc29, amtk-5.0.0-2.fc29, anjuta-3.28.0-7.fc29, at-spi2-atk-2.30.0-1.fc29, at-spi2-core-2.30.0-2.fc29, atk-2.30.0-1.fc29, atomix-3.30.0.1-1.fc29, baobab-3.30.0-1.fc29, bijiben-3.30.0-1.fc29, cheese-3.30.0-2.fc29, dconf-0.30.0-1.fc29, dconf-editor-3.30.0-1.fc29, devhelp-3.30.0-2.fc29, epiphany-3.30.0-1.fc29, evince-3.30.0-2.fc29, file-roller-3.30.0-1.fc29, five-or-more-3.30.0-1.fc29, gdk-pixbuf2-2.38.0-4.fc29, gdm-3.30.0-3.fc29, gedit-3.30.0-2.fc29, gedit-plugins-3.30.0-1.fc29, gjs-1.54.0-2.fc29, glib-networking-2.58.0-2.fc29, glib2-2.58.0-1.fc29, gnome-2048-3.30.0-1.fc29, gnome-backgrounds-3.30.0-1.fc29, gnome-boxes-3.30.0-2.fc29, gnome-builder-3.30.0-2.fc29, gnome-calculator-3.30.0-1.fc29, gnome-calendar-3.30.0-1.fc29, gnome-characters-3.29.91-1.fc29, gnome-chess-3.30.0-1.fc29, gnome-clocks-3.30.0-2.fc29, gnome-color-manager-3.30.0-1.fc29, gnome-contacts-3.30-1.fc29, gnome-control-center-3.30.0-1.fc29, gnome-desktop3-3.30.0-2.fc29, gnome-disk-utility-3.30.0-1.fc29, gnome-font-viewer-3.30.0-1.fc29, gnome-getting-started-docs-3.30.0-1.fc29, gnome-initial-setup-3.29.92-1.fc29, gnome-logs-3.30.0-1.fc29, gnome-maps-3.30.0-1.fc29, gnome-mines-3.30.0-2.fc29, gnome-multi-writer-3.30.0-1.fc29, gnome-music-3.30.0-1.fc29, gnome-nibbles-3.24.1-1.fc29, gnome-online-accounts-3.30.0-3.fc29, gnome-online-miners-3.30.0-1.fc29, gnome-packagekit-3.30.0-1.fc29, gnome-photos-3.30.0-1.fc29, gnome-power-manager-3.30.0-1.fc29, gnome-screenshot-3.30.0-1.fc29, gnome-session-3.30.0-1.fc29, gnome-settings-daemon-3.30.0-1.fc29, gnome-shell-3.30.0-1.fc29, gnome-shell-extensions-3.30.0-1.fc29, gnome-software-3.30.0-1.fc29, gnome-sudoku-3.30.0-2.fc29, gnome-taquin-3.30.0-1.fc29, gnome-tweaks-3.30.0-1.fc29, gnome-user-docs-3.30.0-1.fc29, gobject-introspection-1.58.0-2.fc29, gpaste-3.30.1-1.fc29, gsettings-desktop-schemas-3.28.1-2.fc29, gtk-doc-1.29-1.fc29, gtk3-3.24.0-4.fc29, gtksourceview3-3.24.9-4.fc29, gtksourceview4-4.0.3-2.fc29, gucharmap-11.0.2-2.fc29, gvfs-1.38.0-1.fc29, iagno-3.30.0-1.fc29, jsonrpc-glib-3.30.0-2.fc29, libdazzle-3.30.0-1.fc29, librsvg2-2.44.2-2.fc29, libsoup-2.64.0-2.fc29, lightsoff-3.30.0-1.fc29, mozjs60-60.1.0-1.fc29, mutter-3.30.0-1.fc29, nautilus-3.30.0-2.fc29, orca-3.29.92-1.fc29, polari-3.30.0-1.fc29, pyatspi-2.30.0-1.fc29, pygobject3-3.30.0-1.fc29, rygel-0.36.2-2.fc29, seahorse-3.30-1.fc29, shotwell-0.29.92-1.fc29, simple-scan-3.30.0-1.fc29, sushi-3.30.0-1.fc29, swell-foop-3.30.0-1.fc29, sysprof-3.30.0-1.fc29, template-glib-3.30.0-2.fc29, tracker-2.1.4-3.fc29, tracker-miners-2.1.4-2.fc29, vala-0.42.0-1.fc29, webkit2gtk3-2.22.0-3.fc29, yelp-3.30.0-1.fc29, yelp-xsl-3.30.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.