Bug 1623690 - RFE Please re-enable windows guest enlightenments disabled by #1336517
Summary: RFE Please re-enable windows guest enlightenments disabled by #1336517
Keywords:
Status: CLOSED DUPLICATE of bug 1610461
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Vitaly Kuznetsov
QA Contact: FuXiangChun
URL:
Whiteboard:
Depends On: 1631439
Blocks: 1624786
TreeView+ depends on / blocked
 
Reported: 2018-08-29 21:53 UTC by Mai Ling
Modified: 2018-10-15 09:50 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1628757 (view as bug list)
Environment:
Last Closed: 2018-10-15 09:50:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1336517 unspecified CLOSED Disable hv-vpindex, hv-runtime, hv-reset, hv-synic & hv-stimer enlightenment for Windows 2019-12-10 06:05:13 UTC

Description Mai Ling 2018-08-29 21:53:02 UTC
Description of problem:
idle windows 10 guests consume > 50%cpu

Version-Release number of selected component (if applicable):
http://cbs.centos.org/kojifiles/packages/qemu-kvm-ev/2.10.0/21.el7_5.4.1/src/qemu-kvm-ev-2.10.0-21.el7_5.4.1.src.rpm

How reproducible:
always

Steps to Reproduce:
1. run windows 1803 (or server 2019 insider) guest, uefi q35
2.
3.

Actual results:
idle guest takes >50% of host cpu

Expected results:
windows idle guest consumes 2-3% cpu (ideally zero like linux, but that's a different bug)

Additional info:
#1336517 disabled several hyper-v features.
the impact is windows 10 idle guests take big cpu cycles on host.
After learning from https://bugs.launchpad.net/qemu/+bug/1775702/comments/3 that I need hv-synic and hv-stimer, I've rebuilt locally qemu-kvm-ev-2.10.0-21.el7_5.4.1.src.rpm by reverting the "if 0" to "if 1" around these lines:

    DEFINE_PROP_BOOL("hv-synic", X86CPU, hyperv_synic, false),
    DEFINE_PROP_BOOL("hv-stimer", X86CPU, hyperv_stimer, false),

now guest cpu usage is down to 2-3% (needs kernel 4.2+ because ovmf secure boot needed by win10 images downloaded from ms ie modern.ie is supported only by kvm in kernel 4.2 or later)

please revert #1336517

thanks.


Note You need to log in before you can comment on or make changes to this bug.