Bug 162385 - [i915] vt's blank after x11 starts
[i915] vt's blank after x11 starts
Status: CLOSED DUPLICATE of bug 161242
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 162386 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-03 16:46 EDT by Paul Dickson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-02 06:41:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shell script to update x11 to use i915 (2.03 KB, text/plain)
2005-07-03 16:52 EDT, Paul Dickson
no flags Details

  None (edit)
Description Paul Dickson 2005-07-03 16:46:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050620 Firefox/1.0+

Description of problem:
Some change between xorg-x11-6.8.2-31 and xorg-x11-6.8.2-37 causes the vt's (1 through 6) to be displayed as blank screens (only the backlight is on).  The contents of the vt is there (I can login and ps from gnome-terminal shows the login), but nothing is displayed on the vt screen.

This is on my Dell Inspiron 6000, which needs updated drivers to use the i915 video.  I replace three X11 file with version from http://dri.freedesktop.org/snapshots.  Attached is the shell script I use to download these files.

    Files being replaced:
      /usr/X11R6/lib/libGL.so.1.2
      /usr/X11R6/lib/modules/dri/i915_dri.so
      /usr/X11R6/lib/modules/drivers/i810_drv.o

If I don't download the above files, then x11 won't start and I don't have the vt to fall back to.  I can only do a Ctl-Alt-Del so the system will shutdown and reboot.

00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

For other reasons, I run rhgb using the VESA driver.  But during that period I can switch to vt1 and see the output.

This problem exists in 6.8.2-38 and 6.8.2-40.

Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-37

How reproducible:
Always

Steps to Reproduce:
1. From 6.8.2-31 and the 915 chip set, install 6.8.2-37 
2. reboot
3. Replace the three files if you wish to get the system working under the chipset rather than the slow VESA driver.
4. Ctl-Alt-Fn (where n=any of 1-6)

Actual Results:  I get a blank screen (dark) with only the back light on.

I can login blindly, but I can't see what's supposed to be on the screen.

Expected Results:  I should be given a login display.

Additional info:
Comment 1 Paul Dickson 2005-07-03 16:52:38 EDT
Created attachment 116313 [details]
Shell script to update x11 to use i915

I use this script to download and install the three files I need to get x11 to
work using the i915 chipset.  I noticed today that they aren't making daily
updates, hence the value YESTERDAY is set to June 28, the latest snapshot
available.
Comment 2 Paul Dickson 2005-07-03 17:10:21 EDT
*** Bug 162386 has been marked as a duplicate of this bug. ***
Comment 3 Paul Dickson 2005-07-03 17:26:33 EDT
My most recent thought about what was causing this problem was difference in
compiler versions from the rawhide and the one from 
http://dri.freedesktop.org/snapshots.  

So after yum installed 6.8.2-40, I attempted to bring up the system without
snapshot versions.  Not only did x11 not start (expected) but I still could not
use the vt.

The good news is that after updating x11 with the snapshot version, it could
build xorg.conf with the correct drivers and resolutions.  Although I'm not sure
if this is related to the snapshot update or the later version (-40).
Comment 4 Mike A. Harris 2005-07-05 05:14:44 EDT
This is probably a duplicate of bug #161242.  You'll need to restore all
Red Hat supplied files in order to test this first however.

Please restore all original files, then update to the latest updates
we've released for this FC release.  After this, reproduce the problem,
then test the workaround in bug #161242 by installing the libvgahw.a
module linked to and rebooting the system completely.  If the problem
recurs, attach your X server config file and log file using our supplied
modules.

Setting status to "NEEDINFO"
Comment 5 Paul Dickson 2005-07-05 12:02:15 EDT
I replaced libvgahw.a with the one provided in bug #161242 and the problem's
gone away.  I can now access the vt's.

Thanks.
Comment 6 Paul Dickson 2005-07-15 08:53:49 EDT
I updated to xorg-x11-6.8.2-43, which purports to have a work-around for bug
#161242 (among others).

This version still has the same problems as initial reported in this bug report.
Comment 7 Colin Charles 2005-07-29 05:36:31 EDT
So while bug #161242's libvgahw appears to have been solved, your's on the i915
didn't? However, using the regular libvgahw.a from FC-3 (or mharris's site)
seemed to have worked for you? Please double check, to make sure
Comment 8 Paul Dickson 2005-07-29 11:47:24 EDT
I update to xorg-x11-6.8.2-44.  The problem does not occur in this version.

I did have the problem with Ctl-Alt-F1 being interepted as F1, so I was unable
to swap to the VT's.  This happened at gdm's login screen:  from the login
prompt, ctl-alt-F1 correctly placed me at vt1, ctl-alt-F7 placed me at gdm's
login prompt again, then pressing ctl-alt-F1 would NOT allow me to switch back
to vt1.

The same problem occurred after I logged in.  I was able to get to vt1 once, and
not again until I changed the focus (I had several help windows eventually pop
up, from the F1's).  Then the problem went away.

I'm willing to consider the problem closed.  The above problem is likely due to
Gnome.
Comment 9 Olivier Baudron 2005-08-02 06:39:12 EDT
Based on the summary and comment #1 we shall consider this a dup of bug #161242.

The issue in comment #8 is not related, so if the problem persists reopen
another bug report.
Comment 10 Olivier Baudron 2005-08-02 06:41:03 EDT

*** This bug has been marked as a duplicate of 161242 ***

Note You need to log in before you can comment on or make changes to this bug.