Bug 1623985 - podman rm emits networking error messages
Summary: podman rm emits networking error messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: podman
Version: 7.6
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Frantisek Kluknavsky
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-30 15:29 UTC by Qian Cai
Modified: 2018-09-26 07:48 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-26 07:47:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2796 None None None 2018-09-26 07:48:04 UTC

Description Qian Cai 2018-08-30 15:29:07 UTC
Description of problem:
This only happened on ppc64le so far.

# podman rm httpd
time="2018-08-30T11:16:39-04:00" level=error msg="`iptables -t filter -D FORWARD -s 10.88.0.137 ! -o 10.88.0.137 -j ACCEPT` failed: iptables: Bad rule (does a matching rule exist in that chain?).
  (exit status 1)" 
time="2018-08-30T11:16:39-04:00" level=error msg="Error deleting network: failed to Statfs "/var/run/netns/cni-872691e1-c322-c29d-6394-13c59e72e4af": no such file or directory" 
time="2018-08-30T11:16:39-04:00" level=error msg="Error while removing pod from CNI network "podman": failed to Statfs "/var/run/netns/cni-872691e1-c322-c29d-6394-13c59e72e4af": no such file or directory" 
time="2018-08-30T11:16:39-04:00" level=error msg="Failed to tear down network namespace for container 1930017ee2ba38cc70143bca96e3da65394fb6e01ba81bf60eb7b580bfb5822a: failed to Statfs "/var/run/netns/cni-872691e1-c322-c29d-6394-13c59e72e4af": no such file or directory" 
1930017ee2ba38cc70143bca96e3da65394fb6e01ba81bf60eb7b580bfb5822a

Version-Release number of selected component (if applicable):
podman-0.7.3-1.git0791210.el7.ppc64le
RHEL-7.6 snapshot 1

How reproducible:
always

Steps to Reproduce:
1. podman pull brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/rhel7:7.6
2. podman tag brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/rhel7:7.6 base-image
3. cat Dockerfile
FROM base-image

RUN yum -y install  httpd
RUN yum clean all; systemctl enable httpd
RUN echo "Hello World!" > /var/www/html/index.html

STOPSIGNAL SIGRTMIN+3
EXPOSE 80
CMD ["/usr/sbin/init"]
4. podman build -v /etc/yum.repos.d/:/etc/yum.repos.d/ --rm --no-cache --force-rm -t httpd-systemd .
5. podman  run -d --name httpd httpd-systemd
6. podman inspect httpd | grep IPA
7. curl <ip above>
8. podman stop httpd
9. podman rm httpd

Comment 1 Daniel Walsh 2018-08-30 16:04:10 UTC
Brent isn't this fixed in the newer updates?

Comment 4 Lokesh Mandvekar 2018-08-30 17:49:05 UTC
Frantisek, please use this bug for podman errata.

Comment 5 Qian Cai 2018-08-30 18:20:14 UTC
This also happened on s390x.

RHEL-ALT-7.6-20180829.0

Comment 6 Frantisek Kluknavsky 2018-09-03 16:14:54 UTC
Hi,

podman does not depend on oci-systemd-hook, systemd in the container does not start without --privileged.
After installing oci-systemd-hook, it seems to work well. I can not reproduce the problem on ppc64le.

Comment 7 Frantisek Kluknavsky 2018-09-03 16:37:58 UTC
The same result on regular rhel ppc64le and on alt-arch rhel ppc64le.

Comment 11 Qian Cai 2018-09-04 13:09:45 UTC
Fixed in podman-0.8.4-3.git9f9b8cf.el7

Comment 13 errata-xmlrpc 2018-09-26 07:47:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2796


Note You need to log in before you can comment on or make changes to this bug.