Bug 1624311 - Need cifs-utils package installed by default for Azure
Summary: Need cifs-utils package installed by default for Azure
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.11.z
Assignee: Jan Chaloupka
QA Contact: Wenqi He
URL:
Whiteboard:
: 1651052 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-31 08:06 UTC by Wenqi He
Modified: 2019-06-04 10:40 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:40:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:40:41 UTC

Description Wenqi He 2018-08-31 08:06:37 UTC
Description of problem:
To use Azure file, all the cluster node should install cifs-utils by default
Seems a regression for bug #1537872

Version-Release number of the following components:
rpm -q openshift-ansible
openshift-ansible-3.11.0-0.25.0.git.0.7497e69.el7
rpm -q ansible
ansible-2.6.3-1.el7ae
How reproducible:
Always

Steps to Reproduce:
1. Install OCP on Azure
2.
3.

Actual results:
No packages of cifs-utils on all nodes
mount -t cifs will fail

Expected results:
mount type cifs should be enabled by default

Additional info:

Comment 5 Scott Dodson 2018-12-06 13:23:46 UTC
*** Bug 1651052 has been marked as a duplicate of this bug. ***

Comment 6 Scott Dodson 2018-12-06 13:24:22 UTC
The duped bug also mentions the need to install samba-common.

Comment 8 Jan Chaloupka 2018-12-07 12:54:27 UTC
Upstream issue: https://github.com/openshift/openshift-ansible/pull/10842

Comment 9 Jan Chaloupka 2019-01-09 12:24:44 UTC
Merged upstream

Comment 11 Wenqi He 2019-01-23 07:40:24 UTC
Hi Jan, are we going to fix this in 4.0? Since I found this bug's target release is 4.0, but only has 3.11 PR, and the I tried to verify it on master branch(4.0?), there is no packages of cifs-utils.
For 4.0: https://github.com/openshift/openshift-ansible/blob/master/roles/openshift_node/defaults/main.yml
For 3.11: https://github.com/openshift/openshift-ansible/blob/release-3.11/roles/openshift_node/defaults/main.yml

Comment 13 Wenqi He 2019-01-29 08:16:43 UTC
Tested on below openshift-ansible version:
openshift-ansible-3.11.75

Now we have cifs-utils packages:
# mount.
mount.cifs       mount.glusterfs  mount.nfs        mount.nfs4       
# rpm -qa | grep cifs
cifs-utils-6.2-10.el7.x86_64

Comment 15 errata-xmlrpc 2019-06-04 10:40:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.