Bug 162444 - Update to ant 1.6.5
Update to ant 1.6.5
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Gary Benson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-04 16:07 EDT by Andrew Overholt
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-13 10:14:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2005-07-04 16:07:34 EDT
Description of problem:
Eclipse 3.1 needs classes from ant >= 1.6.3 to build.  This is, unless we ship
the pre-built ant jars that come with Eclipse.  We don't want to do this anymore :)

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Always

Steps to Reproduce:
1. try to build Eclipse 3.1 with all of ant's jars symlinked to those in
/usr/share/java.
  
Actual results:
    [javac] 1. ERROR in
/home/overholt/cvsdist/eclipse/devel/eclipse-3.1.0_fc/plugins/org.eclipse.ant.core/src_ant/org/eclipse/ant/internal/core/ant/EclipseDefaultExecutor.java
    [javac]  (at line 17)
    [javac]     import org.apache.tools.ant.Executor;
    [javac]            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    [javac] The import org.apache.tools.ant.Executor cannot be resolved


Expected results:
Compilation succeeds.

Additional info:
Comment 3 Andrew Overholt 2005-09-13 10:14:33 EDT
This is no longer necessary.  Closing.

Note You need to log in before you can comment on or make changes to this bug.