Bug 1624440 - Fail volume stop operation in case brick detach request fails
Summary: Fail volume stop operation in case brick detach request fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1624444
TreeView+ depends on / blocked
 
Reported: 2018-08-31 15:11 UTC by Atin Mukherjee
Modified: 2018-10-23 15:18 UTC (History)
1 user (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1624444 (view as bug list)
Environment:
Last Closed: 2018-10-23 15:18:02 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2018-08-31 15:11:07 UTC
Description of problem:

While sending a detach request for a brick in brick multiplexing mode, in any situation if the brick isn't connected, glusterd will fail to detach the brick but due to the missing error code handling, glusterd will mark the volume as stopped.

Version-Release number of selected component (if applicable):
mainline.



How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2018-08-31 15:14:28 UTC
REVIEW: https://review.gluster.org/21055 (glusterd: fail volume stop operation if brick detach fails) posted (#1) for review on master by Atin Mukherjee

Comment 2 Worker Ant 2018-09-04 04:02:30 UTC
COMMIT: https://review.gluster.org/21055 committed in master by "Atin Mukherjee" <amukherj@redhat.com> with a commit message- glusterd: fail volume stop operation if brick detach fails

While sending a detach request for a brick in brick multiplexing mode,
in any situation if the brick isn't connected, glusterd will fail to
detach the brick but due to the missing error code handling, glusterd
will mark the volume as stopped.

Fix is to handle the return code of send_attach_req in
glusterd_volume_stop_glusterfs ()

Change-Id: I886202969c96eec3620f74cd7027652d6287f4be
Fixes: bz#1624440
Signed-off-by: Atin Mukherjee <amukherj@redhat.com>

Comment 3 Shyamsundar 2018-10-23 15:18:02 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.