Bug 1624464 - openstack overcloud status run on overcloud not deployed output needs cleanup
Summary: openstack overcloud status run on overcloud not deployed output needs cleanup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Emilien Macchi
QA Contact: Gurenko Alex
URL:
Whiteboard:
: 1632495 1635353 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-31 16:34 UTC by mlammon
Modified: 2019-11-07 14:01 UTC (History)
9 users (show)

Fixed In Version: python-tripleoclient-9.2.7-13.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-07 14:01:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1792637 None None None 2018-09-14 21:06:40 UTC
OpenStack gerrit 602753 'None' 'MERGED' 'Handle non-existant plan when getting deployment status' 2019-11-13 09:23:25 UTC
OpenStack gerrit 602754 'None' 'MERGED' 'Handle non-existant plan when getting deployment status' 2019-11-13 09:23:25 UTC
OpenStack gerrit 680760 'None' 'MERGED' 'overcloud status: return a message if no deployment is found' 2019-11-13 09:23:25 UTC
Red Hat Product Errata RHBA-2019:3794 None None None 2019-11-07 14:01:36 UTC

Description mlammon 2018-08-31 16:34:11 UTC
openstack overcloud status run on overcloud not deployed output needs cleanup


It seems in the case we know that their is no overcloud deployed we should suppress
these types of errors to something clean to the end user

Steps to reproduce

1. install undercloud
2. source /home/stack/stackrc
2. openstack overcloud status
  <obviously no overcloud yet deployed in this case>


Environment:
python2-mistralclient-3.7.0-0.20180731011525.f0ee48f.el7ost.noarch
python2-mistral-lib-1.0.0-0.20180730234322.d1ccfd0.el7ost.noarch
puppet-mistral-13.2.0-0.20180731214249.7dd767e.el7ost.noarch
instack-undercloud-9.2.1-0.20180803181448.be5fa97.el7ost.noarch
python-openstackclient-lang-3.16.0-0.20180801103525.f77ca68.el7ost.noarch
python2-openstackclient-3.16.0-0.20180801103525.f77ca68.el7ost.noarch


(undercloud) [stack@undercloud-0 ~]$ openstack overcloud status
Failed to run action [action_ex_id=e9827031-2cd1-4fe2-b50f-9765146b325d, action_cls='<class 'mistral.actions.action_factory.SwiftAction'>', attributes='{u'client_method_name': u'get_object'}', params='{u'obj': u'deployment_status.yaml', u'container': u'overcloud-messages'}']
 SwiftAction.get_object failed: Object GET failed: https://192.168.24.2:13808/v1/AUTH_008d17161a1c4e0ab1cb70e55dc31244/overcloud-messages/deployment_status.yaml 404 Not Found  [first 60 chars of response] <html><h1>Not Found</h1><p>The resource could not be found.<
Exception getting deployment status: Failed to run action [action_ex_id=e9827031-2cd1-4fe2-b50f-9765146b325d, action_cls='<class 'mistral.actions.action_factory.SwiftAction'>', attributes='{u'client_method_name': u'get_object'}', params='{u'obj': u'deployment_status.yaml', u'container': u'overcloud-messages'}']
 SwiftAction.get_object failed: Object GET failed: https://192.168.24.2:13808/v1/AUTH_008d17161a1c4e0ab1cb70e55dc31244/overcloud-messages/deployment_status.yaml 404 Not Found  [first 60 chars of response] <html><h1>Not Found</h1><p>The resource could not be found.<

Comment 1 Marius Cornea 2018-10-02 17:47:58 UTC
*** Bug 1635353 has been marked as a duplicate of this bug. ***

Comment 2 Marius Cornea 2018-10-02 17:48:49 UTC
The issue is showing when a plan different than 'overcloud' exists.

Comment 3 Beth White 2018-10-17 10:25:38 UTC
*** Bug 1632495 has been marked as a duplicate of this bug. ***

Comment 7 Artem Hrechanychenko 2018-12-13 09:17:16 UTC
openstack-tripleo-common-9.4.1-0.20181012010884.el7ost.noarch

(undercloud) [stack@undercloud-0 ~]$ openstack overcloud status
None


From user perspective side it's still not clear why I get None insted of clear output that there are not deployed overcloud.
So I decided to move it back to assigned state.

Comment 14 errata-xmlrpc 2019-11-07 14:01:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3794


Note You need to log in before you can comment on or make changes to this bug.