Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1624475 - Calico requires a role be added that runs stand-alone kube-proxy and DNS
Summary: Calico requires a role be added that runs stand-alone kube-proxy and DNS
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.10.z
Assignee: Ricardo Carrillo Cruz
QA Contact: Meng Bo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-08-31 17:54 UTC by Marc Curry
Modified: 2019-06-11 09:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-11 09:30:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github 9621 None None None 2018-08-31 17:54:44 UTC
Red Hat Product Errata RHBA-2019:0786 None None None 2019-06-11 09:30:59 UTC

Description Marc Curry 2018-08-31 17:54:44 UTC
Description of problem:
OCP 3.10 moved the default openshift-sdn network plugin implementation to daemonSets, and kube-proxy functionality was moved into the "sdn" daemonSet along with openshift-sdn and DNS. Calico still requires the kube-proxy to be loaded in the kubelet process space.

Version-Release number of selected component (if applicable):
3.10

How reproducible:
Every time.

Steps to Reproduce:
1.Deploy Calico + OpenShift 3.10.

Actual results:
kube-proxy and DNS are not started.

Expected results:
kube-proxy and DNS are started on the node when using Calico CNI plug-in.

Additional info:
$ openshift start network --disable=plugins --enable=proxy,dns

Comment 1 Casey Callendrello 2018-09-04 13:53:25 UTC
I believe this is fixed in https://github.com/openshift/openshift-ansible/pull/9878

Comment 4 shiyang.wang 2019-04-17 03:05:30 UTC
Sorry, attached to the wrong advisory move back to MODIFIED

Comment 8 errata-xmlrpc 2019-06-11 09:30:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0786


Note You need to log in before you can comment on or make changes to this bug.