Bug 1624906 - tempest verify-config ends with IndexError
Summary: tempest verify-config ends with IndexError
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z3
: 13.0 (Queens)
Assignee: Martin Kopec
QA Contact: Chandan Kumar
URL:
Whiteboard:
Depends On: 1557736
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-03 14:32 UTC by Martin Kopec
Modified: 2019-01-16 17:54 UTC (History)
8 users (show)

Fixed In Version: openstack-tempest-18.0.0-5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-16 17:53:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 591595 None master: MERGED tempest: Prevent verify-config from IndexError (Ia9abea77e3baeb9418cb1869cec2a159cdc9fd48) 2018-10-16 20:42:50 UTC
Red Hat Product Errata RHBA-2019:0088 None None None 2019-01-16 17:54:14 UTC

Description Martin Kopec 2018-09-03 14:32:21 UTC
Description of problem: 
tempest verify-config command ends with IndexError when volume-feature-enabled.api_extensions is an empty list.

Version-Release number of selected component (if applicable):
OSP: 13   
Puddle: 2018-03-02.2

How reproducible - 
Always

Steps to Reproduce:
1) Install OSP-13 (master branch).

2) Generate tempest.conf and specify volume.api_extensions as an empty list:

[volume-feature-enabled]
api_extensions =

3) Run verify-config:
(overcloud) [stack@undercloud-0 my_workspace]$ tempest verify-config -o ./etc/tempest.conf

Running config verification...

Traceback (most recent call last):
  File "/home/stack/tempest/tempest/cmd/verify_tempest_config.py", line 486, in take_action
    main(parsed_args)
  File "/home/stack/tempest/tempest/cmd/verify_tempest_config.py", line 458, in main
    results = verify_extensions(os, service, results)
  File "/home/stack/tempest/tempest/cmd/verify_tempest_config.py", line 286, in verify_extensions
    if extensions_opt[0] == 'all':
IndexError: list index out of range

Comment 22 errata-xmlrpc 2019-01-16 17:53:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0088


Note You need to log in before you can comment on or make changes to this bug.