Bug 1624972 - No GUI desktop
Summary: No GUI desktop
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: lightdm
Version: 29
Hardware: armhfp
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Alternative GTK desktop environments
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException RejectedBlocker
Depends On:
Blocks: ARMTracker F29BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2018-09-03 18:36 UTC by Robert Moskowitz
Modified: 2018-09-12 13:11 UTC (History)
11 users (show)

Fixed In Version: lightdm-1.28.0-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-11 12:43:36 UTC


Attachments (Terms of Use)

Description Robert Moskowitz 2018-09-03 18:36:45 UTC
Description of problem:

The Xfce desktop never starts.  Lighted screen only

Version-Release number of selected component (if applicable):

Fedora-Xfce-armhfp-29-20180903.n.0-sda on Cubieboard2

How reproducible:

Been this way since I started testing F29-Xfce

Steps to Reproduce:
1. Copy image to uSD card, specifying for a Cubieboard2
2. Connect Cubie to HDMI monitor, Kybd, Mouse, console TTY
3. Run screen on console to capture console log and login to console
4. Power up Cubie
5. "Started GSSAPI Proxy Daemon" is the last message on console and monitor before attempt to switch to GUI mode

Actual results:

Lighted screen with no response to kybd or mouse
See:

[  148.658848] alloc_contig_range: [74200, 749f8) PFNs busy
[  165.979868] bridge: filtering via arp/ip/ip6tables is no longer available by [  173.413278] alloc_contig_range: [74200, 74af8) PFNs busy
[  430.058044] alloc_contig_range: [74200, 74500) PFNs busy

messages on console.  Console is very slow to respond.

Expected results:

GUI starts up and whatever system initiation process runs on the Desktop.  I do not know what that will be, as I have yet to get a F29 initial desktop.

Additional info:

The same setup with Centos Gnome:

CentOS-Userland-7-armv7hl-generic-GNOME-1804-sda

Brings up the Gnome desktop.  I have not tried any other F29 desktop.

Comment 1 Robert Moskowitz 2018-09-03 23:23:02 UTC
I was getting ready to power off the system, but decided to look at /var/log/messages first.  Here is what I am seeing on the tail:

Sep  3 19:19:40 localhost audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-coredump@3947-8730-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Sep  3 19:19:40 localhost audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=lightdm comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Sep  3 19:19:40 localhost audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=lightdm comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Sep  3 19:19:40 localhost audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=lightdm comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Sep  3 19:19:40 localhost systemd-coredump[8733]: Removed old coredump core.Xorg.0.d94e69afc70440c9847fde160772fcbd.26233.1536009316000000.lz4.
Sep  3 19:19:40 localhost abrt-dump-journal-core[796]: Failed to obtain all required information from journald
Sep  3 19:19:40 localhost systemd[1]: lightdm.service: Main process exited, code=dumped, status=11/SEGV
Sep  3 19:19:40 localhost systemd[1]: lightdm.service: Failed with result 'core-dump'.
Sep  3 19:19:40 localhost systemd[1]: lightdm.service: Service RestartSec=100ms expired, scheduling restart.
Sep  3 19:19:40 localhost systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 1974.
Sep  3 19:19:40 localhost systemd[1]: Stopped Light Display Manager.
Sep  3 19:19:40 localhost systemd[1]: Starting Light Display Manager...
Sep  3 19:19:40 localhost systemd[1]: Started Light Display Manager.
Sep  3 19:19:40 localhost audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=lightdm comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Sep  3 19:19:40 localhost systemd-coredump[8733]: Process 8718 (lightdm) of user 0 dumped core.#012#012Stack trace of thread 8718:#012#0  0x00000000004ed0d0 seat_real_stop (lightdm)
Sep  3 19:19:43 localhost audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-coredump@3949-8750-0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

Comment 2 Kevin Fenzi 2018-09-04 02:11:45 UTC
Sounds like a crash in lightdm then. ;( Moving to there. 

Also, can you do: 

sudo journalctl -u lightdm -b -1 -l 

might pick up some more info on the crash...

Comment 3 leigh scott 2018-09-04 06:19:18 UTC
Post rpm -qa dbus\* , do you have dbus-1.12.10-2.fc29

Comment 4 leigh scott 2018-09-04 06:33:31 UTC
Also post the logs from /var/log/lightdm/

Comment 5 Robert Moskowitz 2018-09-04 14:45:22 UTC
journalctl -u lightdm -b -1 -l

(just some of the loops, as I have hours of these messages)

Sep 03 14:41:07 localhost systemd[1]: Starting Light Display Manager...
Sep 03 14:41:12 localhost systemd[1]: Started Light Display Manager.
Sep 03 14:41:15 localhost systemd[1]: lightdm.service: Main process exited, cod>
Sep 03 14:41:15 localhost systemd[1]: lightdm.service: Failed with result 'core>
Sep 03 14:41:16 localhost systemd[1]: lightdm.service: Service RestartSec=100ms>
Sep 03 14:41:16 localhost systemd[1]: lightdm.service: Scheduled restart job, r>
Sep 03 14:41:16 localhost systemd[1]: Stopped Light Display Manager.
Sep 03 14:41:16 localhost systemd[1]: Starting Light Display Manager...
Sep 03 14:41:17 localhost systemd[1]: Started Light Display Manager.
Sep 03 14:41:25 localhost systemd[1]: lightdm.service: Main process exited, cod>
Sep 03 14:41:25 localhost systemd[1]: lightdm.service: Failed with result 'core>
Sep 03 14:41:25 localhost systemd[1]: lightdm.service: Service RestartSec=100ms>
Sep 03 14:41:25 localhost systemd[1]: lightdm.service: Scheduled restart job, r>
Sep 03 14:41:25 localhost systemd[1]: Stopped Light Display Manager.
Sep 03 14:41:25 localhost systemd[1]: Starting Light Display Manager...
Sep 03 14:41:28 localhost systemd[1]: Started Light Display Manager.
Sep 03 14:41:32 localhost systemd[1]: lightdm.service: Main process exited, cod>
Sep 03 14:41:32 localhost systemd[1]: lightdm.service: Failed with result 'core>
Sep 03 14:41:32 localhost systemd[1]: lightdm.service: Service RestartSec=100ms>
Sep 03 14:41:32 localhost systemd[1]: lightdm.service: Scheduled restart job, r>
Sep 03 14:41:32 localhost systemd[1]: Stopped Light Display Manager.

rpm -qa dbus\*

dbus-tools-1.12.10-1.fc29.armv7hl
dbus-1.12.10-1.fc29.armv7hl
dbus-x11-1.12.10-1.fc29.armv7hl
dbus-common-1.12.10-1.fc29.noarch
dbus-daemon-1.12.10-1.fc29.armv7hl
dbus-glib-0.110-3.fc29.armv7hl
dbus-libs-1.12.10-1.fc29.armv7hl

This is what I get with the image.

And:

tail /var/log/lightdm/lightdm.log -n80
[+0.10s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.11s] DEBUG: Starting Light Display Manager 1.26.0, UID=0 PID=3073
[+0.11s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.11s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-backup-logs.conf
[+0.11s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
[+0.11s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-minimum-vt.conf
[+0.11s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-session-wrapper.conf
[+0.11s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-user-authority-in-system-dir.conf
[+0.11s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.11s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf
[+0.11s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.11s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.11s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.11s] DEBUG: Registered seat module local
[+0.11s] DEBUG: Registered seat module xremote
[+0.11s] DEBUG: Registered seat module unity
[+0.11s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.24s] DEBUG: Monitoring logind for seats
[+0.24s] DEBUG: New seat added from logind: seat0
[+0.24s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.24s] DEBUG: Seat seat0: Starting
[+0.24s] DEBUG: Seat seat0: Creating greeter session
[+0.24s] DEBUG: Seat seat0: Creating display server of type x
[+0.24s] DEBUG: posix_spawn avoided (fd close requested) 
[+0.26s] DEBUG: Using VT 1
[+0.26s] DEBUG: Seat seat0: Starting local X display on VT 1
[+0.26s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.26s] DEBUG: XServer 0: Writing X server authority to /var/run/lightdm/root/:0
[+0.26s] DEBUG: XServer 0: Launching X Server
[+0.43s] DEBUG: Launching process 3081: /usr/bin/X -core -noreset :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt1 -novtswitch -background none
[+0.43s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.43s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.43s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.47s] DEBUG: Loading users from org.freedesktop.Accounts

Comment 6 Robert Moskowitz 2018-09-04 14:50:38 UTC
(In reply to leigh scott from comment #3)
> Post rpm -qa dbus\* , do you have dbus-1.12.10-2.fc29

I tried a dnf update to see, and no dbus updates currently available beyond what I have.

But I am doing the update anyway and will reboot...

Comment 7 leigh scott 2018-09-04 15:12:00 UTC
(In reply to Robert Moskowitz from comment #6)
> (In reply to leigh scott from comment #3)
> > Post rpm -qa dbus\* , do you have dbus-1.12.10-2.fc29
> 
> I tried a dnf update to see, and no dbus updates currently available beyond

I asked because dbus-1.12.10-2.fc29 is known to be bad and was pulled from updates-testing

Comment 8 Robert Moskowitz 2018-09-04 17:48:00 UTC
After a dnf update, which took a long time, I powered down.  Powered back up and the console froze.  While the GUI session FINALLY went to the setup.  I set the root password, created my user account and finished the setup.  The console took off and I could log in as root.  Here is what was in the update:

================================================================================
 Package                    Arch    Version               Repository       Size
================================================================================
Upgrading:
 anaconda-core              armv7hl 29.24.2-1.fc29        updates-testing 2.0 M
 anaconda-gui               armv7hl 29.24.2-1.fc29        updates-testing 405 k
 anaconda-tui               armv7hl 29.24.2-1.fc29        updates-testing 166 k
 anaconda-widgets           armv7hl 29.24.2-1.fc29        updates-testing  96 k
 at-spi2-core               armv7hl 2.28.0-4.fc29         updates-testing 139 k
 audit                      armv7hl 3.0-0.4.20180831git0047a6c.fc29
                                                          updates-testing 204 k
 audit-libs                 armv7hl 3.0-0.4.20180831git0047a6c.fc29
                                                          updates-testing  96 k
 blivet-data                noarch  1:3.1.0-2.fc29        updates-testing  99 k
 dnf                        noarch  3.3.0-2.fc29          updates-testing 344 k
 dnf-data                   noarch  3.3.0-2.fc29          updates-testing  59 k
 dnf-yum                    noarch  4.0.3.3.0-2.fc29      updates-testing  62 k
 firewall-config            noarch  0.6.1-2.fc29          updates-testing 102 k
 firewalld                  noarch  0.6.1-2.fc29          updates-testing 408 k
 firewalld-filesystem       noarch  0.6.1-2.fc29          updates-testing  19 k
 fontconfig                 armv7hl 2.13.1-1.fc29         updates-testing 215 k
 ghostscript                armv7hl 9.23-7.fc29           updates-testing  40 k
 glib-networking            armv7hl 2.58.0-1.fc29         updates-testing 128 k
 glibc                      armv7hl 2.28-9.fc29           updates-testing 3.0 M
 glibc-all-langpacks        armv7hl 2.28-9.fc29           updates-testing  25 M
 glibc-common               armv7hl 2.28-9.fc29           updates-testing 665 k
 glibc-langpack-en          armv7hl 2.28-9.fc29           updates-testing 810 k
 hwdata                     noarch  0.315-1.fc29          updates-testing 1.5 M
 ibus                       armv7hl 1.5.19-3.fc29         updates-testing 6.0 M
 ibus-gtk2                  armv7hl 1.5.19-3.fc29         updates-testing  24 k
 ibus-gtk3                  armv7hl 1.5.19-3.fc29         updates-testing  24 k
 ibus-libs                  armv7hl 1.5.19-3.fc29         updates-testing 209 k
 ibus-setup                 noarch  1.5.19-3.fc29         updates-testing  62 k
 iproute                    armv7hl 4.18.0-3.fc29         updates-testing 490 k
 libdnf                     armv7hl 0.17.2-1.fc29         updates-testing 380 k
 libgs                      armv7hl 9.23-7.fc29           updates-testing 2.6 M
 libssh                     armv7hl 0.8.2-1.fc29          updates-testing 173 k
 libtool-ltdl               armv7hl 2.4.6-27.fc29         updates-testing  31 k
 lightdm                    armv7hl 1.28.0-1.fc29         updates-testing 189 k
 lightdm-gobject            armv7hl 1.28.0-1.fc29         updates-testing  53 k
 llvm-libs                  armv7hl 7.0.0-0.9.rc2.fc29    updates-testing  10 M
 mesa-dri-drivers           armv7hl 18.2.0~rc5-1.fc29     updates-testing 6.9 M
 mesa-filesystem            armv7hl 18.2.0~rc5-1.fc29     updates-testing  18 k
 mesa-libEGL                armv7hl 18.2.0~rc5-1.fc29     updates-testing  86 k
 mesa-libGL                 armv7hl 18.2.0~rc5-1.fc29     updates-testing 131 k
 mesa-libgbm                armv7hl 18.2.0~rc5-1.fc29     updates-testing  34 k
 mesa-libglapi              armv7hl 18.2.0~rc5-1.fc29     updates-testing  40 k
 nettle                     armv7hl 3.4-5.fc29            updates-testing 293 k
 openssh                    armv7hl 7.8p1-2.fc29          updates-testing 363 k
 openssh-askpass            armv7hl 7.8p1-2.fc29          updates-testing  18 k
 openssh-clients            armv7hl 7.8p1-2.fc29          updates-testing 448 k
 openssh-server             armv7hl 7.8p1-2.fc29          updates-testing 342 k
 pcre                       armv7hl 8.42-4.fc29           updates-testing 160 k
 pcre2                      armv7hl 10.31-11.fc29         updates-testing 202 k
 perl-PathTools             armv7hl 3.75-1.fc29           updates-testing  84 k
 python-unversioned-command noarch  2.7.15-8.fc29         updates-testing  13 k
 python2                    armv7hl 2.7.15-8.fc29         updates-testing  46 k
 python2-libs               armv7hl 2.7.15-8.fc29         updates-testing 5.6 M
 python3                    armv7hl 3.7.0-9.fc29          updates-testing  39 k
 python3-audit              armv7hl 3.0-0.4.20180831git0047a6c.fc29
                                                          updates-testing  66 k
 python3-blivet             noarch  1:3.1.0-2.fc29        updates-testing 856 k
 python3-dnf                noarch  3.3.0-2.fc29          updates-testing 423 k
 python3-firewall           noarch  0.6.1-2.fc29          updates-testing 324 k
 python3-hawkey             armv7hl 0.17.2-1.fc29         updates-testing  61 k
 python3-libdnf             armv7hl 0.17.2-1.fc29         updates-testing 403 k
 python3-libs               armv7hl 3.7.0-9.fc29          updates-testing 7.0 M
 python3-setools            armv7hl 4.1.1-13.fc29         updates-testing 397 k
 wget                       armv7hl 1.19.5-5.fc29         updates-testing 694 k
Installing dependencies:
 linux-atm-libs             armv7hl 2.5.1-21.fc29         fedora           35 k
Installing weak dependencies:
 iproute-tc                 armv7hl 4.18.0-3.fc29         updates-testing 355 k

Transaction Summary
================================================================================
Install   2 Packages
Upgrade  62 Packages

Total download size: 81 M
Is this ok [y/N]:

Perhaps when I have an image with all of these I can test again?  But why would any of the above fix lightdm?

Oh, system seemed sluggish at first.

2 SELinux errors reported.  First on Firewald and second on ebtables.

Comment 9 leigh scott 2018-09-04 19:15:34 UTC
(In reply to Robert Moskowitz from comment #8)
> After a dnf update, which took a long time, I powered down.  Powered back up
> and the console froze.  While the GUI session FINALLY went to the setup.  I
> set the root password, created my user account and finished the setup.  The
> console took off and I could log in as root.  Here is what was in the update:
> 
> =============================================================================
> ===
>  Package                    Arch    Version               Repository      
> Size
> =============================================================================
> ===
> Upgrading:
>  anaconda-core              armv7hl 29.24.2-1.fc29        updates-testing

>  lightdm                    armv7hl 1.28.0-1.fc29         updates-testing
> 189 k
>  lightdm-gobject            armv7hl 1.28.0-1.fc29         updates-testing 
> 53 k

> 
> Transaction Summary
> =============================================================================
> ===
> Install   2 Packages
> Upgrade  62 Packages
> 
> Total download size: 81 M
> Is this ok [y/N]:
> 
> Perhaps when I have an image with all of these I can test again?  But why
> would any of the above fix lightdm?
> 

Maybe the lightdm update :-)

https://bodhi.fedoraproject.org/updates/FEDORA-2018-03104b180d

Comment 10 Robert Moskowitz 2018-09-04 20:24:28 UTC
I was sooo focused on looking for dbus update, I totally missed the ligthdm update!   Good thing I went ahead with the update.


And this version is still not in the image:

https://kojipkgs.fedoraproject.org/compose/branched/Fedora-29-20180904.n.0/compose/Everything/armhfp/os/Packages/l/


[   ] lightdm-1.26.0-2.fc29.armv7hl.rpm            2018-07-26 15:41  197K  
[   ] lightdm-gobject-1.26.0-2.fc29.armv7hl.rpm    2018-07-26 15:41   56K  

So I would venture to say that we are blocked until this version makes it to the image?

Please let me know when it gets rolled into the image and I will do this test again.

Comment 11 Peter Robinson 2018-09-04 22:44:26 UTC
 
> Maybe the lightdm update :-)
> 
> https://bodhi.fedoraproject.org/updates/FEDORA-2018-03104b180d

Leigh: can we get this bug added to that update so it can go through the FE process?

Comment 12 Fedora Update System 2018-09-04 22:53:56 UTC
lightdm-1.28.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-03104b180d

Comment 13 Fedora Blocker Bugs Application 2018-09-05 08:13:52 UTC
Proposed as a Blocker for 29-beta by Fedora user pbrobinson using the blocker tracking app because:

 XFCE is a blocking desktop UX for ARM

Comment 14 leigh scott 2018-09-05 12:15:20 UTC
I Have looked at the issue closely and from the lightdm log it's was waiting for X.

The log normally looks like, lightdm launches X then waits for it to start.


[+0.02s] DEBUG: Launching process 995: /usr/bin/X -core -noreset :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt1 -novtswitch
[+0.02s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.02s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.03s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat
[+0.03s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.03s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.06s] DEBUG: posix_spawn avoided (automatic reaping requested) (fd close requested)

Once it gets the signal it starts lightdm-greeter
 
[+2.30s] DEBUG: Got signal 10 from process 995
[+2.30s] DEBUG: XServer 0: Got signal from X server :0
[+2.30s] DEBUG: XServer 0: Connecting to XServer :0
[+2.30s] DEBUG: Quitting Plymouth; retaining splash
[+2.30s] DEBUG: posix_spawn avoided (fd close requested) 
[+2.32s] DEBUG: posix_spawn avoided (fd close requested) (child_setup specified) 
[+2.32s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+2.32s] DEBUG: Session pid=1123: Started with service 'lightdm-greeter', username 'lightdm'
[+2.34s] DEBUG: Session pid=1123: Authentication complete with return value 0: Success
[+2.34s] DEBUG: Seat seat0: Session authenticated, running command
[+2.34s] DEBUG: Session pid=1123: Running command /usr/sbin/slick-greeter


Maybe mesa update fixed this, note the xorg coredump before any lightdm errors/warnings.


Sep  3 19:19:40 localhost systemd-coredump[8733]: Removed old coredump core.Xorg.0.d94e69afc70440c9847fde160772fcbd.26233.1536009316000000.lz4.
Sep  3 19:19:40 localhost abrt-dump-journal-core[796]: Failed to obtain all required information from journald
Sep  3 19:19:40 localhost systemd[1]: lightdm.service: Main process exited, code=dumped, status=11/SEGV
Sep  3 19:19:40 localhost systemd[1]: lightdm.service: Failed with result 'core-dump'.

Comment 15 Jeremy Linton 2018-09-05 18:48:25 UTC
The alloc_contig_range() issues sound suspiciously like:

https://bugzilla.redhat.com/show_bug.cgi?id=1387793

Comment 16 Robert Moskowitz 2018-09-05 19:40:45 UTC
(In reply to Jeremy Linton from comment #15)
> The alloc_contig_range() issues sound suspiciously like:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1387793

The messages stopped after the lightdm update.

I see them during the update:

  Upgrading        : python3-libdnf-0.17.2-1 [==================      ]  21/126[ 3754.331020] alloc_contig_range: [74200, 74500) PFNs busy
[ 4128.938864] alloc_contig_range: [74200, 74500) PFNs busy
[ 4162.074317] alloc_contig_range: [74200, 74500) PFNs busy
  Upgrading        : dnf-3.3.0-2.fc29.noarch [======================= ]  31/126[ 4777.089222] alloc_contig_range: [74200, 74500) PFNs busy
[ 4850.115660] alloc_contig_range: [74200, 74500) PFNs busy
  Upgrading        : libgs-9.23-7.fc29.armv7 [=====================   ]  34/126[ 5329.609523] alloc_contig_range: [74200, 74500) PFNs busy
[ 5719.840610] alloc_contig_range: [7384b, 7384c) PFNs busy
  Upgrading        : anaconda-gui-29.24.2-1. [=========               ]  44/126[ 5757.801371] alloc_contig_range: [74200, 74500) PFNs busy
[ 5794.662821] alloc_contig_range: [7384b, 7384c) PFNs busy


And then they stopped.

Comment 17 Adam Williamson 2018-09-07 23:52:53 UTC
+1 blocker if this prevents the stock ARM Xfce image from booting to a working desktop.

Comment 18 Chris Murphy 2018-09-08 21:19:57 UTC
+1 beta blocker: "XFCE is a blocking desktop UX for ARM"

Comment 19 Robert Moskowitz 2018-09-09 02:43:27 UTC
(In reply to Adam Williamson from comment #17)
> +1 blocker if this prevents the stock ARM Xfce image from booting to a
> working desktop.

I won't be available to test an image until Wednesday.

Comment 20 Adam Williamson 2018-09-10 19:08:35 UTC
Discussed at 2018-09-10 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-10/f29-blocker-review.2018-09-10-16.01.html . We received additional feedback from pwhalen. He has tested images on multiple ARM devices and not run into this issue, so this seems very hardware-specific, and thus we decided it does not qualify as a blocker. However, we think it is serious enough to be a freeze exception issue. pwhalen has also tested the new lightdm on multiple devices and found it works fine, so we have confidence that it should be safe to pull it through the freeze.

Comment 21 Fedora Update System 2018-09-11 12:43:36 UTC
lightdm-1.28.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Robert Moskowitz 2018-09-12 13:01:38 UTC
(In reply to Adam Williamson from comment #20)
> Discussed at 2018-09-10 blocker review meeting:
> https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2018-09-10/f29-
> blocker-review.2018-09-10-16.01.html . We received additional feedback from
> pwhalen. He has tested images on multiple ARM devices and not run into this
> issue, so this seems very hardware-specific, and thus we decided it does not
> qualify as a blocker. However, we think it is serious enough to be a freeze
> exception issue. pwhalen has also tested the new lightdm on multiple devices
> and found it works fine, so we have confidence that it should be safe to
> pull it through the freeze.

build Fedora-Xfce-armhfp-29-20180911.n.0-sda works on a Cubieboard2.  GUI comes up and setup runs before allwoing access to the GUI desktop.

So I am also saying that this image with lightdm-1.28.0-1.fc29 fixes teh problem.

thanks all

Comment 23 Peter Robinson 2018-09-12 13:11:40 UTC
> build Fedora-Xfce-armhfp-29-20180911.n.0-sda works on a Cubieboard2.  GUI
> comes up and setup runs before allwoing access to the GUI desktop.
> 
> So I am also saying that this image with lightdm-1.28.0-1.fc29 fixes teh
> problem.

Well there was also a new mesa and I believe Xorg in there so there was a couple of moving parts, either way good that it's now fixed.


Note You need to log in before you can comment on or make changes to this bug.