Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 1624975

Summary: SNAP 20- Creating content view with filters failing with RPM1008 error.
Product: Red Hat Satellite Reporter: maneesh verma <mverma>
Component: Content ViewsAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED DUPLICATE QA Contact:
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.4CC: jjansky
Target Milestone: Unspecified   
Target Release: Unused   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-09-06 20:15:08 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description maneesh verma 2018-09-03 18:38:37 UTC
Description of problem:

Creating Content View with filters fails to publish.


How reproducible:

Every time create a new content view with filters.


Steps to Reproduce:
1.Enable the Repository with On-Demand policy.
2.Create a content view with repository and filter enabled.
3. Publish a new version of the content view.

Actual results:

The publishing of content view fails with an error.

RPM1008: Checksum type "sha256" is not available for all units in the repository. Make sure those units have been downloaded.

Tried with the mutiple content view, if I remove the filter the content view published fine.

Expected results:

The content view should publish without any errors.

Repo used to create CV- 

RHEL7 Server repository.

Additional info:

      state: FAILED
      error_details:
      - traceback: |2
            File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 239, in process
              self._process_block(item=item)

            File "/usr/lib/python2.7/site-packages/pulp/plugins/util/publish_step.py", line 301, in _process_block
              self.process_main(item=item)

            File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/distributors/yum/publish.py", line 496, in process_main
              context.add_unit_metadata(unit)

            File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/distributors/yum/metadata/filelists.py", line 42, in add_unit_metadata
              self.metadata_file_handle.write(unit.render_filelists(self.checksum_type))

            File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/db/models.py", line 863, in render_filelists
              context = Context({'pkgid': self.get_or_calculate_and_save_checksum(checksumtype)})

            File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/db/models.py", line 258, in get_or_calculate_and_save_checksum
              checksumtype=checksumtype)
        error: Checksum type "sha256" is not available for all units in the repository.
          Make sure those units have been downloaded.
      details: ''
      num_failures: 1
      step_id: 220d560b-dc99-48ad-812f-89f693032a6a

Comment 1 Jan Jansky 2018-09-06 16:29:10 UTC
Same for me during betatesting.

satellite-6.4.0-13.el7sat.noarch

Comment 2 Brad Buckingham 2018-09-06 20:15:08 UTC

*** This bug has been marked as a duplicate of bug 1619680 ***