Bug 1625158 - [abrt] policycoreutils-devel: tab_change(): gui.py:1345:tab_change:AttributeError: 'SELinuxGui' object has no attribute 'mislabeled_files' [NEEDINFO]
Summary: [abrt] policycoreutils-devel: tab_change(): gui.py:1345:tab_change:AttributeE...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Lautrbach 👨
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:be0fc400ab0f93903d305937280...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-09-04 09:40 UTC by ep
Modified: 2019-01-23 02:28 UTC (History)
5 users (show)

Fixed In Version: policycoreutils-2.8-15.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-23 02:28:08 UTC
vmojzis: needinfo? (ep)


Attachments (Terms of Use)
File: backtrace (539 bytes, text/plain)
2018-09-04 09:40 UTC, ep
no flags Details
File: cgroup (331 bytes, text/plain)
2018-09-04 09:40 UTC, ep
no flags Details
File: cpuinfo (1.36 KB, text/plain)
2018-09-04 09:40 UTC, ep
no flags Details
File: environ (3.72 KB, text/plain)
2018-09-04 09:40 UTC, ep
no flags Details
File: mountinfo (5.37 KB, text/plain)
2018-09-04 09:40 UTC, ep
no flags Details
File: namespaces (129 bytes, text/plain)
2018-09-04 09:40 UTC, ep
no flags Details
File: open_fds (1.73 KB, text/plain)
2018-09-04 09:40 UTC, ep
no flags Details

Description ep 2018-09-04 09:40:19 UTC
Version-Release number of selected component:
policycoreutils-devel-2.8-1.fc28

Additional info:
reporter:       libreport-2.9.5
cmdline:        /usr/bin/python3 -Es /usr/bin/sepolicy gui
crash_function: tab_change
exception_type: AttributeError
executable:     /usr/bin/sepolicy
interpreter:    python3-3.6.6-1.fc28.x86_64
kernel:         4.17.19-200.fc28.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
gui.py:1345:tab_change:AttributeError: 'SELinuxGui' object has no attribute 'mislabeled_files'

Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/sepolicy/gui.py", line 1345, in tab_change
    self.show_mislabeled_files_only.set_visible(self.mislabeled_files)
AttributeError: 'SELinuxGui' object has no attribute 'mislabeled_files'

Local variables in innermost frame:
args: (<Gtk.RadioButton object at 0x7fe465335f78 (GtkRadioButton at 0x56094a9927b0)>,)
self: <sepolicy.gui.SELinuxGui object at 0x7fe46eef7630>

Comment 1 ep 2018-09-04 09:40:27 UTC
Created attachment 1480717 [details]
File: backtrace

Comment 2 ep 2018-09-04 09:40:29 UTC
Created attachment 1480718 [details]
File: cgroup

Comment 3 ep 2018-09-04 09:40:30 UTC
Created attachment 1480719 [details]
File: cpuinfo

Comment 4 ep 2018-09-04 09:40:33 UTC
Created attachment 1480720 [details]
File: environ

Comment 5 ep 2018-09-04 09:40:35 UTC
Created attachment 1480721 [details]
File: mountinfo

Comment 6 ep 2018-09-04 09:40:37 UTC
Created attachment 1480722 [details]
File: namespaces

Comment 7 ep 2018-09-04 09:40:38 UTC
Created attachment 1480723 [details]
File: open_fds

Comment 8 Vit Mojzis 🔒 2018-11-26 12:52:34 UTC
Thank you for reporting the issue.
Could you please provide the output of the following commands?

# sestatus

# dnf list "selinux-policy*"


Also, it would help if you could specify under what circumstances the traceback appeared (a reproducer would be ideal), since I failed to reproduce the issue.

Comment 9 Fedora Update System 2019-01-21 20:51:15 UTC
policycoreutils-2.8-15.fc29 libselinux-2.8-6.fc29 libsepol-2.8-3.fc29 libsemanage-2.8-8.fc29 checkpolicy-2.8-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-16fd3acb03

Comment 10 Fedora Update System 2019-01-22 03:04:03 UTC
checkpolicy-2.8-3.fc29, libselinux-2.8-6.fc29, libsemanage-2.8-8.fc29, libsepol-2.8-3.fc29, policycoreutils-2.8-15.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-16fd3acb03

Comment 11 Fedora Update System 2019-01-23 02:28:08 UTC
checkpolicy-2.8-3.fc29, libselinux-2.8-6.fc29, libsemanage-2.8-8.fc29, libsepol-2.8-3.fc29, policycoreutils-2.8-15.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.